# Elasticsearch upgrade 5.3 to 5.5.2 failing to restart

**URL:** <https://discuss.elastic.co/t/elasticsearch-upgrade-5-3-to-5-5-2-failing-to-restart/99265>\
**Category:** Elasticsearch\
**Created:** [September 4, 2017, 9:32am UTC](https://discuss.elastic.co/t/elasticsearch-upgrade-5-3-to-5-5-2-failing-to-restart/99265 "2017-09-04T09:32:47Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![alessandro](https://avatars.discourse-cdn.com/v4/letter/a/ac91a4/32.png) [@alessandro](https://discuss.elastic.co/u/alessandro)\
**Post date:** [September 4, 2017, 9:32am UTC](https://discuss.elastic.co/t/elasticsearch-upgrade-5-3-to-5-5-2-failing-to-restart/99265/1 "2017-09-04T09:32:47Z")

</div>

Hi,

I am currently upgrading Elasticsearch from 5.3.0 to 5.5.2 and doing it as rolling upgrade on a server with Debian Linux.

After updating /bin, /lib and /modules directories for Elasticsearch, the elasticsearch service is failing to restart and I am getting the following messages

> alessandro@apollo-elk-server-staging:/var/lib/elk/elk-config/elasticsearch$ sudo service elasticsearch restart  
> alessandro@apollo-elk-server-staging:/var/lib/elk/elk-config/elasticsearch$ sudo service elasticsearch status  
> ● elasticsearch.service - Elasticsearch  
> Loaded: loaded (/etc/systemd/system/elasticsearch.service; enabled)  
> Active: active (running) since Mon 2017-09-04 09:17:28 UTC; 1s ago  
> Main PID: 14608 (java)  
> CGroup: /system.slice/elasticsearch.service  
> └─14608 /usr/bin/java -Xms4g -Xmx4g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+Dis...  
> Sep 04 09:17:28 apollo-elk-server-staging systemd[1]: Started Elasticsearch.  
> Sep 04 09:17:28 apollo-elk-server-staging elasticsearch[14608]: Java HotSpot(TM) 64-Bit Server VM warning: Insufficient space for shared memory file:  
> Sep 04 09:17:28 apollo-elk-server-staging elasticsearch[14608]: 14619  
> Sep 04 09:17:28 apollo-elk-server-staging elasticsearch[14608]: Try using the -Djava.io.tmpdir= option to select an alternate temp location.  
> Sep 04 09:17:28 apollo-elk-server-staging elasticsearch[14608]: Java HotSpot(TM) 64-Bit Server VM warning: Insufficient space for shared memory file:  
> Sep 04 09:17:28 apollo-elk-server-staging elasticsearch[14608]: 14608  
> Sep 04 09:17:28 apollo-elk-server-staging elasticsearch[14608]: Try using the -Djava.io.tmpdir= option to select an alternate temp location.  
> alessandro@apollo-elk-server-staging:/var/lib/elk/elk-config/elasticsearch$ sudo service elasticsearch status  
> ● elasticsearch.service - Elasticsearch  
> Loaded: loaded (/etc/systemd/system/elasticsearch.service; enabled)  
> Active: activating (auto-restart) (Result: exit-code) since Mon 2017-09-04 09:18:39 UTC; 9s ago  
> Process: 14786 ExecStart=/var/lib/elk/elk-config/elasticsearch/bin/elasticsearch (code=exited, status=1/FAILURE)  
> Main PID: 14786 (code=exited, status=1/FAILURE)

I see there is an issue with the temp directory for the JVM but I don know how to solve it.  
Does anybody know how I can solve this issue?

Thanks in advance, Alessandro

---

<div class="post-metadata">

**Author:** ![alessandro](https://avatars.discourse-cdn.com/v4/letter/a/ac91a4/32.png) [@alessandro](https://discuss.elastic.co/u/alessandro)\
**Post date:** [September 4, 2017, 1:47pm UTC](https://discuss.elastic.co/t/elasticsearch-upgrade-5-3-to-5-5-2-failing-to-restart/99265/2 "2017-09-04T13:47:24Z")

</div>

Solved,

basically the disk was nearly full and Elasticsearch didn't have enough space for a restart and I simply had to create some space.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 2, 2017, 1:47pm UTC](https://discuss.elastic.co/t/elasticsearch-upgrade-5-3-to-5-5-2-failing-to-restart/99265/3 "2017-10-02T13:47:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
