# Elasticsearch v5.16.5 and v6.7.2 will not start

**URL:** <https://discuss.elastic.co/t/elasticsearch-v5-16-5-and-v6-7-2-will-not-start/179619>\
**Category:** Elasticsearch\
**Created:** [May 4, 2019, 12:16pm UTC](https://discuss.elastic.co/t/elasticsearch-v5-16-5-and-v6-7-2-will-not-start/179619 "2019-05-04T12:16:58Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![s1k3s](https://avatars.discourse-cdn.com/v4/letter/s/47e85d/32.png) [@s1k3s](https://discuss.elastic.co/u/s1k3s)\
**Post date:** [May 4, 2019, 12:16pm UTC](https://discuss.elastic.co/t/elasticsearch-v5-16-5-and-v6-7-2-will-not-start/179619/1 "2019-05-04T12:16:58Z")

</div>

```
$ ./elasticsearch --version
Version: 6.7.2, Build: default/tar/56c6e48/2019-04-29T09:05:50.290371Z, JVM: 1.8.0_191

$ java --version
openjdk version "1.8.0_191"
OpenJDK Runtime Environment (build 1.8.0_191-8u191-b12-2ubuntu0.18.04.1-b12)
OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)

$ ./bin/elasticsearch
java.security.policy: error adding Entry:
	java.net.MalformedURLException: no protocol: ${codebase.netty-common}
java.security.policy: error adding Entry:
	java.net.MalformedURLException: no protocol: ${codebase.netty-transport}
java.security.policy: error adding Entry:
...
java.security.policy: error adding Entry:
	java.net.MalformedURLException: no protocol: ${codebase.lucene-misc}
java.security.policy: error adding Entry:
	java.net.MalformedURLException: no protocol: ${codebase.plugin-classloader}
[2019-05-04T14:52:54,116][INFO][o.e.e.NodeEnvironment] [FUL-kjG] using [1] data paths, mounts [[/ (/dev/sda1)]], net usable_space [168.3gb], net total_space [219gb], types [ext4]
[2019-05-04T14:52:54,119][INFO][o.e.e.NodeEnvironment] [FUL-kjG] heap size [989.8mb], compressed ordinary object pointers [true]
[2019-05-04T14:52:54,120][INFO][o.e.n.Node] [FUL-kjG] node name derived from node ID [FUL-kjGcQ8u_FIzB4ZHrwg]; set [node.name] to override
[2019-05-04T14:52:54,120][INFO][o.e.n.Node] [FUL-kjG] version[6.7.2], pid[18372], build[default/tar/56c6e48/2019-04-29T09:05:50.290371Z], OS[Linux/4.15.0-48-generic/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/1.8.0_191/25.191-b12]
[2019-05-04T14:52:54,120][INFO][o.e.n.Node] [FUL-kjG] JVM arguments [-Xms1g, -Xmx1g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Djava.io.tmpdir=/tmp/elasticsearch-6393734556425414657, -XX:+HeapDumpOnOutOfMemoryError, -XX:HeapDumpPath=data, -XX:ErrorFile=logs/hs_err_pid%p.log, -XX:+PrintGCDetails, -XX:+PrintGCDateStamps, -XX:+PrintTenuringDistribution, -XX:+PrintGCApplicationStoppedTime, -Xloggc:logs/gc.log, -XX:+UseGCLogFileRotation, -XX:NumberOfGCLogFiles=32, -XX:GCLogFileSize=64m, -Des.path.home=/home/me/devbox/elasticsearch-6.7.2, -Des.path.conf=/home/me/devbox/elasticsearch-6.7.2/config, -Des.distribution.flavor=default, -Des.distribution.type=tar]
[2019-05-04T14:52:54,180][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [FUL-kjG] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.security.AccessControlException: access denied ("java.lang.RuntimePermission" "createClassLoader")
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-
...

```

I have set the JAVA\_HOME environment variable to point to my jdk installation. What am I missing here? Am I using a not supported JDK version?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [May 4, 2019, 12:41pm UTC](https://discuss.elastic.co/t/elasticsearch-v5-16-5-and-v6-7-2-will-not-start/179619/2 "2019-05-04T12:41:14Z")

</div>

From which url did you download the distribution ?

---

<div class="post-metadata">

**Author:** ![s1k3s](https://avatars.discourse-cdn.com/v4/letter/s/47e85d/32.png) [@s1k3s](https://discuss.elastic.co/u/s1k3s)\
**Post date:** [May 4, 2019, 12:50pm UTC](https://discuss.elastic.co/t/elasticsearch-v5-16-5-and-v6-7-2-will-not-start/179619/3 "2019-05-04T12:50:46Z")

</div>

From [https://www.elastic.co/downloads/past-releases/elasticsearch-6-7-2](https://www.elastic.co/downloads/past-releases/elasticsearch-6-7-2)  
I used the [MACOS/LINUX](https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-6.7.2.tar.gz) link.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [May 4, 2019, 2:50pm UTC](https://discuss.elastic.co/t/elasticsearch-v5-16-5-and-v6-7-2-will-not-start/179619/4 "2019-05-04T14:50:15Z")

</div>

I just tried this version locally and everything is ok on my side.  
I'm super surprised by this part:

```auto
$ ./bin/elasticsearch
java.security.policy: error adding Entry:
	java.net.MalformedURLException: no protocol: ${codebase.netty-common}
java.security.policy: error adding Entry:
	java.net.MalformedURLException: no protocol: ${codebase.netty-transport}
java.security.policy: error adding Entry:
...
java.security.policy: error adding Entry:
	java.net.MalformedURLException: no protocol: ${codebase.lucene-misc}
java.security.policy: error adding Entry:
	java.net.MalformedURLException: no protocol: ${codebase.plugin-classloader}

```

Wondering if you changed anything else.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 1, 2019, 2:50pm UTC](https://discuss.elastic.co/t/elasticsearch-v5-16-5-and-v6-7-2-will-not-start/179619/5 "2019-06-01T14:50:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
