# Elasticsearch will not start, no logs, (code=exited, status=1/FAILURE)

**URL:** https://discuss.elastic.co/t/elasticsearch-will-not-start-no-logs-code-exited-status-1-failure/135797
**Category:** Elasticsearch
**Created:** [June 13, 2018, 9:37pm UTC](https://discuss.elastic.co/t/elasticsearch-will-not-start-no-logs-code-exited-status-1-failure/135797 "2018-06-13T21:37:20Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Guanilo](https://avatars.discourse-cdn.com/v4/letter/g/53a042/32.png) [@Guanilo](https://discuss.elastic.co/u/Guanilo)
#### Post date: [June 13, 2018, 9:37pm UTC](https://discuss.elastic.co/t/elasticsearch-will-not-start-no-logs-code-exited-status-1-failure/135797/1 "2018-06-13T21:37:20Z")

</div>

Fresh ES 6.2.4 install on RHE 7.4, install is performed by downloading rpms to local machine, ftping rpms (and GPG key) to server), then yum localinstall. All values are default, excepting one:

> ```
> /etc/sysconfig/elasticsearch
> JAVA_HOME=/usr/openv/java/jre/bin
> 
> ```

On trying to start the process with systemctl, the returned status is somewhat opaque and no log files are created.

`# systemctl start elasticsearch`  
`# systemctl status elasticsearch`  
`● elasticsearch.service - Elasticsearch`  
` Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: disabled)`  
` Active: failed (Result: exit-code) since Wed 2018-06-13 21:16:51 GMT; 18s ago`  
` Docs: http://www.elastic.co`  
` Process: 35780 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)`  
` Main PID: 35780 (code=exited, status=1/FAILURE)`  
` `  
` Jun 13 21:16:51 <server name> systemd[1]: Started Elasticsearch.`  
` Jun 13 21:16:51 <server name> systemd[1]: Starting Elasticsearch...`  
` Jun 13 21:16:51 <server name> systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE`  
` Jun 13 21:16:51 <server name> systemd[1]: Unit elasticsearch.service entered failed state.`  
` Jun 13 21:16:51 <server name> systemd[1]: elasticsearch.service failed.`  
` #`  
` # ls -laF /var/log/elasticsearch/`  
` total 4`  
` drwxr-x---. 2 elasticsearch elasticsearch 6 Apr 12 20:39 ./`  
` drwxr-xr-x. 13 root root 4096 Jun 13 19:54 ../`  
` #`

For a prior installation, things seem to be working properly. This installation fails with neither error message nor log files. Suggestions would be welcomed.

Config files will be posted in follow on update (size limited)

---

<div class="post-metadata">

### Author: ![Guanilo](https://avatars.discourse-cdn.com/v4/letter/g/53a042/32.png) [@Guanilo](https://discuss.elastic.co/u/Guanilo)
#### Post date: [June 13, 2018, 9:41pm UTC](https://discuss.elastic.co/t/elasticsearch-will-not-start-no-logs-code-exited-status-1-failure/135797/2 "2018-06-13T21:41:55Z")

</div>

# /etc/sysconfig/elasticsearch:

`################################`  
`# Elasticsearch`  
`################################`  
``  
`# Elasticsearch home directory`  
`#ES_HOME=/usr/share/elasticsearch`  
``  
`# Elasticsearch Java path`  
`JAVA_HOME=/usr/openv/java/jre/bin`  
``  
`# Elasticsearch configuration directory`  
`ES_PATH_CONF=/etc/elasticsearch`  
``  
`# Elasticsearch PID directory`  
`#PID_DIR=/var/run/elasticsearch`  
``  
`# Additional Java OPTS`  
`#ES_JAVA_OPTS=`  
``  
`# Configure restart on package upgrade (true, every other setting will lead to not restarting)`  
`#RESTART_ON_UPGRADE=true`  
``  
`################################`  
`# Elasticsearch service`  
`################################`  
``  
`# SysV init.d`  
`#`  
`# The number of seconds to wait before checking if Elasticsearch started successfully as a daemon process`  
`ES_STARTUP_SLEEP_TIME=5`  
``  
`################################`  
`# System properties`  
`################################`  
``  
`# Specifies the maximum file descriptor number that can be opened by this process`  
`# When using Systemd, this setting is ignored and the LimitNOFILE defined in`  
`# /usr/lib/systemd/system/elasticsearch.service takes precedence`  
`#MAX_OPEN_FILES=65536`  
``  
`# The maximum number of bytes of memory that may be locked into RAM`  
`# Set to "unlimited" if you use the 'bootstrap.memory_lock: true' option`  
`# in elasticsearch.yml.`  
`# When using systemd, LimitMEMLOCK must be set in a unit file such as`  
`# /etc/systemd/system/elasticsearch.service.d/override.conf.`  
`#MAX_LOCKED_MEMORY=unlimited`  
``  
`# Maximum number of VMA (Virtual Memory Areas) a process can own`  
`# When using Systemd, this setting is ignored and the 'vm.max_map_count'`  
`# property is set at boot time in /usr/lib/sysctl.d/elasticsearch.conf`  
`#MAX_MAP_COUNT=262144`

# elasticsearch.yml

`# ======================== Elasticsearch Configuration =========================`  
`#`  
`# NOTE: Elasticsearch comes with reasonable defaults for most settings.`  
`# Before you set out to tweak and tune the configuration, make sure you`  
`# understand what are you trying to accomplish and the consequences.`  
`#`  
`# The primary way of configuring a node is via this file. This template lists`  
`# the most important settings you may want to configure for a production cluster.`  
`#`  
`# Please consult the documentation for further information on configuration options:`  
`# https://www.elastic.co/guide/en/elasticsearch/reference/index.html`  
`#`  
`# ---------------------------------- Cluster -----------------------------------`  
`#`  
`# Use a descriptive name for your cluster:`  
`#`  
`#cluster.name: my-application`  
`#`  
`# ------------------------------------ Node ------------------------------------`  
`#`  
`# Use a descriptive name for the node:`  
`#`  
`#node.name: node-1`  
`#`  
`# Add custom attributes to the node:`  
`#`  
`#node.attr.rack: r1`  
`#`  
`# ----------------------------------- Paths ------------------------------------`  
`#`  
`# Path to directory where to store the data (separate multiple locations by comma):`  
`#`  
`path.data: /var/lib/elasticsearch`  
`#`  
`# Path to log files:`  
`#`  
`path.logs: /var/log/elasticsearch`  
`#`  
`# ----------------------------------- Memory -----------------------------------`  
`#`  
`# Lock the memory on startup:`  
`#`  
`#bootstrap.memory_lock: true`  
`#`  
`# Make sure that the heap size is set to about half the memory available`  
`# on the system and that the owner of the process is allowed to use this`  
`# limit.`  
`#`  
`# Elasticsearch performs poorly when the system is swapping the memory.`  
`#`  
`# ---------------------------------- Network -----------------------------------`  
`#`  
`# Set the bind address to a specific IP (IPv4 or IPv6):`  
`#`  
`#network.host: 192.168.0.1`  
`#`  
`# Set a custom port for HTTP:`  
`#`  
`#http.port: 9200`  
`#`  
`# For more information, consult the network module documentation.`  
`#`  
`# --------------------------------- Discovery ----------------------------------`  
`#`  
`# Pass an initial list of hosts to perform discovery when new node is started:`  
`# The default list of hosts is ["127.0.0.1", "[::1]"]`  
`#`  
`#discovery.zen.ping.unicast.hosts: ["host1", "host2"]`  
`#`  
`# Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):`  
`#`  
`#discovery.zen.minimum_master_nodes:`  
`#`  
`# For more information, consult the zen discovery module documentation.`  
`#`  
`# ---------------------------------- Gateway -----------------------------------`  
`#`  
`# Block initial recovery after a full cluster restart until N nodes are started:`  
`#`  
`#gateway.recover_after_nodes: 3`  
`#`  
`# For more information, consult the gateway module documentation.`  
`#`  
`# ---------------------------------- Various -----------------------------------`  
`#`  
`# Require explicit names when deleting indices:`  
`#`  
`#action.destructive_requires_name: true`

---

<div class="post-metadata">

### Author: ![Guanilo](https://avatars.discourse-cdn.com/v4/letter/g/53a042/32.png) [@Guanilo](https://discuss.elastic.co/u/Guanilo)
#### Post date: [June 13, 2018, 9:43pm UTC](https://discuss.elastic.co/t/elasticsearch-will-not-start-no-logs-code-exited-status-1-failure/135797/3 "2018-06-13T21:43:52Z")

</div>

# /usr/lib/systemd/system/elasticsearch.service

`[Unit]`  
`Description=Elasticsearch`  
`Documentation=http://www.elastic.co`  
`Wants=network-online.target`  
`After=network-online.target`  
``  
`[Service]`  
`RuntimeDirectory=elasticsearch`  
`Environment=ES_HOME=/usr/share/elasticsearch`  
`Environment=ES_PATH_CONF=/etc/elasticsearch`  
`Environment=PID_DIR=/var/run/elasticsearch`  
`EnvironmentFile=-/etc/sysconfig/elasticsearch`  
``  
`WorkingDirectory=/usr/share/elasticsearch`  
``  
`User=elasticsearch`  
`Group=elasticsearch`  
``  
`ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet`  
``  
`# StandardOutput is configured to redirect to journalctl since`  
`# some error messages may be logged in standard output before`  
`# elasticsearch logging system is initialized. Elasticsearch`  
`# stores its logs in /var/log/elasticsearch and does not use`  
`# journalctl by default. If you also want to enable journalctl`  
`# logging, you can simply remove the "quiet" option from ExecStart.`  
`StandardOutput=journal`  
`StandardError=inherit`  
``  
`# Specifies the maximum file descriptor number that can be opened by this process`  
`LimitNOFILE=65536`  
``  
`# Specifies the maximum number of processes`  
`LimitNPROC=4096`  
``  
`# Specifies the maximum size of virtual memory`  
`LimitAS=infinity`  
``  
`# Specifies the maximum file size`  
`LimitFSIZE=infinity`  
``  
`# Disable timeout logic and wait until process is stopped`  
`TimeoutStopSec=0`  
``  
`# SIGTERM signal is used to stop the Java process`  
`KillSignal=SIGTERM`  
``  
`# Send the signal only to the JVM rather than its control group`  
`KillMode=process`  
``  
`# Java process is never killed`  
`SendSIGKILL=no`  
``  
`# When a JVM receives a SIGTERM signal it exits with code 143`  
`SuccessExitStatus=143`  
``  
`[Install]`  
`WantedBy=multi-user.target`  
``  
`# Built for distribution-6.2.4 (distribution`

---

<div class="post-metadata">

### Author: ![Guanilo](https://avatars.discourse-cdn.com/v4/letter/g/53a042/32.png) [@Guanilo](https://discuss.elastic.co/u/Guanilo)
#### Post date: [June 14, 2018, 3:16pm UTC](https://discuss.elastic.co/t/elasticsearch-will-not-start-no-logs-code-exited-status-1-failure/135797/4 "2018-06-14T15:16:57Z")

</div>

Solved. Problem was that the JAVA\_HOME setting in /etc/sysconfig/elasticsearch was pointing too far down the Java path. Should have been /usr/openv/java

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 12, 2018, 3:24pm UTC](https://discuss.elastic.co/t/elasticsearch-will-not-start-no-logs-code-exited-status-1-failure/135797/5 "2018-07-12T15:24:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
