# Elasticsearch with Jetty - Fails while running as a windows service using elasticsearch-servicewrapper

**URL:** https://discuss.elastic.co/t/elasticsearch-with-jetty-fails-while-running-as-a-windows-service-using-elasticsearch-servicewrapper/8609
**Category:** Elasticsearch
**Created:** [August 2, 2012, 2:38pm UTC](https://discuss.elastic.co/t/elasticsearch-with-jetty-fails-while-running-as-a-windows-service-using-elasticsearch-servicewrapper/8609 "2012-08-02T14:38:30Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Parag\_Dere](https://avatars.discourse-cdn.com/v4/letter/p/e47774/32.png) [@Parag\_Dere](https://discuss.elastic.co/u/Parag_Dere)
#### Post date: [August 2, 2012, 2:38pm UTC](https://discuss.elastic.co/t/elasticsearch-with-jetty-fails-while-running-as-a-windows-service-using-elasticsearch-servicewrapper/8609/1 "2012-08-02T14:38:30Z")

</div>

Hi all,  
I get an intermittent error while trying to run ES as a service and when  
Jetty is enabled.  
Sometimes it works fine, and sometimes it fails.  
I tried to Apache Commons Daemon and it gives me no problems.  
Only when i use ES as a service using servicewrapper that it fails..

The stacktrace is pasted below:  
[2012-08-01 07:15:56,398][WARN][bootstrap] jvm uses the  
client vm, make sure to run `java` with the server vm for best performance  
by adding `-server` to the command line  
[2012-08-01 07:15:56,403][INFO][node] [Warhawk]  
{0.19.8}[3124]: initializing ...  
[2012-08-01 07:15:56,484][INFO][plugins] [Warhawk]  
loaded [jetty], sites [bigdesk, head]  
[2012-08-01 07:15:59,555][INFO][node] [Warhawk]  
{0.19.8}[3124]: initialized  
[2012-08-01 07:15:59,555][INFO][node] [Warhawk]  
{0.19.8}[3124]: starting ...  
[2012-08-01 07:15:59,803][INFO][transport] [Warhawk]  
bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address {inet[/  
192.168.2.2:9300]}  
[2012-08-01 07:16:03,181][INFO][cluster.service] [Warhawk]  
new\_master [Warhawk][V8EIJFCMR-K4NXFSXGmwMw][inet[/192.168.2.2:9300]],  
reason: zen-disco-join (elected\_as\_master)  
[2012-08-01 07:16:03,255][INFO][discovery] [Warhawk]  
PaRaG/V8EIJFCMR-K4NXFSXGmwMw  
[2012-08-01 07:16:03,677][INFO][org.eclipse.jetty.server.Server] [Warhawk]  
jetty-8.1.4.v20120524  
[2012-08-01 07:16:03,763][INFO  
][org.eclipse.jetty.server.AbstractConnector] [Warhawk] Started  
SelectChannelConnector@0.0.0.0:9200  
[2012-08-01 07:16:03,906][INFO][gateway] [Warhawk]  
recovered [5] indices into cluster\_state  
[2012-08-01 07:16:04,027][INFO][http] [Warhawk]  
bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address {inet[/  
192.168.2.2:9200]}  
[2012-08-01 07:16:04,027][INFO][node] [Warhawk]  
{0.19.8}[3124]: started

soon afterwards, i restarted the service and then i got the error again.

[2012-08-01 07:19:41,747][WARN][bootstrap] jvm uses the  
client vm, make sure to run `java` with the server vm for best performance  
by adding `-server` to the command line  
[2012-08-01 07:19:41,751][INFO][node] [Link]  
{0.19.8}[1196]: initializing ...  
[2012-08-01 07:19:41,766][INFO][plugins] [Link] loaded  
[jetty], sites [bigdesk, head]  
[2012-08-01 07:19:44,384][INFO][node] [Link]  
{0.19.8}[1196]: initialized  
[2012-08-01 07:19:44,384][INFO][node] [Link]  
{0.19.8}[1196]: starting ...  
[2012-08-01 07:19:44,643][INFO][transport] [Link]  
bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address {inet[/  
192.168.2.2:9300]}  
[2012-08-01 07:19:48,074][INFO][cluster.service] [Link]  
new\_master [Link][gCJHFIApQSmnxugHpLHe7g][inet[/192.168.2.2:9300]], reason:  
zen-disco-join (elected\_as\_master)  
[2012-08-01 07:19:48,099][INFO][discovery] [Link]  
PaRaG/gCJHFIApQSmnxugHpLHe7g  
[2012-08-01 07:19:48,304][INFO][org.eclipse.jetty.server.Server] [Link]  
jetty-8.1.4.v20120524  
[2012-08-01 07:19:48,369][INFO  
][org.eclipse.jetty.server.AbstractConnector] [Link] Started  
SelectChannelConnector@0.0.0.0:9200  
[2012-08-01 07:19:48,631][INFO][http] [Link]  
bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address {inet[/  
192.168.2.2:9200]}  
[2012-08-01 07:19:48,631][INFO][node] [Link]  
{0.19.8}[1196]: started  
[2012-08-01 07:19:48,756][INFO][gateway] [Link]  
recovered [5] indices into cluster\_state  
[2012-08-01 07:20:00,736][WARN  
][org.eclipse.jetty.server.AbstractHttpConnection] [Link] /  
java.lang.NoClassDefFoundError:  
com/sonian/elasticsearch/http/jetty/JettyHttpServerRestRequest  
at  
com.sonian.elasticsearch.http.jetty.handler.JettyHttpServerTransportHandler.handle(JettyHttpServerTransportHandler.java:66)  
at  
org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:499)  
at  
org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)  
at org.eclipse.jetty.server.Server.handle(Server.java:350)  
at  
org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:454)  
at  
org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:890)  
at  
org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:944)  
at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:630)  
at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:230)  
at  
org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:77)  
at  
org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:620)  
at  
org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:46)  
at  
org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:603)  
at  
org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:538)  
at java.lang.Thread.run(Unknown Source)  
Caused by: java.lang.ClassNotFoundException:  
com.sonian.elasticsearch.http.jetty.JettyHttpServerRestRequest  
at java.net.URLClassLoader$1.run(Unknown Source)  
at java.net.URLClassLoader$1.run(Unknown Source)  
at java.security.AccessController.doPrivileged(Native Method)  
at java.net.URLClassLoader.findClass(Unknown Source)  
at java.lang.ClassLoader.loadClass(Unknown Source)  
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)  
at java.lang.ClassLoader.loadClass(Unknown Source)  
... 15 more  
[2012-08-01 07:20:03,023][WARN  
][org.eclipse.jetty.server.AbstractHttpConnection] [Link] /  
java.lang.NoClassDefFoundError:  
com/sonian/elasticsearch/http/jetty/JettyHttpServerRestRequest  
at  
com.sonian.elasticsearch.http.jetty.handler.JettyHttpServerTransportHandler.handle(JettyHttpServerTransportHandler.java:66)  
at  
org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:499)  
at  
org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)  
at org.eclipse.jetty.server.Server.handle(Server.java:350)  
at  
org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:454)  
at  
org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:890)  
at  
org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:944)  
at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:630)  
at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:230)  
at  
org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:77)  
at  
org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:620)  
at  
org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:46)  
at  
org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:603)  
at  
org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:538)  
at java.lang.Thread.run(Unknown Source)

Any body else having similar problems ?

regards,  
-Parag

---

<div class="post-metadata">

### Author: ![Ivan](https://avatars.discourse-cdn.com/v4/letter/i/df788c/32.png) [@Ivan](https://discuss.elastic.co/u/Ivan)
#### Post date: [August 3, 2012, 4:41pm UTC](https://discuss.elastic.co/t/elasticsearch-with-jetty-fails-while-running-as-a-windows-service-using-elasticsearch-servicewrapper/8609/2 "2012-08-03T16:41:48Z")

</div>

Are you using the Jetty plugin? [GitHub - sonian/elasticsearch-jetty](https://github.com/sonian/elasticsearch-jetty)

Judging by the NoClassDefFoundError error, you probably do not have it  
installed on every machine.

--  
Ivan

On Thu, Aug 2, 2012 at 7:38 AM, Parag Dere [paragdere@gmail.com](mailto:paragdere@gmail.com) wrote:

> Hi all,  
> I get an intermittent error while trying to run ES as a service and when  
> Jetty is enabled.  
> Sometimes it works fine, and sometimes it fails.  
> I tried to Apache Commons Daemon and it gives me no problems.  
> Only when i use ES as a service using servicewrapper that it fails..
> 
> The stacktrace is pasted below:  
> [2012-08-01 07:15:56,398][WARN][bootstrap] jvm uses the  
> client vm, make sure to run `java` with the server vm for best performance  
> by adding `-server` to the command line  
> [2012-08-01 07:15:56,403][INFO][node] [Warhawk]  
> {0.19.8}[3124]: initializing ...  
> [2012-08-01 07:15:56,484][INFO][plugins] [Warhawk] loaded  
> [jetty], sites [bigdesk, head]  
> [2012-08-01 07:15:59,555][INFO][node] [Warhawk]  
> {0.19.8}[3124]: initialized  
> [2012-08-01 07:15:59,555][INFO][node] [Warhawk]  
> {0.19.8}[3124]: starting ...  
> [2012-08-01 07:15:59,803][INFO][transport] [Warhawk]  
> bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
> {inet[/192.168.2.2:9300]}  
> [2012-08-01 07:16:03,181][INFO][cluster.service] [Warhawk]  
> new\_master [Warhawk][V8EIJFCMR-K4NXFSXGmwMw][inet[/192.168.2.2:9300]],  
> reason: zen-disco-join (elected\_as\_master)  
> [2012-08-01 07:16:03,255][INFO][discovery] [Warhawk]  
> PaRaG/V8EIJFCMR-K4NXFSXGmwMw  
> [2012-08-01 07:16:03,677][INFO][org.eclipse.jetty.server.Server] [Warhawk]  
> jetty-8.1.4.v20120524  
> [2012-08-01 07:16:03,763][INFO][org.eclipse.jetty.server.AbstractConnector]  
> [Warhawk] Started SelectChannelConnector@0.0.0.0:9200  
> [2012-08-01 07:16:03,906][INFO][gateway] [Warhawk]  
> recovered [5] indices into cluster\_state  
> [2012-08-01 07:16:04,027][INFO][http] [Warhawk]  
> bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address  
> {inet[/192.168.2.2:9200]}  
> [2012-08-01 07:16:04,027][INFO][node] [Warhawk]  
> {0.19.8}[3124]: started
> 
> soon afterwards, i restarted the service and then i got the error again.
> 
> [2012-08-01 07:19:41,747][WARN][bootstrap] jvm uses the  
> client vm, make sure to run `java` with the server vm for best performance  
> by adding `-server` to the command line  
> [2012-08-01 07:19:41,751][INFO][node] [Link]  
> {0.19.8}[1196]: initializing ...  
> [2012-08-01 07:19:41,766][INFO][plugins] [Link] loaded  
> [jetty], sites [bigdesk, head]  
> [2012-08-01 07:19:44,384][INFO][node] [Link]  
> {0.19.8}[1196]: initialized  
> [2012-08-01 07:19:44,384][INFO][node] [Link]  
> {0.19.8}[1196]: starting ...  
> [2012-08-01 07:19:44,643][INFO][transport] [Link]  
> bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
> {inet[/192.168.2.2:9300]}  
> [2012-08-01 07:19:48,074][INFO][cluster.service] [Link]  
> new\_master [Link][gCJHFIApQSmnxugHpLHe7g][inet[/192.168.2.2:9300]], reason:  
> zen-disco-join (elected\_as\_master)  
> [2012-08-01 07:19:48,099][INFO][discovery] [Link]  
> PaRaG/gCJHFIApQSmnxugHpLHe7g  
> [2012-08-01 07:19:48,304][INFO][org.eclipse.jetty.server.Server] [Link]  
> jetty-8.1.4.v20120524  
> [2012-08-01 07:19:48,369][INFO][org.eclipse.jetty.server.AbstractConnector]  
> [Link] Started SelectChannelConnector@0.0.0.0:9200  
> [2012-08-01 07:19:48,631][INFO][http] [Link]  
> bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address  
> {inet[/192.168.2.2:9200]}  
> [2012-08-01 07:19:48,631][INFO][node] [Link]  
> {0.19.8}[1196]: started  
> [2012-08-01 07:19:48,756][INFO][gateway] [Link] recovered  
> [5] indices into cluster\_state  
> [2012-08-01 07:20:00,736][WARN  
> ][org.eclipse.jetty.server.AbstractHttpConnection] [Link] /  
> java.lang.NoClassDefFoundError:  
> com/sonian/elasticsearch/http/jetty/JettyHttpServerRestRequest  
> at  
> com.sonian.elasticsearch.http.jetty.handler.JettyHttpServerTransportHandler.handle(JettyHttpServerTransportHandler.java:66)  
> at  
> org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:499)  
> at  
> org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)  
> at org.eclipse.jetty.server.Server.handle(Server.java:350)  
> at  
> org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:454)  
> at  
> org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:890)  
> at  
> org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:944)  
> at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:630)  
> at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:230)  
> at  
> org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:77)  
> at  
> org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:620)  
> at  
> org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:46)  
> at  
> org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:603)  
> at  
> org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:538)  
> at java.lang.Thread.run(Unknown Source)  
> Caused by: java.lang.ClassNotFoundException:  
> com.sonian.elasticsearch.http.jetty.JettyHttpServerRestRequest  
> at java.net.URLClassLoader$1.run(Unknown Source)  
> at java.net.URLClassLoader$1.run(Unknown Source)  
> at java.security.AccessController.doPrivileged(Native Method)  
> at java.net.URLClassLoader.findClass(Unknown Source)  
> at java.lang.ClassLoader.loadClass(Unknown Source)  
> at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)  
> at java.lang.ClassLoader.loadClass(Unknown Source)  
> ... 15 more  
> [2012-08-01 07:20:03,023][WARN  
> ][org.eclipse.jetty.server.AbstractHttpConnection] [Link] /  
> java.lang.NoClassDefFoundError:  
> com/sonian/elasticsearch/http/jetty/JettyHttpServerRestRequest  
> at  
> com.sonian.elasticsearch.http.jetty.handler.JettyHttpServerTransportHandler.handle(JettyHttpServerTransportHandler.java:66)  
> at  
> org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:499)  
> at  
> org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)  
> at org.eclipse.jetty.server.Server.handle(Server.java:350)  
> at  
> org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:454)  
> at  
> org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:890)  
> at  
> org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:944)  
> at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:630)  
> at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:230)  
> at  
> org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:77)  
> at  
> org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:620)  
> at  
> org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:46)  
> at  
> org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:603)  
> at  
> org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:538)  
> at java.lang.Thread.run(Unknown Source)
> 
> Any body else having similar problems ?
> 
> regards,  
> -Parag

---

<div class="post-metadata">

### Author: ![Igor\_Motov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/igor_motov/32/45193_2.png) [@Igor\_Motov](https://discuss.elastic.co/u/Igor_Motov)
#### Post date: [August 4, 2012, 1:07am UTC](https://discuss.elastic.co/t/elasticsearch-with-jetty-fails-while-running-as-a-windows-service-using-elasticsearch-servicewrapper/8609/3 "2012-08-04T01:07:55Z")

</div>

It's somewhat strange classloader issue that we are still trying to figure  
out [Classloader fails to load some plugin classes when running on Windows · Issue #17 · elastic/elasticsearch-servicewrapper · GitHub](https://github.com/elasticsearch/elasticsearch-servicewrapper/issues/17). A temporary workaround  
is to explicitly add failing plugin to the wrapper classpath. For example,  
this issue for the jetty plugin can be fixed by adding the following line  
to elasticsearch.conf:

wrapper.java.classpath.5=%ES\_HOME%/plugins/jetty/\*.jar

On Friday, August 3, 2012 12:41:48 PM UTC-4, Ivan Brusic wrote:

> Are you using the Jetty plugin?  
> [GitHub - sonian/elasticsearch-jetty](https://github.com/sonian/elasticsearch-jetty)
> 
> Judging by the NoClassDefFoundError error, you probably do not have it  
> installed on every machine.
> 
> --  
> Ivan
> 
> On Thu, Aug 2, 2012 at 7:38 AM, Parag Dere [paragdere@gmail.com](mailto:paragdere@gmail.com) wrote:
> 
> > Hi all,  
> > I get an intermittent error while trying to run ES as a service and when  
> > Jetty is enabled.  
> > Sometimes it works fine, and sometimes it fails.  
> > I tried to Apache Commons Daemon and it gives me no problems.  
> > Only when i use ES as a service using servicewrapper that it fails..
> > 
> > The stacktrace is pasted below:  
> > [2012-08-01 07:15:56,398][WARN][bootstrap] jvm uses the  
> > client vm, make sure to run `java` with the server vm for best  
> > performance  
> > by adding `-server` to the command line  
> > [2012-08-01 07:15:56,403][INFO][node] [Warhawk]  
> > {0.19.8}[3124]: initializing ...  
> > [2012-08-01 07:15:56,484][INFO][plugins] [Warhawk]  
> > loaded  
> > [jetty], sites [bigdesk, head]  
> > [2012-08-01 07:15:59,555][INFO][node] [Warhawk]  
> > {0.19.8}[3124]: initialized  
> > [2012-08-01 07:15:59,555][INFO][node] [Warhawk]  
> > {0.19.8}[3124]: starting ...  
> > [2012-08-01 07:15:59,803][INFO][transport] [Warhawk]  
> > bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
> > {inet[/192.168.2.2:9300]}  
> > [2012-08-01 07:16:03,181][INFO][cluster.service] [Warhawk]  
> > new\_master [Warhawk][V8EIJFCMR-K4NXFSXGmwMw][inet[/192.168.2.2:9300]],  
> > reason: zen-disco-join (elected\_as\_master)  
> > [2012-08-01 07:16:03,255][INFO][discovery] [Warhawk]  
> > PaRaG/V8EIJFCMR-K4NXFSXGmwMw  
> > [2012-08-01 07:16:03,677][INFO][org.eclipse.jetty.server.Server]  
> > [Warhawk]  
> > jetty-8.1.4.v20120524  
> > [2012-08-01 07:16:03,763][INFO  
> > ][org.eclipse.jetty.server.AbstractConnector]  
> > [Warhawk] Started SelectChannelConnector@0.0.0.0:9200  
> > [2012-08-01 07:16:03,906][INFO][gateway] [Warhawk]  
> > recovered [5] indices into cluster\_state  
> > [2012-08-01 07:16:04,027][INFO][http] [Warhawk]  
> > bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address  
> > {inet[/192.168.2.2:9200]}  
> > [2012-08-01 07:16:04,027][INFO][node] [Warhawk]  
> > {0.19.8}[3124]: started
> > 
> > soon afterwards, i restarted the service and then i got the error again.
> > 
> > [2012-08-01 07:19:41,747][WARN][bootstrap] jvm uses the  
> > client vm, make sure to run `java` with the server vm for best  
> > performance  
> > by adding `-server` to the command line  
> > [2012-08-01 07:19:41,751][INFO][node] [Link]  
> > {0.19.8}[1196]: initializing ...  
> > [2012-08-01 07:19:41,766][INFO][plugins] [Link]  
> > loaded  
> > [jetty], sites [bigdesk, head]  
> > [2012-08-01 07:19:44,384][INFO][node] [Link]  
> > {0.19.8}[1196]: initialized  
> > [2012-08-01 07:19:44,384][INFO][node] [Link]  
> > {0.19.8}[1196]: starting ...  
> > [2012-08-01 07:19:44,643][INFO][transport] [Link]  
> > bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
> > {inet[/192.168.2.2:9300]}  
> > [2012-08-01 07:19:48,074][INFO][cluster.service] [Link]  
> > new\_master [Link][gCJHFIApQSmnxugHpLHe7g][inet[/192.168.2.2:9300]],  
> > reason:  
> > zen-disco-join (elected\_as\_master)  
> > [2012-08-01 07:19:48,099][INFO][discovery] [Link]  
> > PaRaG/gCJHFIApQSmnxugHpLHe7g  
> > [2012-08-01 07:19:48,304][INFO][org.eclipse.jetty.server.Server] [Link]  
> > jetty-8.1.4.v20120524  
> > [2012-08-01 07:19:48,369][INFO  
> > ][org.eclipse.jetty.server.AbstractConnector]  
> > [Link] Started SelectChannelConnector@0.0.0.0:9200  
> > [2012-08-01 07:19:48,631][INFO][http] [Link]  
> > bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address  
> > {inet[/192.168.2.2:9200]}  
> > [2012-08-01 07:19:48,631][INFO][node] [Link]  
> > {0.19.8}[1196]: started  
> > [2012-08-01 07:19:48,756][INFO][gateway] [Link]  
> > recovered  
> > [5] indices into cluster\_state  
> > [2012-08-01 07:20:00,736][WARN  
> > ][org.eclipse.jetty.server.AbstractHttpConnection] [Link] /  
> > java.lang.NoClassDefFoundError:  
> > com/sonian/elasticsearch/http/jetty/JettyHttpServerRestRequest  
> > at
> 
> com.sonian.elasticsearch.http.jetty.handler.JettyHttpServerTransportHandler.handle(JettyHttpServerTransportHandler.java:66)
> 
> > at
> 
> org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:499)
> 
> > at
> 
> org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)
> 
> > at org.eclipse.jetty.server.Server.handle(Server.java:350)  
> > at
> 
> org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:454)
> 
> > at
> 
> org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:890)
> 
> > at
> 
> org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:944)
> 
> > at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:630)  
> > at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:230)  
> > at
> 
> org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:77)
> 
> > at
> 
> org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:620)
> 
> > at
> 
> org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:46)
> 
> > at
> 
> org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:603)
> 
> > at
> 
> org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:538)
> 
> > at java.lang.Thread.run(Unknown Source)  
> > Caused by: java.lang.ClassNotFoundException:  
> > com.sonian.elasticsearch.http.jetty.JettyHttpServerRestRequest  
> > at java.net.URLClassLoader$1.run(Unknown Source)  
> > at java.net.URLClassLoader$1.run(Unknown Source)  
> > at java.security.AccessController.doPrivileged(Native Method)  
> > at java.net.URLClassLoader.findClass(Unknown Source)  
> > at java.lang.ClassLoader.loadClass(Unknown Source)  
> > at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)  
> > at java.lang.ClassLoader.loadClass(Unknown Source)  
> > ... 15 more  
> > [2012-08-01 07:20:03,023][WARN  
> > ][org.eclipse.jetty.server.AbstractHttpConnection] [Link] /  
> > java.lang.NoClassDefFoundError:  
> > com/sonian/elasticsearch/http/jetty/JettyHttpServerRestRequest  
> > at
> 
> com.sonian.elasticsearch.http.jetty.handler.JettyHttpServerTransportHandler.handle(JettyHttpServerTransportHandler.java:66)
> 
> > at
> 
> org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:499)
> 
> > at
> 
> org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)
> 
> > at org.eclipse.jetty.server.Server.handle(Server.java:350)  
> > at
> 
> org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:454)
> 
> > at
> 
> org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:890)
> 
> > at
> 
> org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:944)
> 
> > at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:630)  
> > at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:230)  
> > at
> 
> org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:77)
> 
> > at
> 
> org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:620)
> 
> > at
> 
> org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:46)
> 
> > at
> 
> org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:603)
> 
> > at
> 
> org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:538)
> 
> > at java.lang.Thread.run(Unknown Source)
> > 
> > Any body else having similar problems ?
> > 
> > regards,  
> > -Parag

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 3:17am UTC](https://discuss.elastic.co/t/elasticsearch-with-jetty-fails-while-running-as-a-windows-service-using-elasticsearch-servicewrapper/8609/4 "2017-07-06T03:17:45Z")

</div>


