# Elasticsearch won't start after 7.9.1 to 7.9.2 upgrade

**URL:** <https://discuss.elastic.co/t/elasticsearch-wont-start-after-7-9-1-to-7-9-2-upgrade/249878>\
**Category:** Elasticsearch\
**Created:** [September 24, 2020, 9:36pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-7-9-1-to-7-9-2-upgrade/249878 "2020-09-24T21:36:08Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![craigothy](https://avatars.discourse-cdn.com/v4/letter/c/258eb7/32.png) [@craigothy](https://discuss.elastic.co/u/craigothy)\
**Post date:** [September 24, 2020, 9:36pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-7-9-1-to-7-9-2-upgrade/249878/1 "2020-09-24T21:36:08Z")

</div>

For some reason, I am getting the following JVM error when starting elasticsearch 7.9.2 on CentOS7 after a yum upgrade. Any ideas? Thanks for any help:

> Exception in thread "main" java.lang.RuntimeException: starting java failed with [1]  
> output:
> 
> error:  
> Unrecognized VM option 'UseConcMarkSweepGC'  
> Error: Could not create the Java Virtual Machine.  
> Error: A fatal exception has occurred. Program will exit.  
> at org.elasticsearch.tools.launchers.JvmErgonomics.flagsFinal(JvmErgonomics.java:126)  
> at org.elasticsearch.tools.launchers.JvmErgonomics.finalJvmOptions(JvmErgonomics.java:88)  
> at org.elasticsearch.tools.launchers.JvmErgonomics.choose(JvmErgonomics.java:59)  
> at org.elasticsearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:137)  
> at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:95)

---

<div class="post-metadata">

**Author:** ![niklaskurvinen](https://avatars.discourse-cdn.com/v4/letter/n/cdc98d/32.png) [@niklaskurvinen](https://discuss.elastic.co/u/niklaskurvinen)\
**Post date:** [September 25, 2020, 9:16am UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-7-9-1-to-7-9-2-upgrade/249878/2 "2020-09-25T09:16:30Z")

</div>

I'm seeing the same thing on Ubuntu 18.04.

A quick google of the error tells me it's related to this:

> ### Upgrades
> 
> Infra/Packaging
> 
> - Upgrade the bundled JDK to JDK 15 [#62580](https://github.com/elastic/elasticsearch/pull/62580)

**UPDATE:**  
So my automated approach of updating elasticsearch ignores any new versions of configuration files. Forcing reinstall using `sudo apt install --reinstall -o Dpkg::Options::="--force-confask,confnew,confmiss" elasticsearch` gave me an updated jvm.options that solves the issue. Here's the diff:

```auto
# diff jvm.options jvm.options.dpkg-old
36,38c36,38
< 8-13:-XX:+UseConcMarkSweepGC
< 8-13:-XX:CMSInitiatingOccupancyFraction=75
< 8-13:-XX:+UseCMSInitiatingOccupancyOnly
---
> -XX:+UseConcMarkSweepGC
> -XX:CMSInitiatingOccupancyFraction=75
> -XX:+UseCMSInitiatingOccupancyOnly
41,48c41,47
< # NOTE: G1 GC is only supported on JDK version 10 or later
< # to use G1GC, uncomment the next two lines and update the version on the
< # following three lines to your version of the JDK
< # 10-13:-XX:-UseConcMarkSweepGC
< # 10-13:-XX:-UseCMSInitiatingOccupancyOnly
< 14-:-XX:+UseG1GC
< 14-:-XX:G1ReservePercent=25
< 14-:-XX:InitiatingHeapOccupancyPercent=30
---
> # NOTE: G1GC is only supported on JDK version 10 or later.
> # To use G1GC uncomment the lines below.
> # 10-:-XX:-UseConcMarkSweepGC
> # 10-:-XX:-UseCMSInitiatingOccupancyOnly
> # 10-:-XX:+UseG1GC
> # 10-:-XX:G1ReservePercent=25
> # 10-:-XX:InitiatingHeapOccupancyPercent=30

```

I'm no Java expert, so to summarize: Make sure you use the latest jvm.options (don't forget to save a backup of your old one in case of custom modifications) and hopefully elasticsearch starts just fine.

---

<div class="post-metadata">

**Author:** ![craigothy](https://avatars.discourse-cdn.com/v4/letter/c/258eb7/32.png) [@craigothy](https://discuss.elastic.co/u/craigothy)\
**Post date:** [September 25, 2020, 4:58pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-7-9-1-to-7-9-2-upgrade/249878/3 "2020-09-25T16:58:39Z")

</div>

Yes, that was the fix. Thank you @niklaskurvinen

---

<div class="post-metadata">

**Author:** ![damianward1972](https://avatars.discourse-cdn.com/v4/letter/d/d26b3c/32.png) [@damianward1972](https://discuss.elastic.co/u/damianward1972)\
**Post date:** [October 14, 2020, 10:53am UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-7-9-1-to-7-9-2-upgrade/249878/4 "2020-10-14T10:53:06Z")

</div>

Thanks.. D

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 11, 2020, 10:53am UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-7-9-1-to-7-9-2-upgrade/249878/5 "2020-11-11T10:53:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
