# ElasticSearch Wont Start after intial config

**URL:** https://discuss.elastic.co/t/elasticsearch-wont-start-after-intial-config/149026
**Category:** Elasticsearch
**Created:** [September 18, 2018, 9:21pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-intial-config/149026 "2018-09-18T21:21:13Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![koocaroo](https://avatars.discourse-cdn.com/v4/letter/k/8edcca/32.png) [@koocaroo](https://discuss.elastic.co/u/koocaroo)
#### Post date: [September 18, 2018, 9:21pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-intial-config/149026/1 "2018-09-18T21:21:13Z")

</div>

After installing elastic i started it once just as a test, and the service started fine. I stopped it and continued to go through the 6.4 guide. Once i finished and tried to start the service again it now fails and gives very little output as to why. Any point in the right direction would be helpful. The service status is below:

[root@elk-001 tmp]# systemctl status elasticsearch.service  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Drop-In: /etc/systemd/system/elasticsearch.service.d  
└─override.conf  
Active: failed (Result: exit-code) since Tue 2018-09-18 16:50:47 EDT; 5s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 13994 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 13994 (code=exited, status=1/FAILURE)

Sep 18 16:50:46 elk-001 systemd[1]: Started Elasticsearch.  
Sep 18 16:50:46 elk-001 systemd[1]: Starting Elasticsearch...  
Sep 18 16:50:47 elk-001 systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Sep 18 16:50:47 elk-001 systemd[1]: Unit elasticsearch.service entered failed state.  
Sep 18 16:50:47 elk-001 systemd[1]: elasticsearch.service failed.

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [September 19, 2018, 5:46am UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-intial-config/149026/2 "2018-09-19T05:46:30Z")

</div>

Is there anything in the Elasticsearch logs?

---

<div class="post-metadata">

### Author: ![koocaroo](https://avatars.discourse-cdn.com/v4/letter/k/8edcca/32.png) [@koocaroo](https://discuss.elastic.co/u/koocaroo)
#### Post date: [September 19, 2018, 6:15pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-intial-config/149026/3 "2018-09-19T18:15:43Z")

</div>

in the elasticsearch.log file only the below are not marked INFO:

[2018-09-18T15:10:48,603][WARN][o.e.x.s.a.s.m.NativeRoleMappingStore] [B27nrvW] Failed to clear cache for realms [[]]

[2018-09-18T15:10:44,255][DEBUG][o.e.a.ActionModule] Using REST wrapper from plugin org.elasticsearch.xpack.security.Security

Is there another log file i should be looking in for this?

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [September 19, 2018, 6:16pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-intial-config/149026/4 "2018-09-19T18:16:35Z")

</div>

What is the specification of the host where Elasticsearch is running?

---

<div class="post-metadata">

### Author: ![koocaroo](https://avatars.discourse-cdn.com/v4/letter/k/8edcca/32.png) [@koocaroo](https://discuss.elastic.co/u/koocaroo)
#### Post date: [September 19, 2018, 6:19pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-intial-config/149026/5 "2018-09-19T18:19:53Z")

</div>

running on a HP proliant running Centos7:

cores = 2  
ram = 64g  
disk = 500gb

---

<div class="post-metadata">

### Author: ![koocaroo](https://avatars.discourse-cdn.com/v4/letter/k/8edcca/32.png) [@koocaroo](https://discuss.elastic.co/u/koocaroo)
#### Post date: [September 19, 2018, 6:27pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-intial-config/149026/6 "2018-09-19T18:27:31Z")

</div>

actually i think this may be the root of the problem:

[2018-09-18T16:50:47,579][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [itd-elk-001] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: Failed to create node environment  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:140) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.4.1.jar:6.4.1]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.4.1.jar:6.4.1]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) ~[elasticsearch-6.4.1.jar:6.4.1]  
Caused by: java.lang.IllegalStateException: Failed to create node environment  
at org.elasticsearch.node.Node.(Node.java:277) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.node.Node.(Node.java:256) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:213) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:213) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:326) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-6.4.1.jar:6.4.1]  
... 6 more  
Caused by: java.nio.file.AccessDeniedException: /data/elasticsearch/elasticsearch\_data/nodes  
at sun.nio.fs.UnixException.translateToIOException(Unknown Source) ~[?:?]  
at sun.nio.fs.UnixException.rethrowAsIOException(Unknown Source) ~[?:?]  
at sun.nio.fs.UnixException.rethrowAsIOException(Unknown Source) ~[?:?]  
at sun.nio.fs.UnixFileSystemProvider.createDirectory(Unknown Source) ~[?:?]  
at java.nio.file.Files.createDirectory(Unknown Source) ~[?:?]  
at java.nio.file.Files.createAndCheckIsDirectory(Unknown Source) ~[?:?]  
at java.nio.file.Files.createDirectories(Unknown Source) ~[?:?]  
at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:203) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.node.Node.(Node.java:274) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.node.Node.(Node.java:256) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:213) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:213) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:326) ~[elasticsearch-6.4.1.jar:6.4.1]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-6.4.1.jar:6.4.1]  
... 6 more

not sure what this entails however

---

<div class="post-metadata">

### Author: ![koocaroo](https://avatars.discourse-cdn.com/v4/letter/k/8edcca/32.png) [@koocaroo](https://discuss.elastic.co/u/koocaroo)
#### Post date: [September 19, 2018, 6:34pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-intial-config/149026/7 "2018-09-19T18:34:16Z")

</div>

noob move on my part. never made the service the owner of the data path. sorry to waste your time @Christian_Dahlqvist

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 17, 2018, 6:34pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-intial-config/149026/8 "2018-10-17T18:34:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
