# Elasticsearch wont start after upgrade to 8.4 - repository-gcs issue

**URL:** <https://discuss.elastic.co/t/elasticsearch-wont-start-after-upgrade-to-8-4-repository-gcs-issue/313060>\
**Category:** Elasticsearch\
**Created:** [August 27, 2022, 10:08am UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-upgrade-to-8-4-repository-gcs-issue/313060 "2022-08-27T10:08:24Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![kribor1](https://avatars.discourse-cdn.com/v4/letter/k/f07891/32.png) [@kribor1](https://discuss.elastic.co/u/kribor1)\
**Post date:** [August 27, 2022, 10:08am UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-upgrade-to-8-4-repository-gcs-issue/313060/1 "2022-08-27T10:08:24Z")

</div>

Hi,

As I updated to 8.4 today one of my nodes (I have a 2-node cluster) now fails to start with the below stacktrace:

```auto
Exception in thread "main" java.lang.IllegalArgumentException: Unknown properties for plugin [repository-gcs] in plugin descriptor: [type]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:218)
	at org.elasticsearch.plugins.PluginsUtils.readPluginBundle(PluginsUtils.java:162)
	at org.elasticsearch.plugins.PluginsUtils.findBundles(PluginsUtils.java:143)
	at org.elasticsearch.plugins.PluginsUtils.getPluginBundles(PluginsUtils.java:125)
	at org.elasticsearch.plugins.PluginsUtils.getDependencyMapView(PluginsUtils.java:135)
	at org.elasticsearch.plugins.cli.RemovePluginAction.ensurePluginsNotUsedByOtherPlugins(RemovePluginAction.java:95)
	at org.elasticsearch.plugins.cli.RemovePluginAction.execute(RemovePluginAction.java:77)
	at org.elasticsearch.plugins.cli.RemovePluginCommand.execute(RemovePluginCommand.java:43)
	at org.elasticsearch.common.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:54)
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:85)
	at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:94)
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:85)
	at org.elasticsearch.cli.Command.main(Command.java:50)
	at org.elasticsearch.launcher.CliToolLauncher.main(CliToolLauncher.java:64)

```

I was expecting this kind of issue going to 8 but not going from 8.3 to 8.4?! So first, yes I know - repository-gcs is no longer a plugin (so no need to install after every upgrade, yay!) but now something went wrong preventing elasticsearch (or plugin removal script for that matter, fails with same error).

I've searched through /etc/elasticsearch and it contains no reference to `repository-gcs`, neither does /var/lib/elasticsearch`. I'm on centos stream release

Any ideas for reviving my cluster?

---

<div class="post-metadata">

**Author:** ![kribor1](https://avatars.discourse-cdn.com/v4/letter/k/f07891/32.png) [@kribor1](https://discuss.elastic.co/u/kribor1)\
**Post date:** [August 27, 2022, 10:23am UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-upgrade-to-8-4-repository-gcs-issue/313060/2 "2022-08-27T10:23:01Z")

</div>

Resolution was simple in the end...

I manually removed `repository-gcs` from `/usr/share/elasticsearch/plugins`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 24, 2022, 10:23am UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-upgrade-to-8-4-repository-gcs-issue/313060/3 "2022-09-24T10:23:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
