Elasticsearch won't start and no logs


(Islam Elshobokshy) #1

I've been trying to start ES for hours and I can't seem to be able to do so.

The command sudo service elasticsearch status prints out :

elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since ven. 2019-01-11 12:22:33 CET; 5min ago
     Docs: http://www.elastic.co
  Process: 16713 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -Des.pidfile=$PID_DIR/elasticsearch.pid -Des.default.path.home=$ES_HOME -Des.default.path.logs=$LOG_DIR -Des.default.path.data=$DATA_DIR -Des.default.confi Main PID: 16713 (code=exited, status=1/FAILURE)

janv. 11 12:22:33 glamuse systemd[1]: Started Elasticsearch.
janv. 11 12:22:33 glamuse systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
janv. 11 12:22:33 glamuse systemd[1]: elasticsearch.service: Unit entered failed state.
janv. 11 12:22:33 glamuse systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

I've increased the memory and done all the fixes I could find on the internet, but I can't seem to figure out what's going on, there's not even a single log generated today... So I don't even have any trace of where the error could be.

Any idea how can I debug this?


#2

More info would help troubleshooting...

Which Elasticsearch version do you run? On which OS? Maybe add your (well formatted) Elasticsearch config as well.


(Islam Elshobokshy) #3

I'm using ES version 1.7.2 (yes, it's old, but that shouldn't be a problem as it does work, and no I can't upgrade because my Elastica uses this version, anyways ...)

I'm using a vagrant machine, so it's a unix based system.

My config is as follow (removed all the useless comments) :

index.number_of_shards: 10
index.number_of_replicas: 1

bootstrap.mlockall: true

network.bind_host: 0
network.host: 0.0.0.0

indices.recovery.max_bytes_per_sec: 200mb
indices.store.throttle.max_bytes_per_sec : 200mb

script.engine.groovy.inline.search: on
script.engine.groovy.inline.aggs: on
script.engine.groovy.inline.update: on

index.query.bool.max_clause_count: 100000

I also have this conf :

ES_HEAP_SIZE=4g
MAX_OPEN_FILES=65535
MAX_LOCKED_MEMORY=unlimited
START_DAEMON=true
ES_USER=elasticsearch
ES_GROUP=elasticsearch
LOG_DIR=/var/log/elasticsearch
DATA_DIR=/var/lib/elasticsearch
WORK_DIR=/tmp/elasticsearch
CONF_DIR=/etc/elasticsearch
CONF_FILE=/etc/elasticsearch/elasticsearch.yml
RESTART_ON_UPGRADE=true

(Leandro Maciel) #4

I had a similar problem once, where elasticsearch won't start and there were no logs, in my case it was the permissions for the log directory that were wrong, the elasticsearch user didn't had the correct permissions.

Could be worth check it on your system.


(Islam Elshobokshy) #5

Yes I've even read that somewhere on the internet and already tried doing a sudo chmod -R 777 on all of the directories in my config above it still doesn't work ... (won't start, and no logs anywhere)


(system) closed #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.