# Elasticsearch won't start anymore

**URL:** <https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857>\
**Category:** Elasticsearch\
**Created:** [April 7, 2014, 8:47pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857 "2014-04-07T20:47:43Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![Danny\_Joris](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/danny_joris/32/1646_2.png) [@Danny\_Joris](https://discuss.elastic.co/u/Danny_Joris)\
**Post date:** [April 7, 2014, 8:47pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857/1 "2014-04-07T20:47:43Z")

</div>

After making a simple change on a query in Kibana, my Elasticsearch  
instance stopped working and I can't start it up again. I'm using ES 0.90.9  
on OSX using homebrew.

Normally I would use this to start ES:  
elasticsearch -f -D  
es.config=/usr/local/opt/elasticsearch/config/elasticsearch.yml

This however throws out a repeated error:

[2014-04-07 15:59:02,128][INFO][node] [Puck] initializing ...  
[2014-04-07 15:59:02,224][INFO][plugins] [Puck] loaded [mongodb-river,mapper  
-attachments, marvel], sites [river-mongodb, marvel]  
[2014-04-07 15:59:04,553][INFO][node] [Puck] initialized  
[2014-04-07 15:59:04,553][INFO][node] [Puck] starting ...  
[2014-04-07 15:59:04,665][INFO][transport] [Puck] bound\_address {inet[/127.0.0.1:9302]},  
publish\_address {inet[/127.0.0.1:9302]}  
[2014-04-07 15:59:07,727][INFO][cluster.service] [Puck] new\_master  
[Puck][gtub58OkR9SskDE0SfYobw][inet[/127.0.0.1:9302]], reason:  
zen-disco-join (elected\_as\_master)  
[2014-04-07 15:59:07,778][INFO][discovery] [Puck]  
elasticsearch\_dannyjoris/gtub58OkR9SskDE0SfYobw  
[2014-04-07 15:59:07,795][INFO][http] [Puck] bound\_address {inet[/127.0.  
0.1:9202]}, publish\_address {inet[/127.0.0.1:9202]}  
[2014-04-07 15:59:07,796][INFO][node] [Puck] started  
[2014-04-07 15:59:07,813][INFO][gateway] [Puck] recovered [0] indices intocluster\_state  
[2014-04-07 15:59:09,589][ERROR][marvel.agent.exporter] error connecting  
to [localhost:9200]  
java.net.SocketTimeoutException: connect timed out  
at java.net.PlainSocketImpl.socketConnect(Native Method)  
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382)  
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241)  
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228)  
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:431)  
at java.net.Socket.connect(Socket.java:527)  
at sun.net.NetworkClient.doConnect(NetworkClient.java:158)  
at sun.net.www.http.HttpClient.openServer(HttpClient.java:424)  
at sun.net.www.http.HttpClient.openServer(HttpClient.java:538)  
at sun.net.www.http.HttpClient.(HttpClient.java:214)  
at sun.net.www.http.HttpClient.New(HttpClient.java:300)  
at sun.net.www.http.HttpClient.New(HttpClient.java:319)  
at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(  
HttpURLConnection.java:987)  
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(  
HttpURLConnection.java:923)  
at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.  
java:841)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.openConnection(  
ESExporter.java:313)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.openConnection(  
ESExporter.java:293)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.checkAndUpload(  
ESExporter.java:428)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.  
checkAndUploadIndexTemplate(ESExporter.java:464)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.  
checkAndUploadAllResources(ESExporter.java:341)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.  
openExportingConnection(ESExporter.java:190)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.exportXContent(  
ESExporter.java:246)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.exportNodeStats(  
ESExporter.java:134)  
at org.elasticsearch.marvel.agent.AgentService$ExportingWorker.  
exportNodeStats(AgentService.java:274)  
at org.elasticsearch.marvel.agent.AgentService$ExportingWorker.run(  
AgentService.java:174)  
at java.lang.Thread.run(Thread.java:695)  
[2014-04-07 15:59:09,591][ERROR][marvel.agent.exporter] Could not connect  
to any configured elasticsearch instances: [localhost:9200]

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/73f04a55-2292-4a42-87ec-cac771a19db5%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/73f04a55-2292-4a42-87ec-cac771a19db5%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 7, 2014, 8:53pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857/2 "2014-04-07T20:53:49Z")

</div>

I answered this on SOF:

The error you mentioned does not mean that your elasticsearch node is not working but only that it could not contact your Marvel node.

Why do you think it's not working?

Could you also gist your elasticsearch.yml file?

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 7 avril 2014 à 22:47:47, Danny Joris (danny\_joris@yahoo.co.uk) a écrit:

After making a simple change on a query in Kibana, my Elasticsearch instance stopped working and I can't start it up again. I'm using ES 0.90.9 on OSX using homebrew.

Normally I would use this to start ES:  
elasticsearch -f -D es.config=/usr/local/opt/elasticsearch/config/elasticsearch.yml

This however throws out a repeated error:  
[2014-04-07 15:59:02,128][INFO][node] [Puck] initializing ...  
[2014-04-07 15:59:02,224][INFO][plugins] [Puck] loaded [mongodb-river, mapper-attachments, marvel], sites [river-mongodb, marvel]  
[2014-04-07 15:59:04,553][INFO][node] [Puck] initialized  
[2014-04-07 15:59:04,553][INFO][node] [Puck] starting ...  
[2014-04-07 15:59:04,665][INFO][transport] [Puck] bound\_address {inet[/127.0.0.1:9302]}, publish\_address {inet[/127.0.0.1:9302]}  
[2014-04-07 15:59:07,727][INFO][cluster.service] [Puck] new\_master [Puck][gtub58OkR9SskDE0SfYobw][inet[/127.0.0.1:9302]], reason: zen-disco-join (elected\_as\_master)  
[2014-04-07 15:59:07,778][INFO][discovery] [Puck] elasticsearch\_dannyjoris/gtub58OkR9SskDE0SfYobw  
[2014-04-07 15:59:07,795][INFO][http] [Puck] bound\_address {inet[/127.0.0.1:9202]}, publish\_address {inet[/127.0.0.1:9202]}  
[2014-04-07 15:59:07,796][INFO][node] [Puck] started  
[2014-04-07 15:59:07,813][INFO][gateway] [Puck] recovered [0] indices into cluster\_state  
[2014-04-07 15:59:09,589][ERROR][marvel.agent.exporter] error connecting to [localhost:9200]  
java.net.SocketTimeoutException: connect timed out  
at java.net.PlainSocketImpl.socketConnect(Native Method)  
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382)  
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241)  
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228)  
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:431)  
at java.net.Socket.connect(Socket.java:527)  
at sun.net.NetworkClient.doConnect(NetworkClient.java:158)  
at sun.net.www.http.HttpClient.openServer(HttpClient.java:424)  
at sun.net.www.http.HttpClient.openServer(HttpClient.java:538)  
at sun.net.www.http.HttpClient.(HttpClient.java:214)  
at sun.net.www.http.HttpClient.New(HttpClient.java:300)  
at sun.net.www.http.HttpClient.New(HttpClient.java:319)  
at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:987)  
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:923)  
at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:841)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.openConnection(ESExporter.java:313)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.openConnection(ESExporter.java:293)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.checkAndUpload(ESExporter.java:428)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.checkAndUploadIndexTemplate(ESExporter.java:464)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.checkAndUploadAllResources(ESExporter.java:341)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.openExportingConnection(ESExporter.java:190)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.exportXContent(ESExporter.java:246)  
at org.elasticsearch.marvel.agent.exporter.ESExporter.exportNodeStats(ESExporter.java:134)  
at org.elasticsearch.marvel.agent.AgentService$ExportingWorker.exportNodeStats(AgentService.java:274)  
at org.elasticsearch.marvel.agent.AgentService$ExportingWorker.run(AgentService.java:174)  
at java.lang.Thread.run(Thread.java:695)  
[2014-04-07 15:59:09,591][ERROR][marvel.agent.exporter] Could not connect to any configured elasticsearch instances: [localhost:9200]

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/73f04a55-2292-4a42-87ec-cac771a19db5%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/73f04a55-2292-4a42-87ec-cac771a19db5%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/etPan.5343105d.46e87ccd.13fb%40MacBook-Air-de-David.local](https://groups.google.com/d/msgid/elasticsearch/etPan.5343105d.46e87ccd.13fb%40MacBook-Air-de-David.local).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Danny\_Joris](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/danny_joris/32/1646_2.png) [@Danny\_Joris](https://discuss.elastic.co/u/Danny_Joris)\
**Post date:** [April 7, 2014, 9:02pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857/3 "2014-04-07T21:02:21Z")

</div>

Elasticsearch.yml  
file: [elasticsearch.yml · GitHub](https://gist.github.com/DannyJoris/bb559005aad7f0bb1f10)

I don't know why it stopped working. I've had ES running for a while.  
Restarted it several times even over the past months without problems. I  
made a simple query change on Kibana and it stopped working and I can't  
start it up again.

Oh, and I wasn't using the Marvel interface when it went wrong. Though I  
did install the Marvel plugin quite a while ago, but I never really used it.

Danny

On Monday, 7 April 2014 17:53:49 UTC-3, David Pilato wrote:

> I answered this on SOF:
> 
> The error you mentioned does not mean that your elasticsearch node is not  
> working but only that it could not contact your Marvel node.
> 
> Why do you think it's not working?
> 
> Could you also gist your elasticsearch.yml file?
> 
> --  
> _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> 
> Le 7 avril 2014 à 22:47:47, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)\<javascript:\>)  
> a écrit:
> 
> After making a simple change on a query in Kibana, my Elasticsearch  
> instance stopped working and I can't start it up again. I'm using ES 0.90.9  
> on OSX using homebrew.
> 
> Normally I would use this to start ES:  
> elasticsearch -f -D  
> es.config=/usr/local/opt/elasticsearch/config/elasticsearch.yml
> 
> This however throws out a repeated error:
> 
> [2014-04-07 15:59:02,128][INFO][node] [Puck] initializing ...  
> [2014-04-07 15:59:02,224][INFO][plugins] [Puck] loaded [mongodb-river,  
> mapper-attachments, marvel], sites [river-mongodb, marvel]  
> [2014-04-07 15:59:04,553][INFO][node] [Puck] initialized  
> [2014-04-07 15:59:04,553][INFO][node] [Puck] starting ...  
> [2014-04-07 15:59:04,665][INFO][transport] [Puck] bound\_address {inet[/127.0.0.1:9302]},  
> publish\_address {inet[/127.0.0.1:9302]}  
> [2014-04-07 15:59:07,727][INFO][cluster.service] [Puck] new\_master  
> [Puck][gtub58OkR9SskDE0SfYobw][inet[/127.0.0.1:9302]], reason:  
> zen-disco-join (elected\_as\_master)  
> [2014-04-07 15:59:07,778][INFO][discovery] [Puck]  
> elasticsearch\_dannyjoris/gtub58OkR9SskDE0SfYobw  
> [2014-04-07 15:59:07,795][INFO][http] [Puck] bound\_address {inet[/127.0.  
> 0.1:9202]}, publish\_address {inet[/127.0.0.1:9202]}  
> [2014-04-07 15:59:07,796][INFO][node] [Puck] started  
> [2014-04-07 15:59:07,813][INFO][gateway] [Puck] recovered [0] indices  
> into cluster\_state  
> [2014-04-07 15:59:09,589][ERROR][marvel.agent.exporter] error connecting  
> to [localhost:9200]  
> java.net.SocketTimeoutException: connect timed out  
> at java.net.PlainSocketImpl.socketConnect(Native Method)  
> at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382)  
> at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241)  
> at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228)  
> at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:431)  
> at java.net.Socket.connect(Socket.java:527)  
> at sun.net.NetworkClient.doConnect(NetworkClient.java:158)  
> at sun.net.www.http.HttpClient.openServer(HttpClient.java:424)  
> at sun.net.www.http.HttpClient.openServer(HttpClient.java:538)  
> at sun.net.www.http.HttpClient.(HttpClient.java:214)  
> at sun.net.www.http.HttpClient.New(HttpClient.java:300)\</sp
> 
> ...

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 7, 2014, 9:05pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857/4 "2014-04-07T21:05:28Z")

</div>

Can you tell why do you think it's not working anymore?

What gives GET /localhost:9200

Also, could you try to modify  
network.host: 127.0.0.1

And unset it or set it to

network.host: localhost

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 7 avril 2014 à 23:02:27, Danny Joris (danny\_joris@yahoo.co.uk) a écrit:

Elasticsearch.yml file: [https://gist.github.com/DannyJoris/bb559005aad7f0bb1f10](https://gist.github.com/DannyJoris/bb559005aad7f0bb1f10)

I don't know why it stopped working. I've had ES running for a while. Restarted it several times even over the past months without problems. I made a simple query change on Kibana and it stopped working and I can't start it up again.

Oh, and I wasn't using the Marvel interface when it went wrong. Though I did install the Marvel plugin quite a while ago, but I never really used it.

Danny

On Monday, 7 April 2014 17:53:49 UTC-3, David Pilato wrote:  
I answered this on SOF:

The error you mentioned does not mean that your elasticsearch node is not working but only that it could not contact your Marvel node.

Why do you think it's not working?

Could you also gist your elasticsearch.yml file?

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 7 avril 2014 à 22:47:47, Danny Joris (danny...@yahoo.co.uk) a écrit:

After making a simple change on a query in Kibana, my Elasticsearch instance stopped working and I can't start it up again. I'm using ES 0.90.9 on OSX using homebrew.

Normally I would use this to start ES:  
elasticsearch -f -D es.config=/usr/local/opt/elasticsearch/config/elasticsearch.yml

## This however throws out a repeated error: [2014-04-07 15:59:02,128][INFO][node] [Puck] initializing ... [2014-04-07 15:59:02,224][INFO][plugins] [Puck] loaded [mongodb-river, mapper-attachments, marvel], sites [river-mongodb, marvel] [2014-04-07 15:59:04,553][INFO][node] [Puck] initialized [2014-04-07 15:59:04,553][INFO][node] [Puck] starting ... [2014-04-07 15:59:04,665][INFO][transport] [Puck] bound\_address {inet[/127.0.0.1:9302]}, publish\_address {inet[/127.0.0.1:9302]} [2014-04-07 15:59:07,727][INFO][cluster.service] [Puck] new\_master [Puck][gtub58OkR9SskDE0SfYobw][inet[/127.0.0.1:9302]], reason: zen-disco-join (elected\_as\_master) [2014-04-07 15:59:07,778][INFO][discovery] [Puck] elasticsearch\_dannyjoris/gtub58OkR9SskDE0SfYobw [2014-04-07 15:59:07,795][INFO][http] [Puck] bound\_address {inet[/127.0.0.1:9202]}, publish\_address {inet[/127.0.0.1:9202]} [2014-04-07 15:59:07,796][INFO][node] [Puck] started [2014-04-07 15:59:07,813][INFO][gateway] [Puck] recovered [0] indices into cluster\_state [2014-04-07 15:59:09,589][ERROR][marvel.agent.exporter] error connecting to [localhost:9200] java.net.SocketTimeoutException: connect timed out at java.net.PlainSocketImpl.socketConnect(Native Method) at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382) at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241) at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228) at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:431) at java.net.Socket.connect(Socket.java:527) at sun.net.NetworkClient.doConnect(NetworkClient.java:158) at sun.net.www.http.HttpClient.openServer(HttpClient.java:424) at sun.net.www.http.HttpClient.openServer(HttpClient.java:538) at sun.net.www.http.HttpClient.(HttpClient.java:214) at sun.net.www.http.HttpClient.New(HttpClient.java:300)\</sp ...

You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/etPan.53431319.6b8b4567.164d%40MacBook-Air-de-David.local](https://groups.google.com/d/msgid/elasticsearch/etPan.53431319.6b8b4567.164d%40MacBook-Air-de-David.local).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Danny\_Joris](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/danny_joris/32/1646_2.png) [@Danny\_Joris](https://discuss.elastic.co/u/Danny_Joris)\
**Post date:** [April 7, 2014, 9:13pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857/5 "2014-04-07T21:13:33Z")

</div>

> > curl -XGET '[http://127.0.0.1:9200/](http://127.0.0.1:9200/)'

curl: (7) Failed connect to 127.0.0.1:9200; Operation timed out

Removing or updating network.host to localhost has the same result when  
trying to start elasticsearch.

I'll try to remove the marvel plugin and see what it does.

On Monday, 7 April 2014 18:05:28 UTC-3, David Pilato wrote:

> Can you tell why do you think it's not working anymore?
> 
> What gives GET /localhost:9200
> 
> Also, could you try to modify  
> network.host: 127.0.0.1
> 
> And unset it or set it to
> 
> network.host: localhost
> 
> --  
> _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> 
> Le 7 avril 2014 à 23:02:27, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)\<javascript:\>)  
> a écrit:
> 
> Elasticsearch.yml file:  
> [elasticsearch.yml · GitHub](https://gist.github.com/DannyJoris/bb559005aad7f0bb1f10)
> 
> I don't know why it stopped working. I've had ES running for a while.  
> Restarted it several times even over the past months without problems. I  
> made a simple query change on Kibana and it stopped working and I can't  
> start it up again.
> 
> Oh, and I wasn't using the Marvel interface when it went wrong. Though I  
> did install the Marvel plugin quite a while ago, but I never really used it.
> 
> Danny
> 
> On Monday, 7 April 2014 17:53:49 UTC-3, David Pilato wrote:
> 
> > I answered this on SOF:
> > 
> > The error you mentioned does not mean that your elasticsearch node is  
> > not working but only that it could not contact your Marvel node.
> > 
> > Why do you think it's not working?
> > 
> > Could you also gist your elasticsearch.yml file?
> > 
> > ```
> > -- 
> > 
> > ```
> > 
> > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > 
> > Le 7 avril 2014 à 22:47:47, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)) a écrit:
> > 
> > After making a simple change on a query in Kibana, my Elasticsearch  
> > instance stopped working and I can't start it up again. I'm using ES 0.90.9  
> > on OSX using homebrew.
> > 
> > Normally I would use this to start ES:  
> > elasticsearch -f -D  
> > es.config=/usr/local/opt/elasticsearch/config/elasticsearch.yml
> > 
> > This however throws out a repeated error:
> > 
> > [2014-04-07 15:59:02,128][INFO][node] [Puck] initializing ...  
> > [2014-04-07 15:59:02,224][INFO][plugins] [Puck] loaded [mongodb-river,  
> > mapper-attachments, marvel], sites [river-mongodb, marvel]  
> > [2014-04-07 15:59:04,553][INFO][node] [Puck] initialized  
> > [2014-04-07 15:59:04,553][INFO][node] [Puck] starting ...  
> > [2014-04-07 15:59:04,665][INFO][transport] [Puck] bound\_address {inet[/127.0.0.1:9302]},  
> > publish\_address {inet[/127.0.0.1:9302]}  
> > [2014-04-07 15:59:07,727][INFO][cluster.service] [Puck] new\_master  
> > [Puck][gtub58OkR9SskDE0SfYobw][inet[/127.0.0.1:9302]], reason:  
> > zen-disco-join (elected\_as\_master)  
> > [2014-04-07 15:59:07,778][INFO][discovery] [Puck]  
> > elasticsearch\_dannyjoris/gtub58OkR9SskDE0SfYobw  
> > [2014-04-07 15:59:07,795][INFO][http] [Puck] bound\_address {inet[/127.0  
> > .0.1:9202]}, publish\_address {inet[/127.0.0.1:9202]}  
> > [2014-04-07 15:59:07,796][INFO][node] [Puck] started  
> > [2014-04-07 15:59:07,813][INFO][gateway] [Puck] recovered [0] indices  
> > into cluster\_state  
> > [2014-04-07 15:59:09,589][ERROR][marvel.agent.exporter] error  
> > connecting to [localhost:9200]  
> > java.net.SocketTimeoutException: connect timed out  
> > at java.net.PlainSocketImpl.socketConnect(Native Method)  
> > at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382)  
> > at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241)  
> > at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228)  
> > at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:431)  
> > at java.net.Socket.connect(Socket.java:527)  
> > at sun.net.NetworkClient.doConnect(NetworkClient.java:158)  
> > at sun.net.www.http.HttpClient.openServer(HttpClient.java:424)  
> > at sun.net.www.http.HttpClient.openServer(HttpClient.java:538)  
> > at sun.net.www.http.HttpClient.(HttpClient.java:214)  
> > at sun.net.www.http.HttpClient.New(HttpClient.java:300)\</sp
> > 
> > ...
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com)[https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/11c54ef0-6cdd-4f2d-86f3-7c795fe861d6%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/11c54ef0-6cdd-4f2d-86f3-7c795fe861d6%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Danny\_Joris](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/danny_joris/32/1646_2.png) [@Danny\_Joris](https://discuss.elastic.co/u/Danny_Joris)\
**Post date:** [April 7, 2014, 9:17pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857/6 "2014-04-07T21:17:39Z")

</div>

Removing Marvel worked using  
plugin --remove Marvel

Seems like Elasticsearch starts correctly again. Not sure why Marvel became  
a culprit here as I haven't used it since I first installed it when it came  
out. I also didn't update Elasticsearch or any of the other plugins since.

Thanks for your fast response, David.

On Monday, 7 April 2014 18:13:33 UTC-3, Danny Joris wrote:

> > > curl -XGET '[http://127.0.0.1:9200/](http://127.0.0.1:9200/)'
> 
> curl: (7) Failed connect to 127.0.0.1:9200; Operation timed out
> 
> Removing or updating network.host to localhost has the same result when  
> trying to start elasticsearch.
> 
> I'll try to remove the marvel plugin and see what it does.
> 
> On Monday, 7 April 2014 18:05:28 UTC-3, David Pilato wrote:
> 
> > Can you tell why do you think it's not working anymore?
> > 
> > What gives GET /localhost:9200
> > 
> > Also, could you try to modify  
> > network.host: 127.0.0.1
> > 
> > And unset it or set it to
> > 
> > network.host: localhost
> > 
> > --  
> > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > 
> > Le 7 avril 2014 à 23:02:27, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)) a écrit:
> > 
> > Elasticsearch.yml file:  
> > [elasticsearch.yml · GitHub](https://gist.github.com/DannyJoris/bb559005aad7f0bb1f10)
> > 
> > I don't know why it stopped working. I've had ES running for a while.  
> > Restarted it several times even over the past months without problems. I  
> > made a simple query change on Kibana and it stopped working and I can't  
> > start it up again.
> > 
> > Oh, and I wasn't using the Marvel interface when it went wrong. Though I  
> > did install the Marvel plugin quite a while ago, but I never really used it.
> > 
> > Danny
> > 
> > On Monday, 7 April 2014 17:53:49 UTC-3, David Pilato wrote:
> > 
> > > I answered this on SOF:
> > > 
> > > The error you mentioned does not mean that your elasticsearch node is  
> > > not working but only that it could not contact your Marvel node.
> > > 
> > > Why do you think it's not working?
> > > 
> > > Could you also gist your elasticsearch.yml file?
> > > 
> > > ```
> > > -- 
> > > 
> > > ```
> > > 
> > > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> > > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > > 
> > > Le 7 avril 2014 à 22:47:47, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)) a écrit:
> > > 
> > > After making a simple change on a query in Kibana, my Elasticsearch  
> > > instance stopped working and I can't start it up again. I'm using ES 0.90.9  
> > > on OSX using homebrew.
> > > 
> > > Normally I would use this to start ES:  
> > > elasticsearch -f -D  
> > > es.config=/usr/local/opt/elasticsearch/config/elasticsearch.yml
> > > 
> > > This however throws out a repeated error:
> > > 
> > > [2014-04-07 15:59:02,128][INFO][node] [Puck] initializing ...  
> > > [2014-04-07 15:59:02,224][INFO][plugins] [Puck] loaded [mongodb-river,  
> > > mapper-attachments, marvel], sites [river-mongodb, marvel]  
> > > [2014-04-07 15:59:04,553][INFO][node] [Puck] initialized  
> > > [2014-04-07 15:59:04,553][INFO][node] [Puck] starting ...  
> > > [2014-04-07 15:59:04,665][INFO][transport] [Puck] bound\_address {inet[/127.0.0.1:9302]},  
> > > publish\_address {inet[/127.0.0.1:9302]}  
> > > [2014-04-07 15:59:07,727][INFO][cluster.service] [Puck] new\_master  
> > > [Puck][gtub58OkR9SskDE0SfYobw][inet[/127.0.0.1:9302]], reason:  
> > > zen-disco-join (elected\_as\_master)  
> > > [2014-04-07 15:59:07,778][INFO][discovery] [Puck]  
> > > elasticsearch\_dannyjoris/gtub58OkR9SskDE0SfYobw  
> > > [2014-04-07 15:59:07,795][INFO][http] [Puck] bound\_address {inet[/  
> > > 127.0.0.1:9202]}, publish\_address {inet[/127.0.0.1:9202]}  
> > > [2014-04-07 15:59:07,796][INFO][node] [Puck] started  
> > > [2014-04-07 15:59:07,813][INFO][gateway] [Puck] recovered [0] indices  
> > > into cluster\_state  
> > > [2014-04-07 15:59:09,589][ERROR][marvel.agent.exporter] error  
> > > connecting to [localhost:9200]  
> > > java.net.SocketTimeoutException: connect timed out  
> > > at java.net.PlainSocketImpl.socketConnect(Native Method)  
> > > at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382)  
> > > at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241)  
> > > at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228)  
> > > at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:431)  
> > > at java.net.Socket.connect(Socket.java:527)  
> > > at sun.net.NetworkClient.doConnect(NetworkClient.java:158)  
> > > at sun.net.www.http.HttpClient.openServer(HttpClient.java:424)  
> > > at sun.net.www.http.HttpClient.openServer(HttpClient.java:538)  
> > > at sun.net.www.http.HttpClient.(HttpClient.java:214)  
> > > at sun.net.www.http.HttpClient.New(HttpClient.java:300)\</sp
> > > 
> > > ...
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an  
> > email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com)[https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/490609ae-5989-4d36-ab78-ab345267b053%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/490609ae-5989-4d36-ab78-ab345267b053%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 7, 2014, 9:18pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857/7 "2014-04-07T21:18:42Z")

</div>

I guess you installed Marvel some time ago and did not restart your node?

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 7 avril 2014 à 23:17:44, Danny Joris ([danny\_joris@yahoo.co.uk](mailto:danny_joris@yahoo.co.uk)) a écrit:

Removing Marvel worked using  
plugin --remove Marvel

Seems like Elasticsearch starts correctly again. Not sure why Marvel became a culprit here as I haven't used it since I first installed it when it came out. I also didn't update Elasticsearch or any of the other plugins since.

Thanks for your fast response, David.

On Monday, 7 April 2014 18:13:33 UTC-3, Danny Joris wrote:

> > curl -XGET '[http://127.0.0.1:9200/](http://127.0.0.1:9200/)'  
> > curl: (7) Failed connect to 127.0.0.1:9200; Operation timed out

Removing or updating network.host to localhost has the same result when trying to start elasticsearch.

I'll try to remove the marvel plugin and see what it does.

On Monday, 7 April 2014 18:05:28 UTC-3, David Pilato wrote:  
Can you tell why do you think it's not working anymore?

What gives GET /localhost:9200

Also, could you try to modify

network.host:  
127.0.0.1

And unset it or set it to

network.host:  
localhost

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 7 avril 2014 à 23:02:27, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)) a écrit:

Elasticsearch.yml file: [elasticsearch.yml · GitHub](https://gist.github.com/DannyJoris/bb559005aad7f0bb1f10)

I don't know why it stopped working. I've had ES running for a while. Restarted it several times even over the past months without problems. I made a simple query change on Kibana and it stopped working and I can't start it up again.

Oh, and I wasn't using the Marvel interface when it went wrong. Though I did install the Marvel plugin quite a while ago, but I never really used it.

Danny

On Monday, 7 April 2014 17:53:49 UTC-3, David Pilato wrote:  
I answered this on SOF:

The error you mentioned does not mean that your elasticsearch node is not working but only that it could not contact your Marvel node.

Why do you think it's not working?

Could you also gist your elasticsearch.yml file?

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 7 avril 2014 à 22:47:47, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)) a écrit:

After making a simple change on a query in Kibana, my Elasticsearch instance stopped working and I can't start it up again. I'm using ES 0.90.9 on OSX using homebrew.

Normally I would use this to start ES:  
elasticsearch -f -D es.config=/usr/local/opt/elasticsearch/config/elasticsearch.yml

## This however throws out a repeated error: [2014-04-07 15:59:02,128][INFO][node] [Puck] initializing ... [2014-04-07 15:59:02,224][INFO][plugins] [Puck] loaded [mongodb-river, mapper-attachments, marvel], sites [river-mongodb, marvel] [2014-04-07 15:59:04,553][INFO][node] [Puck] initialized [2014-04-07 15:59:04,553][INFO][node] [Puck] starting ... [2014-04-07 15:59:04,665][INFO][transport] [Puck] bound\_address {inet[/127.0.0.1:9302]}, publish\_address {inet[/127.0.0.1:9302]} [2014-04-07 15:59:07,727][INFO][cluster.service] [Puck] new\_master [Puck][gtub58OkR9SskDE0SfYobw][inet[/127.0.0.1:9302]], reason: zen-disco-join (elected\_as\_master) [2014-04-07 15:59:07,778][INFO][discovery] [Puck] elasticsearch\_dannyjoris/gtub58OkR9SskDE0SfYobw [2014-04-07 15:59:07,795][INFO][http] [Puck] bound\_address {inet[/127.0.0.1:9202]}, publish\_address {inet[/127.0.0.1:9202]} [2014-04-07 15:59:07,796][INFO][node] [Puck] started [2014-04-07 15:59:07,813][INFO][gateway] [Puck] recovered [0] indices into cluster\_state [2014-04-07 15:59:09,589][ERROR][marvel.agent.exporter] error connecting to [localhost:9200] java.net.SocketTimeoutException: connect timed out at java.net.PlainSocketImpl.socketConnect(Native Method) at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382) at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241) at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228) at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:431) at java.net.Socket.connect(Socket.java:527) at sun.net.NetworkClient.doConnect(NetworkClient.java:158) at sun.net.www.http.HttpClient.openServer(HttpClient.java:424) at sun.net.www.http.HttpClient.openServer(HttpClient.java:538) at sun.net.www.http.HttpClient.(HttpClient.java:214) at sun.net.www.http.HttpClient.New(HttpClient.java:300)\</sp ...

## You received this message because you are subscribed to the Google Groups "elasticsearch" group. To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com). To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com). For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/490609ae-5989-4d36-ab78-ab345267b053%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/490609ae-5989-4d36-ab78-ab345267b053%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/etPan.53431632.74b0dc51.164d%40MacBook-Air-de-David.local](https://groups.google.com/d/msgid/elasticsearch/etPan.53431632.74b0dc51.164d%40MacBook-Air-de-David.local).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Danny\_Joris](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/danny_joris/32/1646_2.png) [@Danny\_Joris](https://discuss.elastic.co/u/Danny_Joris)\
**Post date:** [April 7, 2014, 9:31pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857/8 "2014-04-07T21:31:00Z")

</div>

Possibly.

now this returns no hits: GET localhost:9200/\_search

Shouldn't this at least return my \_river and kibana dashboard settings?

I had an index with documents as well. No big deal if it's gone as it's  
just data imported from mongodb through a river. Though I hope I didn't  
lose the mapping.

On Monday, 7 April 2014 18:18:42 UTC-3, David Pilato wrote:

> I guess you installed Marvel some time ago and did not restart your node?
> 
> --  
> _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> 
> Le 7 avril 2014 à 23:17:44, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)\<javascript:\>)  
> a écrit:
> 
> Removing Marvel worked using  
> plugin --remove Marvel
> 
> Seems like Elasticsearch starts correctly again. Not sure why Marvel  
> became a culprit here as I haven't used it since I first installed it when  
> it came out. I also didn't update Elasticsearch or any of the other plugins  
> since.
> 
> Thanks for your fast response, David.
> 
> On Monday, 7 April 2014 18:13:33 UTC-3, Danny Joris wrote:
> 
> > > curl -XGET '[http://127.0.0.1:9200/](http://127.0.0.1:9200/)'
> 
> curl: (7) Failed connect to 127.0.0.1:9200; Operation timed out
> 
> Removing or updating network.host to localhost has the same result when  
> trying to start elasticsearch.
> 
> I'll try to remove the marvel plugin and see what it does.
> 
> On Monday, 7 April 2014 18:05:28 UTC-3, David Pilato wrote:
> 
> Can you tell why do you think it's not working anymore?
> 
> What gives GET /localhost:9200
> 
> Also, could you try to modify  
> network.host: 127.0.0.1
> 
> And unset it or set it to
> 
> network.host: localhost
> 
> --  
> _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> 
> Le 7 avril 2014 à 23:02:27, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)) a écrit:
> 
> Elasticsearch.yml file:  
> [elasticsearch.yml · GitHub](https://gist.github.com/DannyJoris/bb559005aad7f0bb1f10)
> 
> I don't know why it stopped working. I've had ES running for a while.  
> Restarted it several times even over the past months without problems. I  
> made a simple query change on Kibana and it stopped working and I can't  
> start it up again.
> 
> Oh, and I wasn't using the Marvel interface when it went wrong. Though I  
> did install the Marvel plugin quite a while ago, but I never really used it.
> 
> Danny
> 
> On Monday, 7 April 2014 17:53:49 UTC-3, David Pilato wrote:
> 
> I answered this on SOF:
> 
> The error you mentioned does not mean that your elasticsearch node is  
> not working but only that it could not contact your Marvel node.
> 
> Why do you think it's not working?
> 
> Could you also gist your elasticsearch.yml file?
> 
> ```
> -- 
> 
> ```
> 
> _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> 
> Le 7 avril 2014 à 22:47:47, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)) a écrit:
> 
> After making a simple change on a query in Kibana, my Elasticsearch  
> instance stopped working and I can't start it up again. I'm using ES 0.90.9  
> on OSX using homebrew.
> 
> Normally I would use this to start ES:  
> elasticsearch -f -D  
> es.config=/usr/local/opt/elasticsearch/config/elasticsearch.yml
> 
> This however throws out a repeated error:
> 
> [2014-04-07 15:59:02,128][INFO][node] [Puck] initializing ...  
> [2014-04-07 15:59:02,224][INFO][plugins] [Puck] loaded [mongodb-river,  
> mapper-attachments, marvel], sites [river-mongodb, marvel]  
> [2014-04-07 15:59:04,553][INFO][node] [Puck] initialized  
> [2014-04-07 15:59:04,553][INFO][node] [Puck] starting ...  
> [2014-04-07 15:59:04,665][INFO][transport] [Puck] bound\_address {inet[/127.0.0.1:9302]},  
> publish\_address {inet[/127.0.0.1:9302]}  
> [2014-04-07 15:59:07,727][INFO][cluster.service] [Puck] new\_master  
> [Puck][gtub58OkR9SskDE0SfYobw][inet[/127.0.0.1:9302]], reason:  
> zen-disco-join (elected\_as\_master)  
> [2014-04-07 15:59:07,778][INFO][discovery] [Puck]  
> elasticsearch\_dannyjoris/gtub58OkR9SskDE0SfYobw  
> [2014-04-07 15:59:07,795][INFO][http] [Puck] bound\_address {inet[/127.0.  
> 0.1:9202]}, publish\_address {inet[/127.0.0.1:9202]}  
> [2014-04-07 15:59:07,796][INFO][node] [Puck] started  
> [2014-04-07 15:59:07,813][INFO][gateway] [Puck] recovered [0] indices  
> into cluster\_state  
> [2014-04-07 15:59:09,589][ERROR][marvel.agent.exporter] error connecting  
> to [localhost:9200]  
> java.net.SocketTimeoutException: connect timed out  
> at java.net.PlainSocketImpl.socketConnect(Native Method)  
> at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382)  
> at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241)  
> at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228)  
> at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:431)  
> at java.net.Socket.connect(Socket.java:527)  
> at sun.net.NetworkClient.doConnect(NetworkClient.java:158)  
> at sun.net.www.http.HttpClient.openServer(HttpClient.java:424)  
> at sun.net.www.http.HttpClient.openServer(HttpClient.java:538)  
> at sun.net.www.http.HttpClient.(HttpClient.java:214)  
> at sun.net.www.http.HttpClient.New(HttpClient.java:300)\</sp
> 
> ...
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com)[https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> 
> ...

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/06118f00-1fc8-42b7-9850-76e1832bb0b7%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/06118f00-1fc8-42b7-9850-76e1832bb0b7%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Danny\_Joris](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/danny_joris/32/1646_2.png) [@Danny\_Joris](https://discuss.elastic.co/u/Danny_Joris)\
**Post date:** [April 7, 2014, 9:43pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857/9 "2014-04-07T21:43:43Z")

</div>

I guess there is a difference for network.host. If I keep it to either  
127.0.0.1 or localhost, pinging ES will time out. If I remove the  
network.host line it won't. (but still no data results)

On Monday, 7 April 2014 18:31:00 UTC-3, Danny Joris wrote:

> Possibly.
> 
> now this returns no hits: GET localhost:9200/\_search
> 
> Shouldn't this at least return my \_river and kibana dashboard settings?
> 
> I had an index with documents as well. No big deal if it's gone as it's  
> just data imported from mongodb through a river. Though I hope I didn't  
> lose the mapping.
> 
> On Monday, 7 April 2014 18:18:42 UTC-3, David Pilato wrote:
> 
> > I guess you installed Marvel some time ago and did not restart your node?
> > 
> > --  
> > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > 
> > Le 7 avril 2014 à 23:17:44, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)) a écrit:
> > 
> > Removing Marvel worked using  
> > plugin --remove Marvel
> > 
> > Seems like Elasticsearch starts correctly again. Not sure why Marvel  
> > became a culprit here as I haven't used it since I first installed it when  
> > it came out. I also didn't update Elasticsearch or any of the other plugins  
> > since.
> > 
> > Thanks for your fast response, David.
> > 
> > On Monday, 7 April 2014 18:13:33 UTC-3, Danny Joris wrote:
> > 
> > > > curl -XGET '[http://127.0.0.1:9200/](http://127.0.0.1:9200/)'
> > 
> > curl: (7) Failed connect to 127.0.0.1:9200; Operation timed out
> > 
> > Removing or updating network.host to localhost has the same result when  
> > trying to start elasticsearch.
> > 
> > I'll try to remove the marvel plugin and see what it does.
> > 
> > On Monday, 7 April 2014 18:05:28 UTC-3, David Pilato wrote:
> > 
> > Can you tell why do you think it's not working anymore?
> > 
> > What gives GET /localhost:9200
> > 
> > Also, could you try to modify  
> > network.host: 127.0.0.1
> > 
> > And unset it or set it to
> > 
> > network.host: localhost
> > 
> > --  
> > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > 
> > Le 7 avril 2014 à 23:02:27, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)) a écrit:
> > 
> > Elasticsearch.yml file:  
> > [elasticsearch.yml · GitHub](https://gist.github.com/DannyJoris/bb559005aad7f0bb1f10)
> > 
> > I don't know why it stopped working. I've had ES running for a while.  
> > Restarted it several times even over the past months without problems. I  
> > made a simple query change on Kibana and it stopped working and I can't  
> > start it up again.
> > 
> > Oh, and I wasn't using the Marvel interface when it went wrong. Though I  
> > did install the Marvel plugin quite a while ago, but I never really used it.
> > 
> > Danny
> > 
> > On Monday, 7 April 2014 17:53:49 UTC-3, David Pilato wrote:
> > 
> > I answered this on SOF:
> > 
> > The error you mentioned does not mean that your elasticsearch node is  
> > not working but only that it could not contact your Marvel node.
> > 
> > Why do you think it's not working?
> > 
> > Could you also gist your elasticsearch.yml file?
> > 
> > ```
> > -- 
> > 
> > ```
> > 
> > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > 
> > Le 7 avril 2014 à 22:47:47, Danny Joris ([danny...@yahoo.co.uk](mailto:danny...@yahoo.co.uk)) a écrit:
> > 
> > After making a simple change on a query in Kibana, my Elasticsearch  
> > instance stopped working and I can't start it up again. I'm using ES 0.90.9  
> > on OSX using homebrew.
> > 
> > Normally I would use this to start ES:  
> > elasticsearch -f -D  
> > es.config=/usr/local/opt/elasticsearch/config/elasticsearch.yml
> > 
> > This however throws out a repeated error:
> > 
> > [2014-04-07 15:59:02,128][INFO][node] [Puck] initializing ...  
> > [2014-04-07 15:59:02,224][INFO][plugins] [Puck] loaded [mongodb-river,  
> > mapper-attachments, marvel], sites [river-mongodb, marvel]  
> > [2014-04-07 15:59:04,553][INFO][node] [Puck] initialized  
> > [2014-04-07 15:59:04,553][INFO][node] [Puck] starting ...  
> > [2014-04-07 15:59:04,665][INFO][transport] [Puck] bound\_address {inet[/127.0.0.1:9302]},  
> > publish\_address {inet[/127.0.0.1:9302]}  
> > [2014-04-07 15:59:07,727][INFO][cluster.service] [Puck] new\_master  
> > [Puck][gtub58OkR9SskDE0SfYobw][inet[/127.0.0.1:9302]], reason:  
> > zen-disco-join (elected\_as\_master)  
> > [2014-04-07 15:59:07,778][INFO][discovery] [Puck]  
> > elasticsearch\_dannyjoris/gtub58OkR9SskDE0SfYobw  
> > [2014-04-07 15:59:07,795][INFO][http] [Puck] bound\_address {inet[/127.0  
> > .0.1:9202]}, publish\_address {inet[/127.0.0.1:9202]}  
> > [2014-04-07 15:59:07,796][INFO][node] [Puck] started  
> > [2014-04-07 15:59:07,813][INFO][gateway] [Puck] recovered [0] indices  
> > into cluster\_state  
> > [2014-04-07 15:59:09,589][ERROR][marvel.agent.exporter] error  
> > connecting to [localhost:9200]  
> > java.net.SocketTimeoutException: connect timed out  
> > at java.net.PlainSocketImpl.socketConnect(Native Method)  
> > at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382)  
> > at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241)  
> > at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228)  
> > at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:431)  
> > at java.net.Socket.connect(Socket.java:527)  
> > at sun.net.NetworkClient.doConnect(NetworkClient.java:158)  
> > at sun.net.www.http.HttpClient.openServer(HttpClient.java:424)  
> > at sun.net.www.http.HttpClient.openServer(HttpClient.java:538)  
> > at sun.net.www.http.HttpClient.(HttpClient.java:214)  
> > at sun.net.www.http.HttpClient.New(HttpClient.java:300)\</sp
> > 
> > ...
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an  
> > email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com)[https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/0ce9a89f-48ce-4197-8c13-a36f0ac8f762%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > 
> > ...

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/1913e64e-5f7e-4529-92d4-28ecdc823297%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/1913e64e-5f7e-4529-92d4-28ecdc823297%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:37am UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-anymore/16857/10 "2017-07-06T01:37:44Z")

</div>


