# Elasticsearch X-Pack plugin breaks elasticsearch

**URL:** <https://discuss.elastic.co/t/elasticsearch-x-pack-plugin-breaks-elasticsearch/82051>\
**Category:** Elasticsearch\
**Created:** [April 11, 2017, 9:07pm UTC](https://discuss.elastic.co/t/elasticsearch-x-pack-plugin-breaks-elasticsearch/82051 "2017-04-11T21:07:11Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![banderson](https://avatars.discourse-cdn.com/v4/letter/b/a8b319/32.png) [@banderson](https://discuss.elastic.co/u/banderson)\
**Post date:** [April 11, 2017, 9:07pm UTC](https://discuss.elastic.co/t/elasticsearch-x-pack-plugin-breaks-elasticsearch/82051/1 "2017-04-11T21:07:11Z")

</div>

I installed elasticsearch 5.3 and kibana 5.3 using the RPM repository on a Red Hat Enterprise Server running version 7. Then I installed the x-pack plugins using the "bin/kibana-plugin install x-pack" and "bin/kibana-plugin install x-pack" commands. Both plugin installs finished with no errors.  
Both elasticsearch and kibana were working before I installed the x-pack plugins in both. Now elastic search dies after starting. In the elasticsearch log is "org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: Could not load plugin descriptor for existing plugin [x-pack]. Was the plugin built before 2.0?". Is the elasticsearch x-pack plugin not compatible with 5.3?

---

<div class="post-metadata">

**Author:** ![Ryan\_Groten](https://avatars.discourse-cdn.com/v4/letter/r/f9ae1b/32.png) [@Ryan\_Groten](https://discuss.elastic.co/u/Ryan_Groten)\
**Post date:** [April 11, 2017, 9:21pm UTC](https://discuss.elastic.co/t/elasticsearch-x-pack-plugin-breaks-elasticsearch/82051/2 "2017-04-11T21:21:53Z")

</div>

What output do you get when you run this?  
`bin/elasticsearch-plugin list`

---

<div class="post-metadata">

**Author:** ![banderson](https://avatars.discourse-cdn.com/v4/letter/b/a8b319/32.png) [@banderson](https://discuss.elastic.co/u/banderson)\
**Post date:** [April 11, 2017, 9:24pm UTC](https://discuss.elastic.co/t/elasticsearch-x-pack-plugin-breaks-elasticsearch/82051/3 "2017-04-11T21:24:49Z")

</div>

```
bin/elasticsearch-plugin list
x-pack
```

---

<div class="post-metadata">

**Author:** ![Ryan\_Groten](https://avatars.discourse-cdn.com/v4/letter/r/f9ae1b/32.png) [@Ryan\_Groten](https://discuss.elastic.co/u/Ryan_Groten)\
**Post date:** [April 11, 2017, 9:32pm UTC](https://discuss.elastic.co/t/elasticsearch-x-pack-plugin-breaks-elasticsearch/82051/4 "2017-04-11T21:32:34Z")

</div>

Last time I got this error it was a permission issue on the x-pack plugin directory (I installed x-pack as root, and the elasticsearch user could not read the directory `/usr/share/elasticsearch/plugins/x-pack`). The specific error I got was "AccessDeniedException" but it was buried in the long stack trace.

```
 org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: Could not load plugin descriptor for existing plugin [x-pack]. Was the plugin built before 2.0?
 ...<snip>
Caused by: java.nio.file.AccessDeniedException: /usr/share/elasticsearch/plugins/x-pack/plugin-descriptor.properties
```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 11, 2017, 10:37pm UTC](https://discuss.elastic.co/t/elasticsearch-x-pack-plugin-breaks-elasticsearch/82051/5 "2017-04-11T22:37:09Z")

</div>

Did you by any chance added a zip file in elasticsearch plugins dir? Could you ls -l it?

---

<div class="post-metadata">

**Author:** ![banderson](https://avatars.discourse-cdn.com/v4/letter/b/a8b319/32.png) [@banderson](https://discuss.elastic.co/u/banderson)\
**Post date:** [April 12, 2017, 7:27am UTC](https://discuss.elastic.co/t/elasticsearch-x-pack-plugin-breaks-elasticsearch/82051/6 "2017-04-12T07:27:56Z")

</div>

Changing the permissions of the plugin folder and files fixed this problem. Now I am having trouble with Kibana. I will start a new topic for the new issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 10, 2017, 7:35am UTC](https://discuss.elastic.co/t/elasticsearch-x-pack-plugin-breaks-elasticsearch/82051/7 "2017-05-10T07:35:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
