# Elasticsearch 'xpack.security.transport.ssl' related error after upgrade to 8.x

**URL:** <https://discuss.elastic.co/t/elasticsearch-xpack-security-transport-ssl-related-error-after-upgrade-to-8-x/366387>\
**Category:** Elasticsearch\
**Created:** [September 11, 2024, 7:50am UTC](https://discuss.elastic.co/t/elasticsearch-xpack-security-transport-ssl-related-error-after-upgrade-to-8-x/366387 "2024-09-11T07:50:26Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![kotsobot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kotsobot/32/137514_2.png) [@kotsobot](https://discuss.elastic.co/u/kotsobot)\
**Post date:** [September 11, 2024, 7:50am UTC](https://discuss.elastic.co/t/elasticsearch-xpack-security-transport-ssl-related-error-after-upgrade-to-8-x/366387/1 "2024-09-11T07:50:26Z")

</div>

Hi all, after upgrading elasticsearch (deployed in k8s) from 7.17.3 to 8.5, elasticsearch cannot start due to error:

```auto
[2024-09-11T07:22:27,949][ERROR][o.e.b.Elasticsearch] [a-elasticsearch-master-0] fatal exception while booting Elasticsearch
org.elasticsearch.ElasticsearchSecurityException: failed to load SSL configuration [xpack.security.transport.ssl] - cannot specify both [certificate] and [keystore.path]

```

Related configuration:

```auto
xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.keystore.path: /usr/share/elasticsearch/config/certs/elastic-certificates.p12
xpack.security.transport.ssl.truststore.path: /usr/share/elasticsearch/config/certs/elastic-certificates.p12
xpack.security.http.ssl.enabled: true
xpack.security.http.ssl.truststore.path: /usr/share/elasticsearch/config/certs/elastic-certificates.p12
xpack.security.http.ssl.keystore.path: /usr/share/elasticsearch/config/certs/elastic-certificates.p12

```

Note that with 7.17.3 this issue was not there.

Any ideas?
