# Elasticsearch.yml made an error after adding \[bootstrap.mlockall: true\]. The version used was 5.6.3

**URL:** <https://discuss.elastic.co/t/elasticsearch-yml-made-an-error-after-adding-bootstrap-mlockall-true-the-version-used-was-5-6-3/108660>\
**Category:** Elasticsearch\
**Created:** [November 22, 2017, 7:32am UTC](https://discuss.elastic.co/t/elasticsearch-yml-made-an-error-after-adding-bootstrap-mlockall-true-the-version-used-was-5-6-3/108660 "2017-11-22T07:32:55Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![648007679](https://avatars.discourse-cdn.com/v4/letter/6/dec6dc/32.png) [@648007679](https://discuss.elastic.co/u/648007679)\
**Post date:** [November 22, 2017, 7:32am UTC](https://discuss.elastic.co/t/elasticsearch-yml-made-an-error-after-adding-bootstrap-mlockall-true-the-version-used-was-5-6-3/108660/1 "2017-11-22T07:32:55Z")

</div>

Hi  
elasticsearch.yml is after adding [bootstrap.mlockall: true],An error occurred while the program was started:  
uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [bootstrap.mlockall] please check that any required plugins are installed, or check the breaking changes documentation for removed settings  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:123) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:70) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.6.3.jar:5.6.3]  
Caused by: java.lang.IllegalArgumentException: unknown setting [bootstrap.mlockall] please check that any required plugins are installed, or check the breaking changes documentation for removed settings

---

<div class="post-metadata">

**Author:** ![xavierfacq](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xavierfacq/32/8744_2.png) [@xavierfacq](https://discuss.elastic.co/u/xavierfacq)\
**Post date:** [November 22, 2017, 8:39am UTC](https://discuss.elastic.co/t/elasticsearch-yml-made-an-error-after-adding-bootstrap-mlockall-true-the-version-used-was-5-6-3/108660/2 "2017-11-22T08:39:51Z")

</div>

> [@648007679](#):
>
> unknown setting [bootstrap.mlockall

You need to read the doc [Important Elasticsearch configuration | Elasticsearch Reference [5.6] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/5.6/important-settings.html#bootstrap.memory_lock)

---

<div class="post-metadata">

**Author:** ![aholbreich](https://avatars.discourse-cdn.com/v4/letter/a/d6d6ee/32.png) [@aholbreich](https://discuss.elastic.co/u/aholbreich)\
**Post date:** [November 22, 2017, 10:15am UTC](https://discuss.elastic.co/t/elasticsearch-yml-made-an-error-after-adding-bootstrap-mlockall-true-the-version-used-was-5-6-3/108660/3 "2017-11-22T10:15:19Z")

</div>

In 5.6.3 it called:

> bootstrap.memory\_lock: true

---

<div class="post-metadata">

**Author:** ![648007679](https://avatars.discourse-cdn.com/v4/letter/6/dec6dc/32.png) [@648007679](https://discuss.elastic.co/u/648007679)\
**Post date:** [November 24, 2017, 5:54am UTC](https://discuss.elastic.co/t/elasticsearch-yml-made-an-error-after-adding-bootstrap-mlockall-true-the-version-used-was-5-6-3/108660/4 "2017-11-24T05:54:24Z")

</div>

thank you

---

<div class="post-metadata">

**Author:** ![648007679](https://avatars.discourse-cdn.com/v4/letter/6/dec6dc/32.png) [@648007679](https://discuss.elastic.co/u/648007679)\
**Post date:** [November 24, 2017, 5:55am UTC](https://discuss.elastic.co/t/elasticsearch-yml-made-an-error-after-adding-bootstrap-mlockall-true-the-version-used-was-5-6-3/108660/5 "2017-11-24T05:55:45Z")

</div>

So that's it,thank you

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 22, 2017, 5:56am UTC](https://discuss.elastic.co/t/elasticsearch-yml-made-an-error-after-adding-bootstrap-mlockall-true-the-version-used-was-5-6-3/108660/6 "2017-12-22T05:56:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
