# Elasticsearchのスナップショット利用設定について

**URL:** <https://discuss.elastic.co/t/elasticsearch/87419>\
**Category:** 日本語による質問・議論はこちら\
**Created:** [May 29, 2017, 9:05am UTC](https://discuss.elastic.co/t/elasticsearch/87419 "2017-05-29T09:05:37Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jun1](https://avatars.discourse-cdn.com/v4/letter/j/f6c823/32.png) [@jun1](https://discuss.elastic.co/u/jun1)\
**Post date:** [May 29, 2017, 9:05am UTC](https://discuss.elastic.co/t/elasticsearch/87419/1 "2017-05-29T09:05:37Z")

</div>

お世話になります

Elasticsearchのスナップショットを利用しようとしています。  
バージョンはElasticsearch 5.1.2を使用しています。

スナップショット利用のためのリポジトリ登録コマンドを実行すると、  
権限不足が原因でテストデータが削除できないと読み取れるエラーが発生し、リポジトリが登録できません。  
スナップショットのテストデータが格納されるディレクトリのパーミッション変更を試しましたが、特に結果は変わりませんでした。  
elasticsearchユーザとして、直接、削除コマンドを実行すると削除できます。

同じ事象の情報や、原因調査方法など、助言をいただきたく、宜しくお願いいたします。

実施した作業は以下の通りです。  
構成はサーバ３台(ノード:３)でクラスタを組んでいます。  
discovery.zen.minimum\_master\_nodesは2を設定

スナップショットリポジトリのために  
上記クラスタとは別のサーバに共有ディレクトリを作成（NFSサービスを用いて共有）。  
共有ディレクトリをelasticsearch.ymlにpath.repoで追記して、Elasticsearch再起動

リポジトリ登録コマンドを実行  
curl -XPUT '[http://localhost:9200/\_snapshot/backup](http://localhost:9200/_snapshot/backup)' -d '  
{  
"type": "fs",  
"settings":  
{ "location" : "共有ディレクトリ",  
"compress" : true  
}  
}'

共有ディレクトリにテストデータが作成されるが、以下のエラーが発生し登録できない。  
{"error":  
{"root\_cause":[{"type":"repository\_verification\_exception","reason":"[backup] cannot delete test data at "}],  
"type" :"repository\_verification\_exception",  
"reason" :"[backup] cannot delete test data at ",  
"caused\_by" :{"type" :"i\_o\_exception",  
"reason":"Could not remove the following files (in the order of attempts):\n  
/共有ディレクトリ/tests-oBI7Wq\_lRVymdJ72tcBwEg:  
java.nio.file.FileSystemException:  
/共有ディレクトリ/tests-oBI7Wq\_lRVymdJ72tcBwEg: 許可されていない操作です\n"  
}  
},  
"status":500  
}

---

<div class="post-metadata">

**Author:** ![st1t](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/st1t/32/9188_2.png) [@st1t](https://discuss.elastic.co/u/st1t)\
**Post date:** [May 29, 2017, 10:34am UTC](https://discuss.elastic.co/t/elasticsearch/87419/2 "2017-05-29T10:34:04Z")

</div>

念のための確認となりますが、  
以下設定は問題なさそうでしょうか。

1. 全ノードで同一箇所を同一のファイルシステムとして出来ているか  
(全ノードで以下のようなマウント先設定が統一されているか等)  
`ex. NFSサーバIP:/共有ディレクトリ /mount/backups/my_backup nfs defaults 0 0`
2. 全ノードのelasticsearch.ymlにpath.repoの記載があるか
3. OS上でelasticsearchユーザとしてNFS領域にデータの追加/削除が出来るか  
`ex. sudo -u elasticsearch touch /共有ディレクトリ/hoge`

---

<div class="post-metadata">

**Author:** ![jun1](https://avatars.discourse-cdn.com/v4/letter/j/f6c823/32.png) [@jun1](https://discuss.elastic.co/u/jun1)\
**Post date:** [May 29, 2017, 11:36pm UTC](https://discuss.elastic.co/t/elasticsearch/87419/3 "2017-05-29T23:36:06Z")

</div>

返信ありがとうございます。  
ご確認の以下、３件とも問題なく設定できています。

> 1.全ノードで同一箇所を同一のファイルシステムとして出来ているか  
> (全ノードで以下のようなマウント先設定が統一されているか等)  
> ex. NFSサーバIP:/共有ディレクトリ /mount/backups/my\_backup nfs defaults 0 0  
> 2.全ノードのelasticsearch.ymlにpath.repoの記載があるか  
> 3.OS上でelasticsearchユーザとしてNFS領域にデータの追加/削除が出来るか  
> ex. sudo -u elasticsearch touch /共有ディレクトリ/hoge

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 26, 2017, 11:36pm UTC](https://discuss.elastic.co/t/elasticsearch/87419/4 "2017-06-26T23:36:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
