# Elasticsearch7.4.2 takes too long to form a cluster

**URL:** <https://discuss.elastic.co/t/elasticsearch7-4-2-takes-too-long-to-form-a-cluster/207911>\
**Category:** Elasticsearch\
**Created:** [November 14, 2019, 2:16pm UTC](https://discuss.elastic.co/t/elasticsearch7-4-2-takes-too-long-to-form-a-cluster/207911 "2019-11-14T14:16:48Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![weekyuan](https://avatars.discourse-cdn.com/v4/letter/w/85e7bf/32.png) [@weekyuan](https://discuss.elastic.co/u/weekyuan)\
**Post date:** [November 14, 2019, 2:16pm UTC](https://discuss.elastic.co/t/elasticsearch7-4-2-takes-too-long-to-form-a-cluster/207911/1 "2019-11-14T14:16:48Z")

</div>

hi，all：  
When I deploy a brand new ealsticsearch cluster, it's always difficult to quickly form a whole.After some nodes form a cluster, other individual nodes wait for several hours and have not yet joined them.This has not happened in versions prior to 7.0  
I tried to close all nodes and clean up the data directory before starting. I found that the nodes that could not join the cluster can join the cluster normally, but the normal nodes can not join the cluster.

There are usually several tips for not being able to join a cluster.

1. [m06] failed to join {m02}  
2.Caused by: org.elasticsearch.transport.ConnectTransportException: [m06][xxxx:9300] general node connection failure  
3.Caused by: org.elasticsearch.transport.TransportException: handshake failed because connection reset  
4.Caused by: java.io.IOException: Connection timed out: xxxx/xxxx:9300  
Caused by: java.io.IOException: Connection timed out  
5.Caused by: java.io.IOException: Connection reset by peer: xxxx/xxxx:9300  
Caused by: java.io.IOException: Connection reset by peer  
6.[m06] last failed join attempt was 1.9s ago, failed to join {m02}  
7.Caused by: org.elasticsearch.transport.ConnectTransportException: [m06][xxxx:9300] a channel closed while connecting

I make sure there are no special entries on the configuration, and the wrong 9300 port can also be telnet.

---

<div class="post-metadata">

**Author:** ![weekyuan](https://avatars.discourse-cdn.com/v4/letter/w/85e7bf/32.png) [@weekyuan](https://discuss.elastic.co/u/weekyuan)\
**Post date:** [November 19, 2019, 4:12am UTC](https://discuss.elastic.co/t/elasticsearch7-4-2-takes-too-long-to-form-a-cluster/207911/2 "2019-11-19T04:12:20Z")

</div>

Request support, please help me, thank you!

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 19, 2019, 7:04am UTC](https://discuss.elastic.co/t/elasticsearch7-4-2-takes-too-long-to-form-a-cluster/207911/3 "2019-11-19T07:04:03Z")

</div>

Please share your configuration. Be aware that there are a number of settings that have chnaged between 6.X and 7.X, so make sure you read the documentation.

---

<div class="post-metadata">

**Author:** ![weekyuan](https://avatars.discourse-cdn.com/v4/letter/w/85e7bf/32.png) [@weekyuan](https://discuss.elastic.co/u/weekyuan)\
**Post date:** [November 19, 2019, 7:35am UTC](https://discuss.elastic.co/t/elasticsearch7-4-2-takes-too-long-to-form-a-cluster/207911/4 "2019-11-19T07:35:19Z")

</div>

\<

# ================== Elasticsearch Configuration ===================

# ---------------------------------- Cluster -----------------------------------

cluster.name: games

# ------------------------------------ Node ------------------------------------

node.name: m01

# ----------------------------------- Paths ------------------------------------

path.data: "/data1/elasticmaster/data"  
path.logs: "/data1/elasticmaster/log"

# ----------------------------------- Memory -----------------------------------

bootstrap.memory\_lock: true

# ---------------------------------- Network -----------------------------------

network.host: 10.142.114.120  
http.port: 9200  
transport.port: 9300-9400

# --------------------------------- Discovery ----------------------------------

discovery.seed\_hosts:  
- 10.142.114.120:9300  
- 10.142.114.121:9300  
- 10.142.114.122:9300  
- 10.142.114.243:9300  
- 10.142.114.242:9300  
- 10.142.100.51:9300  
- 10.142.100.52:9300  
- 10.142.107.71:9300  
cluster.initial\_master\_nodes:  
- m01  
- m02  
- m03  
- m04  
- m05  
- m06  
- m07  
- m08

# ---------------------------------- Gateway -----------------------------------

gateway.recover\_after\_nodes: 5

# ---------------------------------- Various -----------------------------------

bootstrap.system\_call\_filter: false  
action.destructive\_requires\_name: true

### DEBUG

##logger.org.elasticsearch.discovery: TRACE  
##logger.org.elasticsearch.transport: TRACE  
##logger.org.elasticsearch.cluster.coordination: TRACE

# ---------------------------------- Security -----------------------------------

xpack.security.enabled: true  
xpack.security.audit.enabled: true  
xpack.security.transport.ssl.enabled: true  
xpack.security.transport.ssl.verification\_mode: certificate  
xpack.security.transport.ssl.keystore.path: elastic-certificates.p12  
xpack.security.transport.ssl.truststore.path: elastic-certificates.p12  
xpack.security.transport.ssl.cipher\_suites: "TLS\_RSA\_WITH\_AES\_256\_GCM\_SHA384"  
/\>

Thanks for the reply, the above is my configuration information. I have indeed reviewed the configuration documentation repeatedly. But I really can't find the reason why I can't form a whole. Please also assist in troubleshooting, thank you very much!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 17, 2019, 7:35am UTC](https://discuss.elastic.co/t/elasticsearch7-4-2-takes-too-long-to-form-a-cluster/207911/5 "2019-12-17T07:35:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
