# ElasticsearchIllegalArgumentException\[No version type match \[34\]\]; \]\]

**URL:** <https://discuss.elastic.co/t/elasticsearchillegalargumentexception-no-version-type-match-34/17730>\
**Category:** Elasticsearch\
**Created:** [May 26, 2014, 6:44pm UTC](https://discuss.elastic.co/t/elasticsearchillegalargumentexception-no-version-type-match-34/17730 "2014-05-26T18:44:45Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jorn\_Eilander](https://avatars.discourse-cdn.com/v4/letter/j/b5a626/32.png) [@Jorn\_Eilander](https://discuss.elastic.co/u/Jorn_Eilander)\
**Post date:** [May 26, 2014, 6:44pm UTC](https://discuss.elastic.co/t/elasticsearchillegalargumentexception-no-version-type-match-34/17730/1 "2014-05-26T18:44:45Z")

</div>

Hey Guys,

I have a 1 node Logstash/ElasticSearch server and the disk went full. In  
order to recover I thought I'd just delete some old indices with:

curl -XDELETE '[http://localhost:9200/logstash-2014.05.##](http://localhost:9200/logstash-2014.05.##)

Which went fine, I now have some free disk space. But then the current  
shard still wouldn't recover and I get the following messages (see below).  
I can't find anything on the "No version type match" using Google. Does  
anyone have any ideas?

[2014-05-26 20:21:08,987][INFO][node] [Vicky the  
Viking] started  
[2014-05-26 20:21:20,313][WARN][indices.cluster] [Vicky the  
Viking] [logstash-2014.05.26][0] failed to start shard  
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
[logstash-2014.05.26][0] failed to recover shard  
at  
org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:242)  
at  
org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:197)  
at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: org.elasticsearch.ElasticsearchIllegalArgumentException: No  
version type match [34]  
at  
org.elasticsearch.index.VersionType.fromValue(VersionType.java:227)  
at  
org.elasticsearch.index.translog.Translog$Create.readFrom(Translog.java:363)  
at  
org.elasticsearch.index.translog.TranslogStreams.readTranslogOperation(TranslogStreams.java:52)  
at  
org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:219)  
... 4 more  
[2014-05-26 20:21:20,343][WARN][cluster.action.shard] [Vicky the  
Viking] [logstash-2014.05.26][0] sending failed shard for  
[logstash-2014.05.26][0], node[3YVw0sg5TWOw1DCU3QkzCw], [P],  
s[INITIALIZING], indexUUID [wSalAu\_5QgeQ1KWXZxVQ6w], reason [Failed to  
start shard, message  
[IndexShardGatewayRecoveryException[[logstash-2014.05.26][0] failed to  
recover shard]; nested: ElasticsearchIllegalArgumentException[No version  
type match [34]]; ]]  
[2014-05-26 20:21:20,362][WARN][cluster.action.shard] [Vicky the  
Viking] [logstash-2014.05.26][0] received shard failed for  
[logstash-2014.05.26][0], node[3YVw0sg5TWOw1DCU3QkzCw], [P],  
s[INITIALIZING], indexUUID [wSalAu\_5QgeQ1KWXZxVQ6w], reason [Failed to  
start shard, message  
[IndexShardGatewayRecoveryException[[logstash-2014.05.26][0] failed to  
recover shard]; nested: ElasticsearchIllegalArgumentException[No version  
type match [34]]; ]]

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/3d69a0cf-dc4e-4b7a-affc-4d2076601676%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/3d69a0cf-dc4e-4b7a-affc-4d2076601676%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:26am UTC](https://discuss.elastic.co/t/elasticsearchillegalargumentexception-no-version-type-match-34/17730/2 "2017-07-06T01:26:51Z")

</div>


