# Elasticsearchkeystore

**URL:** <https://discuss.elastic.co/t/elasticsearchkeystore/294797>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [January 19, 2022, 10:49am UTC](https://discuss.elastic.co/t/elasticsearchkeystore/294797 "2022-01-19T10:49:09Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![harsh19](https://avatars.discourse-cdn.com/v4/letter/h/ed655f/32.png) [@harsh19](https://discuss.elastic.co/u/harsh19)\
**Post date:** [January 19, 2022, 10:49am UTC](https://discuss.elastic.co/t/elasticsearchkeystore/294797/1 "2022-01-19T10:49:09Z")

</div>

whenever i type ./Elasticsearch-setup-passwords auto then it gives me an error like this

```auto
Enter password for the elasticsearch keystore : 

Failed to authenticate user 'elastic' against http://127.0.0.1:9200/_security/_authenticate?pretty
Possible causes include:
 * The password for the 'elastic' user has already been changed on this cluster
 * Your elasticsearch node is running against a different keystore
   This tool used the keystore at /home/harsh/Downloads/elasticsearch-7.16.3/config/elasticsearch.keystore

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 16, 2022, 10:49am UTC](https://discuss.elastic.co/t/elasticsearchkeystore/294797/3 "2022-02-16T10:49:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
