# Elasticstack in k8s

**URL:** <https://discuss.elastic.co/t/elasticstack-in-k8s/328865>\
**Category:** Elasticsearch\
**Created:** [March 29, 2023, 8:48pm UTC](https://discuss.elastic.co/t/elasticstack-in-k8s/328865 "2023-03-29T20:48:45Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ross\_Phillips](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ross_phillips/32/119169_2.png) [@Ross\_Phillips](https://discuss.elastic.co/u/Ross_Phillips)\
**Post date:** [March 29, 2023, 8:48pm UTC](https://discuss.elastic.co/t/elasticstack-in-k8s/328865/1 "2023-03-29T20:48:45Z")

</div>

Hi all,

I'm having an issue deploying ELK on k8s. The error is shown below, any assistance is v. appreciated.

> java.lang.IllegalStateException: Unable to access 'path.logs' (/data/log)  
> Likely root cause: java.nio.file.AccessDeniedException: /data/log  
> at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:90)  
> at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)  
> at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:116)  
> at java.base/sun.nio.fs.UnixFileSystemProvider.createDirectory(UnixFileSystemProvider.java:389)  
> at java.base/java.nio.file.Files.createDirectory(Files.java:690)  
> at java.base/java.nio.file.Files.createAndCheckIsDirectory(Files.java:797)  
> at java.base/java.nio.file.Files.createDirectories(Files.java:783)  
> at org.opensearch.bootstrap.Security.ensureDirectoryExists(Security.java:424)  
> at org.opensearch.bootstrap.FilePermissionUtils.addDirectoryPath(FilePermissionUtils.java:88)  
> at org.opensearch.bootstrap.Security.addFilePermissions(Security.java:320)  
> at org.opensearch.bootstrap.Security.createPermissions(Security.java:274)  
> at org.opensearch.bootstrap.Security.configure(Security.java:137)  
> at org.opensearch.bootstrap.Bootstrap.setup(Bootstrap.java:237)  
> at org.opensearch.bootstrap.Bootstrap.init(Bootstrap.java:412)  
> at org.opensearch.bootstrap.OpenSearch.init(OpenSearch.java:178)  
> at org.opensearch.bootstrap.OpenSearch.execute(OpenSearch.java:169)  
> at org.opensearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:100)  
> at org.opensearch.cli.Command.mainWithoutErrorHandling(Command.java:138)  
> at org.opensearch.cli.Command.main(Command.java:101)  
> at org.opensearch.bootstrap.OpenSearch.main(OpenSearch.java:135)  
> at org.opensearch.bootstrap.OpenSearch.main(OpenSearch.java:101)  
> For complete error details, refer to the log at /data/log/default-nokiainfra.log  
> OpenSearch exited with code 1

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 29, 2023, 8:48pm UTC](https://discuss.elastic.co/t/elasticstack-in-k8s/328865/2 "2023-03-29T20:48:46Z")

</div>

OpenSearch/OpenDistro are AWS run products and differ from the original Elasticsearch and Kibana products that Elastic builds and maintains. You may need to contact them directly for further assistance.

(This is an automated response from your friendly Elastic bot. Please report this post if you have any suggestions or concerns :elasticheart: )

---

<div class="post-metadata">

**Author:** ![thirumoorthy](https://avatars.discourse-cdn.com/v4/letter/t/ba9def/32.png) [@thirumoorthy](https://discuss.elastic.co/u/thirumoorthy)\
**Post date:** [March 30, 2023, 6:51am UTC](https://discuss.elastic.co/t/elasticstack-in-k8s/328865/3 "2023-03-30T06:51:37Z")

</div>

Hi ..can you share your elasticsearch yaml file over here ..Because i am also trying to install elasticsearch on k8s by using helm ..

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [March 30, 2023, 7:19am UTC](https://discuss.elastic.co/t/elasticstack-in-k8s/328865/4 "2023-03-30T07:19:14Z")

</div>

As you are running Opensearch I would recommend you reach out to the Opensearch community.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 27, 2023, 7:19am UTC](https://discuss.elastic.co/t/elasticstack-in-k8s/328865/5 "2023-04-27T07:19:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
