# Elasticstart can't start on Deepin 15.3, java.lang.NoClassDefFoundError jackson/dataformat/yaml/snakeyaml/error/YAMLException

**URL:** <https://discuss.elastic.co/t/elasticstart-cant-start-on-deepin-15-3-java-lang-noclassdeffounderror-jackson-dataformat-yaml-snakeyaml-error-yamlexception/182768>\
**Category:** Elasticsearch\
**Created:** [May 25, 2019, 3:39pm UTC](https://discuss.elastic.co/t/elasticstart-cant-start-on-deepin-15-3-java-lang-noclassdeffounderror-jackson-dataformat-yaml-snakeyaml-error-yamlexception/182768 "2019-05-25T15:39:14Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![febrifahmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/febrifahmi/32/46851_2.png) [@febrifahmi](https://discuss.elastic.co/u/febrifahmi)\
**Post date:** [May 25, 2019, 3:39pm UTC](https://discuss.elastic.co/t/elasticstart-cant-start-on-deepin-15-3-java-lang-noclassdeffounderror-jackson-dataformat-yaml-snakeyaml-error-yamlexception/182768/1 "2019-05-25T15:39:14Z")

</div>

Hi,

I'm trying to run elasticsearch (fresh install) on Deepin 15.3 but it seems it stuck. Here is the error log:

Exception in thread "main" java.lang.NoClassDefFoundError: org/elasticsearch/common/jackson/dataformat/yaml/snakeyaml/error/YAMLException  
at org.elasticsearch.common.jackson.dataformat.yaml.YAMLFactory.\_createParser(YAMLFactory.java:426)  
at org.elasticsearch.common.jackson.dataformat.yaml.YAMLFactory.createParser(YAMLFactory.java:327)  
at org.elasticsearch.common.xcontent.yaml.YamlXContent.createParser(YamlXContent.java:90)  
at org.elasticsearch.common.settings.loader.XContentSettingsLoader.load(XContentSettingsLoader.java:45)  
at org.elasticsearch.common.settings.loader.YamlSettingsLoader.load(YamlSettingsLoader.java:46)  
at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:982)  
at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromUrl(ImmutableSettings.java:969)  
at org.elasticsearch.node.internal.InternalSettingsPreparer.prepareSettings(InternalSettingsPreparer.java:110)  
at org.elasticsearch.bootstrap.Bootstrap.initialSettings(Bootstrap.java:144)  
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:215)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)  
Caused by: java.lang.ClassNotFoundException: org.elasticsearch.common.jackson.dataformat.yaml.snakeyaml.error.YAMLException  
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)  
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)  
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)  
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)  
... 11 more

I'm using "/usr/lib/jvm/java-8-openjdk-amd64/", and when I run:

java -verbose:class -cp elasticsearch-1.7.6.jar:lucene-core-4.10.4.jar org.elasticsearch.Version

the result is: Error: Could not find or load main class org.elasticsearch.Version

I have read other similar topics which seems like old problems (2014-2016) and tried several solutions but to no avail.

Is there any working solution for this problem on Deepin 15.3?

---

<div class="post-metadata">

**Author:** ![Andre\_Letterer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andre_letterer/32/42248_2.png) [@Andre\_Letterer](https://discuss.elastic.co/u/Andre_Letterer)\
**Post date:** [May 26, 2019, 11:15pm UTC](https://discuss.elastic.co/t/elasticstart-cant-start-on-deepin-15-3-java-lang-noclassdeffounderror-jackson-dataformat-yaml-snakeyaml-error-yamlexception/182768/2 "2019-05-26T23:15:52Z")

</div>

Hey very welcome in the community.

At first the statement, that everything in your version is way unsupported or old like:  
Elasticsearch 1.7.6  
[https://www.elastic.co/support/eol](https://www.elastic.co/support/eol)  
Deepin 15.3 - this OS in general is not support officially  
[https://www.elastic.co/de/support/matrix](https://www.elastic.co/de/support/matrix)

I understand that you downloaded Elasticsearch 1.7.6  
[http://www.elastic.co/downloads/past-releases/elasticsearch-1.7.6](http://www.elastic.co/downloads/past-releases/elasticsearch-1.7.6)

So first - why do you want to install such old version?

Apart from that I did test your version call:

```auto
java -verbose:class -cp elasticsearch-1.7.6.jar:lucene-core-4.10.4.jar org.elasticsearch.Version

```

The error

```auto
Error: Could not find or load main class org.elasticsearch.Version

```

happens when you aren't in the correct library path where the jar files are located, so please change there at first, assuming you installed the deb package:

```auto
cd /usr/share/elasticsearch/lib

```

If you've downloaded the tar.gz just go to the lib directory.

Please still give a bit detail how you started elasticsearch.

In case you installed the deb package you can start it by  
/etc/init.d/elasticsearch start  
and under /var/log/elasticsearch/elasticsearch.log you will find the logfile.

At the moment I don't where your Exception is coming from but seems that you tried to install it from wrong directory and back then default directory still was not under /etc but under installation path in directory `config`.

if Elasticsearch is start you can always do a curl localhost:9200 and Elasticsearch should answer with some version information.

Hope that helps.

---

<div class="post-metadata">

**Author:** ![febrifahmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/febrifahmi/32/46851_2.png) [@febrifahmi](https://discuss.elastic.co/u/febrifahmi)\
**Post date:** [May 27, 2019, 5:13am UTC](https://discuss.elastic.co/t/elasticstart-cant-start-on-deepin-15-3-java-lang-noclassdeffounderror-jackson-dataformat-yaml-snakeyaml-error-yamlexception/182768/3 "2019-05-27T05:13:44Z")

</div>

Hi Andre,

Thanks for pointing me out that I installed the old version.. I didn't realised it since I install the software using apt-get.

After installed the version 7.1 from .deb package, I still got an exception when running the elasticsearch:

I started elasticsearch by running:

sudo /bin/systemctl daemon-reload  
sudo /bin/systemctl enable elasticsearch.service  
sudo systemctl start elasticsearch.service

it's active when checked using: sudo /bin/systemctl status elasticsearch.service

but I still cannot access it from localhost:9200, so I tried running it directly..

`febrifahmi@djamansusah:~$ /usr/share/elasticsearch/bin/elasticsearch
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=gasp
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=gasp
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=gasp
Exception in thread "main" java.nio.file.AccessDeniedException: /etc/elasticsearch/jvm.options
at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:90)
at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)
at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:116)
at java.base/sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:219)
at java.base/java.nio.file.Files.newByteChannel(Files.java:373)
at java.base/java.nio.file.Files.newByteChannel(Files.java:424)
at java.base/java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:420)
at java.base/java.nio.file.Files.newInputStream(Files.java:158)
at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:60)`

and another error:

`febrifahmi@djamansusah:~$ /usr/share/elasticsearch/bin/elasticsearch
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=gasp
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=gasp
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=gasp
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=gasp
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Could not rename log file '/var/log/elasticsearch/gc.log' to '/var/log/elasticsearch/gc.log.00' (Permission denied).
[0.000s][error][logging] Error opening log file '/var/log/elasticsearch/gc.log': Permission denied
[0.000s][error][logging] Initialization of output 'file=/var/log/elasticsearch/gc.log' using options 'filecount=32,filesize=64m' failed.
Invalid -Xlog option '-Xlog:gc*,gc+age=trace,safepoint:file=/var/log/elasticsearch/gc.log:utctime,pid,tags:filecount=32,filesize=64m', see error log for details.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
`

Should I chmod the /etc/elasticsearch/ directory to make it accessible?

Thanks..

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 27, 2019, 5:20am UTC](https://discuss.elastic.co/t/elasticstart-cant-start-on-deepin-15-3-java-lang-noclassdeffounderror-jackson-dataformat-yaml-snakeyaml-error-yamlexception/182768/4 "2019-05-27T05:20:12Z")

</div>

You would be better off running things via the Elasticsearch user itself if you can.

---

<div class="post-metadata">

**Author:** ![febrifahmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/febrifahmi/32/46851_2.png) [@febrifahmi](https://discuss.elastic.co/u/febrifahmi)\
**Post date:** [May 27, 2019, 7:37am UTC](https://discuss.elastic.co/t/elasticstart-cant-start-on-deepin-15-3-java-lang-noclassdeffounderror-jackson-dataformat-yaml-snakeyaml-error-yamlexception/182768/5 "2019-05-27T07:37:09Z")

</div>

Hi,

The problem is solved after i checked the elastic.log file and uncomment the 'cluster.initial\_master\_nodes' setting.

Elasticsearch is now running on my Deepin 15.3.

Thanks. 🙂

Regards

---

<div class="post-metadata">

**Author:** ![Andre\_Letterer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andre_letterer/32/42248_2.png) [@Andre\_Letterer](https://discuss.elastic.co/u/Andre_Letterer)\
**Post date:** [May 27, 2019, 10:18am UTC](https://discuss.elastic.co/t/elasticstart-cant-start-on-deepin-15-3-java-lang-noclassdeffounderror-jackson-dataformat-yaml-snakeyaml-error-yamlexception/182768/6 "2019-05-27T10:18:28Z")

</div>

Ok great, that's good news.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 24, 2019, 10:25am UTC](https://discuss.elastic.co/t/elasticstart-cant-start-on-deepin-15-3-java-lang-noclassdeffounderror-jackson-dataformat-yaml-snakeyaml-error-yamlexception/182768/7 "2019-06-24T10:25:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
