# Elastisearch-keystore error

**URL:** <https://discuss.elastic.co/t/elastisearch-keystore-error/195683>\
**Category:** Elasticsearch\
**Created:** [August 19, 2019, 7:05am UTC](https://discuss.elastic.co/t/elastisearch-keystore-error/195683 "2019-08-19T07:05:28Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Bob94](https://avatars.discourse-cdn.com/v4/letter/b/c89c15/32.png) [@Bob94](https://discuss.elastic.co/u/Bob94)\
**Post date:** [August 19, 2019, 7:05am UTC](https://discuss.elastic.co/t/elastisearch-keystore-error/195683/1 "2019-08-19T07:05:28Z")

</div>

Hi all,

I face some issue when i use this below command

elasticsearch-keystore list

And the error was like below  
Exception in thread "main" org.apache.lucene.index.corruptindexception: misplaced codec footer ....

Any help is appreciated

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [August 19, 2019, 7:27am UTC](https://discuss.elastic.co/t/elastisearch-keystore-error/195683/2 "2019-08-19T07:27:43Z")

</div>

can you share the full output, and also which Elasticsearch version you are using?

Thank you!

---

<div class="post-metadata">

**Author:** ![Bob94](https://avatars.discourse-cdn.com/v4/letter/b/c89c15/32.png) [@Bob94](https://discuss.elastic.co/u/Bob94)\
**Post date:** [August 19, 2019, 7:46am UTC](https://discuss.elastic.co/t/elastisearch-keystore-error/195683/3 "2019-08-19T07:46:37Z")

</div>

Hi alexander,

Thanks for your respond! I fixed it by overwriting that file now it works! But my concern is to send a mail notofication for a certain threshold, and this doesnt work. Below is the configuration inside my elasticsearch.yml

xpack.notification.email.account:  
outlook\_account:  
profile: outlook  
smtp:  
auth: true  
starttls.enable: true  
host: [smtp-mail.outlook.com](http://smtp-mail.outlook.com)  
port: 587  
user: mymail

The error given when i try to fire the mail is like fail to connect, no password specified?

The secure\_password was already setup in elasticsearch-keystore but the same error keep showing when i tried to fire the mails?

Any help is really appreciated

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 16, 2019, 7:46am UTC](https://discuss.elastic.co/t/elastisearch-keystore-error/195683/4 "2019-09-16T07:46:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
