# Elk 6.2.3 starting Elasticsearch Server fails

**URL:** <https://discuss.elastic.co/t/elk-6-2-3-starting-elasticsearch-server-fails/135638>\
**Category:** Elasticsearch\
**Created:** [June 13, 2018, 6:44am UTC](https://discuss.elastic.co/t/elk-6-2-3-starting-elasticsearch-server-fails/135638 "2018-06-13T06:44:11Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Gowrisankar\_M](https://avatars.discourse-cdn.com/v4/letter/g/41988e/32.png) [@Gowrisankar\_M](https://discuss.elastic.co/u/Gowrisankar_M)\
**Post date:** [June 13, 2018, 6:44am UTC](https://discuss.elastic.co/t/elk-6-2-3-starting-elasticsearch-server-fails/135638/1 "2018-06-13T06:44:11Z")

</div>

Hello,  
I am using readonlyplugin for 6.2.3 which fails as like below ? any help here ?

- Starting Elasticsearch Server Exception in thread "main" 2018-06-13 06:41:17,193 main ERROR No log4j2 configuration file found. Using default configuration: logging only errors to the console. Set system property 'log4j2.debug' to show Log4j2 internal initialization logging.  
SettingsException[Failed to load settings from [elasticsearch.yml]]; nested: IllegalStateException[only value lists are allowed in serialized settings];  
at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1187)  
at org.elasticsearch.common.settings.Settings$Builder.loadFromPath(Settings.java:1162)  
at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:99)  
at org.elasticsearch.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:95)  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)  
at org.elasticsearch.cli.Command.main(Command.java:90)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:85)  
Caused by: java.lang.IllegalStateException: only value lists are allowed in serialized settings  
at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:715)  
at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:704)  
at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:673)  
at org.elasticsearch.common.settings.Settings.access$500(Settings.java:82)  
at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1183)  
... 8 more

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [June 18, 2018, 1:57am UTC](https://discuss.elastic.co/t/elk-6-2-3-starting-elasticsearch-server-fails/135638/2 "2018-06-18T01:57:31Z")

</div>

This looks like a problem with your `elasticsearch.yml`, can you post it here?

---

<div class="post-metadata">

**Author:** ![Gowrisankar\_M](https://avatars.discourse-cdn.com/v4/letter/g/41988e/32.png) [@Gowrisankar\_M](https://discuss.elastic.co/u/Gowrisankar_M)\
**Post date:** [June 18, 2018, 1:44pm UTC](https://discuss.elastic.co/t/elk-6-2-3-starting-elasticsearch-server-fails/135638/3 "2018-06-18T13:44:20Z")

</div>

I have moved the `readonlyrest` property from the `elasticsearch.yml` into a separate `readonlyrest.yml` after that issue is fixed.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 16, 2018, 1:44pm UTC](https://discuss.elastic.co/t/elk-6-2-3-starting-elasticsearch-server-fails/135638/4 "2018-07-16T13:44:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
