# ELK 7.8.0 two node cluster "At least one primary shard for the index \[.security-7\] is unavailable"

**URL:** https://discuss.elastic.co/t/elk-7-8-0-two-node-cluster-at-least-one-primary-shard-for-the-index-security-7-is-unavailable/261031
**Category:** Elasticsearch
**Tags:** elastic-stack-security
**Created:** [January 13, 2021, 5:21pm UTC](https://discuss.elastic.co/t/elk-7-8-0-two-node-cluster-at-least-one-primary-shard-for-the-index-security-7-is-unavailable/261031 "2021-01-13T17:21:13Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![Vishnu\_Oyitty](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vishnu_oyitty/32/82195_2.png) [@Vishnu\_Oyitty](https://discuss.elastic.co/u/Vishnu_Oyitty)
#### Post date: [January 14, 2021, 9:26am UTC](https://discuss.elastic.co/t/elk-7-8-0-two-node-cluster-at-least-one-primary-shard-for-the-index-security-7-is-unavailable/261031/3 "2021-01-14T09:26:48Z")

</div>

Thank you for your reply. We tried restarting which did not help. Based on your suggestions here: [Accidentally deleted .security index for x-pack](https://discuss.elastic.co/t/accidentally-deleted-security-index-for-x-pack/69844/3)

We followed the below steps.  
We tried to reset the passwords for the built in users so that the `.security-7` index will be recreated so that the authentication issue can be fixed :

```auto
# docker exec -u elasticsearch -it elasticsearch bin/elasticsearch-setup-passwords interactive
Failed to authenticate user 'elastic' against https://10.10.206.110:9200/_security/_authenticate?pretty
Possible causes include:
 * The password for the 'elastic' user has already been changed on this cluster
 * Your elasticsearch node is running against a different keystore
   This tool used the keystore at /usr/share/elasticsearch/config/elasticsearch.keystore
ERROR: Failed to verify bootstrap password

```

Tried adding the bootstrap user on both nodes :

```auto
docker exec -u elasticsearch -it elasticsearch bin/elasticsearch-keystore add bootstrap.password

```

and restarted elastcisearch 7.8.0 on both the nodes in the cluster :

# docker restart elasticsearch

again getting the same error when resetting the built in user passwords

```auto
# docker exec -u elasticsearch -it elasticsearch bin/elasticsearch-setup-passwords interactive
Failed to authenticate user 'elastic' against https://10.180.206.110:9200/_security/_authenticate?pretty
Possible causes include:
 * The password for the 'elastic' user has already been changed on this cluster
 * Your elasticsearch node is running against a different keystore
   This tool used the keystore at /usr/share/elasticsearch/config/elasticsearch.keystore
ERROR: Failed to verify bootstrap password

```

Could you please let us know for a possible solution ?

---

_[View the full topic](https://discuss.elastic.co/t/elk-7-8-0-two-node-cluster-at-least-one-primary-shard-for-the-index-security-7-is-unavailable/261031)._
