# ELK authentiation issue

**URL:** <https://discuss.elastic.co/t/elk-authentiation-issue/184143>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [June 4, 2019, 9:59am UTC](https://discuss.elastic.co/t/elk-authentiation-issue/184143 "2019-06-04T09:59:53Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Prakash\_Rathod](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/prakash_rathod/32/44564_2.png) [@Prakash\_Rathod](https://discuss.elastic.co/u/Prakash_Rathod)\
**Post date:** [June 4, 2019, 9:59am UTC](https://discuss.elastic.co/t/elk-authentiation-issue/184143/1 "2019-06-04T09:59:53Z")

</div>

Hello Team,

While accessing kibana I've added Nginx basic auth, which after asking credentials it redirects to kibana perfectly but when I enable ES security feature (xpack.security.enable : true) kibana throwing below error.

> {"statusCode":401,"error":"Unauthorized","message":"[security\_exception] unable to authenticate user [demo] for REST request [/\_security/\_authenticate], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } }"}

nginx config file

> ```
> server {
> listen 80 default_server;
> server_name _;
> auth_basic "Restricted Area";
> auth_basic_user_file /etc/nginx/.htpasswd;
> location / {
> proxy_bind 127.0.0.1;
> proxy_pass http://127.0.0.1:5601/;}}
> 
> ```

ELasticsearch config.yml:

> cluster.name: stgmb  
> xpack.security.enabled: true  
> xpack.security.authc.accept\_default\_password: true  
> xpack.security.transport.ssl.enabled: true  
> node.name: stgmbnode-1  
> path.data: /datadisk/elasticsearch  
> path.logs: /datadisk/log/elasticsearch  
> http.port: 9200  
> discovery.seed\_hosts: ["10.0.2.109"]

Kibana & Elasticsearch version : 7.1.0

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [June 7, 2019, 4:07am UTC](https://discuss.elastic.co/t/elk-authentiation-issue/184143/2 "2019-06-07T04:07:12Z")

</div>

> [@Prakash\_Rathod](#):
>
> unable to authenticate user [demo]

Does this `demo` user exist? Can you authenticate to Elasticsearch with that user and password?

---

<div class="post-metadata">

**Author:** ![Prakash\_Rathod](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/prakash_rathod/32/44564_2.png) [@Prakash\_Rathod](https://discuss.elastic.co/u/Prakash_Rathod)\
**Post date:** [June 7, 2019, 5:46am UTC](https://discuss.elastic.co/t/elk-authentiation-issue/184143/3 "2019-06-07T05:46:19Z")

</div>

**Demo** user exist only in nginx basic auth  
I've set two authentications: one is nginx basic auth and another one is ELK auth.

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [June 7, 2019, 6:32am UTC](https://discuss.elastic.co/t/elk-authentiation-issue/184143/4 "2019-06-07T06:32:05Z")

</div>

Sorry, I don't understand what you're trying to do here.

From what you've written it looks like:

- You've enabled security in Kibana
- You have basic authentication enabled in Nginx
- You have a "demo" user in Nginx, but not in Kibana
- Nginx is passing the "demo" user credentials to Kibana
- But this user doesn't exist in Kibana, so it fails.

That all seems to be working exactly as we'd expect.  
What exactly is the issue?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2019, 6:32am UTC](https://discuss.elastic.co/t/elk-authentiation-issue/184143/5 "2019-07-05T06:32:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
