# ELK custom rule not working

**URL:** <https://discuss.elastic.co/t/elk-custom-rule-not-working/348809>\
**Category:** Elastic Security\
**Created:** [December 7, 2023, 11:46am UTC](https://discuss.elastic.co/t/elk-custom-rule-not-working/348809 "2023-12-07T11:46:18Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![Andrew\_G](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_g/32/49178_2.png) [@Andrew\_G](https://discuss.elastic.co/u/Andrew_G)\
**Post date:** [December 7, 2023, 6:36pm UTC](https://discuss.elastic.co/t/elk-custom-rule-not-working/348809/2 "2023-12-07T18:36:09Z")

</div>

Hi @theacodes , another user who encountered an `Unable to authenticate with provided credentials and anonymous access is not allowed for this request` error [here](https://discuss.elastic.co/t/unable-to-authenticate-with-provided-credentials-and-anonymous-access-is-not-allowed-for-this-request/333518/1) resolved it via the following [reply](https://discuss.elastic.co/t/unable-to-authenticate-with-provided-credentials-and-anonymous-access-is-not-allowed-for-this-request/333518/4).

---

_[View the full topic](https://discuss.elastic.co/t/elk-custom-rule-not-working/348809)._
