# ELK kibana will not authenticate in elastic - Get Kibana server not ready error

**URL:** <https://discuss.elastic.co/t/elk-kibana-will-not-authenticate-in-elastic-get-kibana-server-not-ready-error/379234>\
**Category:** Kibana\
**Tags:** elastic-stack-security\
**Created:** [June 17, 2025, 9:20am UTC](https://discuss.elastic.co/t/elk-kibana-will-not-authenticate-in-elastic-get-kibana-server-not-ready-error/379234 "2025-06-17T09:20:59Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Steant](https://avatars.discourse-cdn.com/v4/letter/s/919ad9/32.png) [@Steant](https://discuss.elastic.co/u/Steant)\
**Post date:** [June 17, 2025, 9:20am UTC](https://discuss.elastic.co/t/elk-kibana-will-not-authenticate-in-elastic-get-kibana-server-not-ready-error/379234/1 "2025-06-17T09:20:59Z")

</div>

Hi,  
I am trying to create a dependency between the ELK stack, so that every service starts with the correct order. Although I have checked that i have the correct password for kibana\_system, and the curl command from the Kibana container returns that the authentication succeeds, I still see this on my elastic logs : Authentication of [kibana\_system] was terminated by realm [reserved] - failed to authenticate user [kibana\_system]. I have also created entrypoint scripts so that the order is the following : Elastic starts, then logstash awaits and then kibana starts last.Do you have any tips?  
Kind Regards and thank you in advance.

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [June 17, 2025, 1:21pm UTC](https://discuss.elastic.co/t/elk-kibana-will-not-authenticate-in-elastic-get-kibana-server-not-ready-error/379234/2 "2025-06-17T13:21:12Z")

</div>

Hello and welcome,

Are you running on docker? You need to share your compose.
