# Elk on openshift server have limit?

**URL:** <https://discuss.elastic.co/t/elk-on-openshift-server-have-limit/316124>\
**Category:** Elasticsearch\
**Created:** [October 8, 2022, 12:03pm UTC](https://discuss.elastic.co/t/elk-on-openshift-server-have-limit/316124 "2022-10-08T12:03:10Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nikolas1306](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nikolas1306/32/111507_2.png) [@Nikolas1306](https://discuss.elastic.co/u/Nikolas1306)\
**Post date:** [October 8, 2022, 12:03pm UTC](https://discuss.elastic.co/t/elk-on-openshift-server-have-limit/316124/1 "2022-10-08T12:03:10Z")

</div>

hello i' ve mounted elk vers 7.16.2 but in console i see this logs

```auto
[2022-10-08T11:59:14,859][ERROR][logstash.licensechecker.licensereader] Unable to retrieve license information from license server {:message=>"No Available connections"}

325[2022-10-08T11:59:26,613][WARN][logstash.licensechecker.licensereader] Attempted to resurrect connection to dead ES instance, but got an error {:url=>"http://elasticsearch:9200/", :exception=>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :message=>"Elasticsearch Unreachable: [http://elasticsearch:9200/][Manticore::SocketException] No route to host (Host unreachable)"}

```

Kibana don't connect but al instance is in same network

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/6/d/6ddf46a33b01e2848d07417d243dfdd28cde1e0e.png)

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/3/6/36b1ea8312b07d7e557e5e85be9db4651eaa8c29.png)

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [October 8, 2022, 2:13pm UTC](https://discuss.elastic.co/t/elk-on-openshift-server-have-limit/316124/2 "2022-10-08T14:13:58Z")

</div>

You need to check the elasticsearch logs to see if the service is running.

---

<div class="post-metadata">

**Author:** ![Nikolas1306](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nikolas1306/32/111507_2.png) [@Nikolas1306](https://discuss.elastic.co/u/Nikolas1306)\
**Post date:** [October 8, 2022, 2:36pm UTC](https://discuss.elastic.co/t/elk-on-openshift-server-have-limit/316124/3 "2022-10-08T14:36:02Z")

</div>

hello this is console with eleastic instance

```auto
[2022-10-08T10:45:14,844][WARN][logstash.licensechecker.licensereader] Marking url as dead. Last error: [LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError] Elasticsearch Unreachable: [http://elasticsearch:9200/][Manticore::SocketException] No route to host (Host unreachable) {:url=>http://elasticsearch:9200/, :error_message=>"Elasticsearch Unreachable: [http://elasticsearch:9200/][Manticore::SocketException] No route to host (Host unreachable)", :error_class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError"}

18[2022-10-08T10:45:14,848][ERROR][logstash.licensechecker.licensereader] Unable to retrieve license information from license server {:message=>"Elasticsearch Unreachable: [http://elasticsearch:9200/][Manticore::SocketException] No route to host (Host unreachable)"}

19[2022-10-08T10:45:14,871][ERROR][logstash.monitoring.internalpipelinesource] Failed to fetch X-Pack information from Elasticsearch. This is likely due to failure to reach a live Elasticsearch cluster.

20[2022-10-08T10:45:15,092][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600, :ssl_enabled=>false}

21[2022-10-08T10:45:16,282][INFO][org.reflections.Reflections] Reflections took 175 ms to scan 1 urls, producing 119 keys and 417 values

22[2022-10-08T10:45:17,093][WARN][deprecation.logstash.codecs.plain] Relying on default value of `pipeline.ecs_compatibility`, which may change in a future major release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.

23[2022-10-08T10:45:17,108][WARN][deprecation.logstash.inputs.beats] Relying on default value of `pipeline.ecs_compatibility`, which may change in a future major release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.

24[2022-10-08T10:45:17,681][INFO][logstash.javapipeline][main] Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>1, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>50, "pipeline.max_inflight"=>125, "pipeline.sources"=>["/usr/share/logstash/pipeline/logstash.conf"], :thread=>"#<Thread:0xa863158 run>"}

25[2022-10-08T10:45:18,897][INFO][logstash.javapipeline][main] Pipeline Java execution initialization time {"seconds"=>1.21}

26[2022-10-08T10:45:18,968][INFO][logstash.inputs.beats][main] Starting input listener {:address=>"0.0.0.0:5044"}

27[2022-10-08T10:45:18,982][INFO][logstash.javapipeline][main] Pipeline started {"pipeline.id"=>"main"}

28[2022-10-08T10:45:19,185][INFO][logstash.agent] Pipelines running {:count=>1, :running_pipelines=>[:main], :non_running_pipelines=>[]}

29[2022-10-08T10:45:19,304][INFO][org.logstash.beats.Server][main][0710cad67e8f47667bc7612580d5b91f691dd8262a4187d9eca8cf87229d04aa] Starting server on port: 5044

30[2022-10-08T10:45:42,872][WARN][logstash.licensechecker.licensereader] Attempted to resurrect connection to dead ES instance, but got an error {:url=>"http://elasticsearch:9200/", :exception=>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :message=>"Elasticsearch Unreachable: [http://elasticsearch:9200/][Manticore::SocketException] No route to host (Host unreachable)"}

31[2022-10-08T10:45:44,863][ERROR][logstash.licensechecker.licensereader] Unable to retrieve license information from license server {:message=>"No Available connections"}

32[2022-10-08T10:46:12,950][WARN][logstash.licensechecker.licensereader] Attempted to resurrect connection to dead ES instance, but got an error {:url=>"http://elasticsearch:9200/", :exception=>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :message=>"Elasticsearch Unreachable: [http://elasticsearch:9200/][Manticore::SocketException] No route to host (Host unreachable)"}

33[2022-10-08T10:46:14,859][ERROR][logstash.licensechecker.licensereader] Unable to retrieve license information from license server {:message=>"No Available connections"}

34[2022-10-08T10:46:43,030][WARN][logstash.licensechecker.licensereader] Attempted to resurrect connection to dead ES instance, but got an error {:url=>"http://elasticsearch:9200/", :exception=>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :message=>"Elasticsearch Unreachable: [http://elasticsearch:9200/][Manticore::SocketException] No route to host (Host unreachable)"}

35[2022-10-08T10:46:44,859][ERROR][logstash.licensechecker.licensereader] Unable to retrieve license information from license server {:message=>"No Available connections"}

```

---

<div class="post-metadata">

**Author:** ![Nikolas1306](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nikolas1306/32/111507_2.png) [@Nikolas1306](https://discuss.elastic.co/u/Nikolas1306)\
**Post date:** [October 8, 2022, 2:37pm UTC](https://discuss.elastic.co/t/elk-on-openshift-server-have-limit/316124/4 "2022-10-08T14:37:31Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/5/6/56efab777be7ca9cbe49c4220978d0965fb2f064.png)

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [October 8, 2022, 2:43pm UTC](https://discuss.elastic.co/t/elk-on-openshift-server-have-limit/316124/5 "2022-10-08T14:43:45Z")

</div>

This log is from Logstash, you need to look at the elasticsearch logs.

Do you have an elasticsearch instance configured and running? This error says that Logstash cannont connect to the Elasticsearch instance.

---

<div class="post-metadata">

**Author:** ![Nikolas1306](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nikolas1306/32/111507_2.png) [@Nikolas1306](https://discuss.elastic.co/u/Nikolas1306)\
**Post date:** [October 8, 2022, 2:51pm UTC](https://discuss.elastic.co/t/elk-on-openshift-server-have-limit/316124/6 "2022-10-08T14:51:36Z")

</div>

yes have error is other

```auto
{"type": "server", "timestamp": "2022-10-08T14:49:16,431Z", "level": "INFO", "component": "o.e.p.PluginsService", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "loaded module [x-pack-stack]" }
{"type": "server", "timestamp": "2022-10-08T14:49:16,431Z", "level": "INFO", "component": "o.e.p.PluginsService", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "loaded module [x-pack-text-structure]" }
{"type": "server", "timestamp": "2022-10-08T14:49:16,431Z", "level": "INFO", "component": "o.e.p.PluginsService", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "loaded module [x-pack-voting-only-node]" }
{"type": "server", "timestamp": "2022-10-08T14:49:16,431Z", "level": "INFO", "component": "o.e.p.PluginsService", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "loaded module [x-pack-watcher]" }
{"type": "server", "timestamp": "2022-10-08T14:49:16,432Z", "level": "INFO", "component": "o.e.p.PluginsService", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "no plugins loaded" }
{"type": "server", "timestamp": "2022-10-08T14:49:16,528Z", "level": "INFO", "component": "o.e.e.NodeEnvironment", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "using [1] data paths, mounts [[/ (overlay)]], net usable_space [165.9gb], net total_space [299.4gb], types [overlay]" }
{"type": "server", "timestamp": "2022-10-08T14:49:16,528Z", "level": "INFO", "component": "o.e.e.NodeEnvironment", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "heap size [400mb], compressed ordinary object pointers [true]" }
{"type": "server", "timestamp": "2022-10-08T14:49:16,543Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "node name [elasticsearch-5cb5f8cc66-srdsq], node ID [yV_YF8EGSmGrDQcCO3JfDw], cluster name [docker-cluster], roles [transform, data_frozen, master, remote_cluster_client, data, ml, data_content, data_hot, data_warm, data_cold, ingest]" }
{"type": "server", "timestamp": "2022-10-08T14:49:25,161Z", "level": "INFO", "component": "o.e.x.m.p.l.CppLogMessageHandler", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "[controller/180] [Main.cc@122] controller (64 bit): Version 7.16.2 (Build 77e5cf03d1077d) Copyright (c) 2021 Elasticsearch BV" }
{"type": "server", "timestamp": "2022-10-08T14:49:26,256Z", "level": "INFO", "component": "o.e.x.s.a.s.FileRolesStore", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "parsed [0] roles from file [/usr/share/elasticsearch/config/roles.yml]" }
{"type": "server", "timestamp": "2022-10-08T14:49:27,454Z", "level": "INFO", "component": "o.e.i.g.ConfigDatabases", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "initialized default databases [[GeoLite2-Country.mmdb, GeoLite2-City.mmdb, GeoLite2-ASN.mmdb]], config databases [[]] and watching [/usr/share/elasticsearch/config/ingest-geoip] for changes" }
{"type": "server", "timestamp": "2022-10-08T14:49:27,455Z", "level": "INFO", "component": "o.e.i.g.DatabaseNodeService", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "initialized database registry, using geoip-databases directory [/tmp/elasticsearch-15195425473546067988/geoip-databases/yV_YF8EGSmGrDQcCO3JfDw]" }
{"type": "server", "timestamp": "2022-10-08T14:49:28,540Z", "level": "INFO", "component": "o.e.t.NettyAllocator", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "creating NettyAllocator with the following configs: [name=unpooled, suggested_max_allocation_size=1mb, factors={es.unsafe.use_unpooled_allocator=null, g1gc_enabled=true, g1gc_region_size=4mb, heap_size=400mb}]" }
{"type": "server", "timestamp": "2022-10-08T14:49:28,645Z", "level": "INFO", "component": "o.e.d.DiscoveryModule", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "using discovery type [zen] and seed hosts providers [settings]" }
{"type": "server", "timestamp": "2022-10-08T14:49:29,536Z", "level": "INFO", "component": "o.e.g.DanglingIndicesState", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "gateway.auto_import_dangling_indices is disabled, dangling indices will not be automatically detected or imported and must be managed manually" }
{"type": "server", "timestamp": "2022-10-08T14:49:30,438Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "initialized" }
{"type": "server", "timestamp": "2022-10-08T14:49:30,438Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "starting ..." }
{"type": "server", "timestamp": "2022-10-08T14:49:30,446Z", "level": "INFO", "component": "o.e.x.s.c.f.PersistentCache", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "persistent cache index loaded" }
{"type": "server", "timestamp": "2022-10-08T14:49:30,447Z", "level": "INFO", "component": "o.e.x.d.l.DeprecationIndexingComponent", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "deprecation component started" }
{"type": "server", "timestamp": "2022-10-08T14:49:30,639Z", "level": "INFO", "component": "o.e.t.TransportService", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "publish_address {10.131.4.54:9300}, bound_addresses {[::]:9300}" }
{"type": "server", "timestamp": "2022-10-08T14:49:31,028Z", "level": "INFO", "component": "o.e.b.BootstrapChecks", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "bound or publishing to a non-loopback address, enforcing bootstrap checks" }

ERROR: [1] bootstrap checks failed. You must address the points described in the following [1] lines before starting Elasticsearch.
bootstrap check failure [1] of [1]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured
ERROR: Elasticsearch did not exit normally - check the logs at /usr/share/elasticsearch/logs/docker-cluster.log
{"type": "server", "timestamp": "2022-10-08T14:49:31,036Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "stopping ..." }
{"type": "server", "timestamp": "2022-10-08T14:49:31,045Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "stopped" }
{"type": "server", "timestamp": "2022-10-08T14:49:31,045Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "closing ..." }
{"type": "server", "timestamp": "2022-10-08T14:49:31,053Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "closed" }
{"type": "server", "timestamp": "2022-10-08T14:49:31,120Z", "level": "INFO", "component": "o.e.x.m.p.NativeController", "cluster.name": "docker-cluster", "node.name": "elasticsearch-5cb5f8cc66-srdsq", "message": "Native controller process has stopped - no new native processes can be started" }

```

---

<div class="post-metadata">

**Author:** ![Nikolas1306](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nikolas1306/32/111507_2.png) [@Nikolas1306](https://discuss.elastic.co/u/Nikolas1306)\
**Post date:** [October 8, 2022, 3:00pm UTC](https://discuss.elastic.co/t/elk-on-openshift-server-have-limit/316124/7 "2022-10-08T15:00:09Z")

</div>

hello the problem is the parameter cluster i add from original docker-compose and now have response on localhost

```auto
 environment:
      discovery.type: single-node

```

```auto
sh-5.0$ ls
'?' LICENSE.txt NOTICE.txt README.asciidoc bin config data jdk lib logs modules plugins
sh-5.0$ curl 127.0.0.1:9200
{
  "name" : "elasticsearch-5bcd79476c-55lgj",
  "cluster_name" : "docker-cluster",
  "cluster_uuid" : "sxTpT-8qRdOPuQUaGcLkYQ",
  "version" : {
    "number" : "7.16.2",
    "build_flavor" : "default",
    "build_type" : "docker",
    "build_hash" : "2b937c44140b6559905130a8650c64dbd0879cfb",
    "build_date" : "2021-12-18T19:42:46.604893745Z",
    "build_snapshot" : false,
    "lucene_version" : "8.10.1",
    "minimum_wire_compatibility_version" : "6.8.0",
    "minimum_index_compatibility_version" : "6.0.0-beta1"
  },
  "tagline" : "You Know, for Search"
}
sh-5.0$

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 5, 2022, 3:00pm UTC](https://discuss.elastic.co/t/elk-on-openshift-server-have-limit/316124/8 "2022-11-05T15:00:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
