# ELK Platinum : Active Directory error

**URL:** <https://discuss.elastic.co/t/elk-platinum-active-directory-error/250780>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [October 2, 2020, 11:35am UTC](https://discuss.elastic.co/t/elk-platinum-active-directory-error/250780 "2020-10-02T11:35:50Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![nityaraj06](https://avatars.discourse-cdn.com/v4/letter/n/d78d45/32.png) [@nityaraj06](https://discuss.elastic.co/u/nityaraj06)\
**Post date:** [October 2, 2020, 11:35am UTC](https://discuss.elastic.co/t/elk-platinum-active-directory-error/250780/1 "2020-10-02T11:35:51Z")

</div>

Hi I have added the following config in elasticsearch.yml

> xpack:  
> security:  
> authc:  
> realms:  
> active\_directory:  
> my\_ad:  
> order: 0  
> domain\_name: [abcd.xyz.org](http://abcd.xyz.org)  
> url: ldap://abcd.xyz.org:389  
> bind\_dn: [nitya.raj@abcd.xyz.org](mailto:nitya.raj@abcd.xyz.org)  
> `

I have also added the xpack.security.authc.realms.active\_directory.my\_ad.secure\_bind\_password for the bind\_dn.

However, I am receiving this error -

`[2020-10-02T13:12:39,827][WARN][o.e.x.s.a.AuthenticationService] [elk.org] Authentication to realm my_ad failed - authenticate failed (Caused by LDAPException(resultCode=49 (invalid credentials), diagnosticMessage='80090308: LdapErr: DSID-0C090446, comment: AcceptSecurityContext error, data 52e, v2580 ', ldapSDKVersion=4.0.8, revision=28812))`  
Could someone guide me in this?

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [October 6, 2020, 3:34pm UTC](https://discuss.elastic.co/t/elk-platinum-active-directory-error/250780/2 "2020-10-06T15:34:26Z")

</div>

This means that a bind to the AD failed because of wrong credentials. This can be caused either by the bind\_dn or password being wrong, or because the username or the password of the user with which you attempt to authenticate is wrong. Can you enable debug logging with

```auto
curl -uelastic -XPUT '<your_fqdn>:9200/_cluster/settings?pretty' -H 'Content-Type: application/json' -d'
{
  "transient": {
    "logger.org.elasticsearch.xpack.security.authc.ldap": "TRACE"
  }
}

```

and also let us know how you are trying to authenticate ? What are you passing as a username ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 3, 2020, 3:34pm UTC](https://discuss.elastic.co/t/elk-platinum-active-directory-error/250780/3 "2020-11-03T15:34:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
