# ELK server timing out filebeat from Windows Server

**URL:** https://discuss.elastic.co/t/elk-server-timing-out-filebeat-from-windows-server/141635
**Category:** Beats
**Tags:** filebeat
**Created:** [July 25, 2018, 5:18pm UTC](https://discuss.elastic.co/t/elk-server-timing-out-filebeat-from-windows-server/141635 "2018-07-25T17:18:26Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![mrojo](https://avatars.discourse-cdn.com/v4/letter/m/a9a28c/32.png) [@mrojo](https://discuss.elastic.co/u/mrojo)
#### Post date: [July 25, 2018, 5:18pm UTC](https://discuss.elastic.co/t/elk-server-timing-out-filebeat-from-windows-server/141635/1 "2018-07-25T17:18:27Z")

</div>

Hello, I'm trying to establish connection between a windows box and ELK server, file beat has been successfully installed and running as a service, I'm able to ping and telnet to port 5044, Netstat shows that the connection has been established, but the filebeat.log shows a timeout and the file is not being harvested, any Help will be appreciated

2018-07-23T15:17:30.057-0500 INFO instance/beat.go:468 Home path: [C:\Temp\filebeat-6.2.4-windows-x86\_64\filebeat-6.2.4-windows-x86\_64] Config path: [C:\Temp\filebeat-6.2.4-windows-x86\_64\filebeat-6.2.4-windows-x86\_64] Data path: [C:\ProgramData\filebeat] Logs path: [C:\ProgramData\filebeat\logs]  
2018-07-23T15:17:30.095-0500 INFO instance/beat.go:475 Beat UUID: 3c86b0a4-785a-47ab-a32b-3891be3794f4  
2018-07-23T15:17:30.095-0500 INFO instance/beat.go:213 Setup Beat: filebeat; Version: 6.2.4  
2018-07-23T15:17:30.095-0500 INFO pipeline/module.go:76 Beat name: LACMEXVECDB01  
2018-07-23T15:17:30.097-0500 INFO instance/beat.go:301 filebeat start running.  
2018-07-23T15:17:30.097-0500 INFO [monitoring] log/log.go:97 Starting metrics logging every 30s  
2018-07-23T15:17:30.099-0500 INFO registrar/registrar.go:110 Loading registrar data from C:\ProgramData\filebeat\registry  
2018-07-23T15:17:30.099-0500 INFO registrar/registrar.go:121 States Loaded from registrar: 0  
2018-07-23T15:17:30.099-0500 WARN beater/filebeat.go:261 Filebeat is unable to load the Ingest Node pipelines for the configured modules because the Elasticsearch output is not configured/enabled. If you have already loaded the Ingest Node pipelines or are using Logstash pipelines, you can ignore this warning.  
2018-07-23T15:17:30.099-0500 INFO crawler/crawler.go:48 Loading Prospectors: 1  
2018-07-23T15:17:30.100-0500 INFO log/prospector.go:111 Configured paths: [c:\temp\report.log]  
2018-07-23T15:17:30.100-0500 INFO crawler/crawler.go:82 Loading and starting Prospectors completed. Enabled prospectors: 1  
2018-07-23T15:17:30.100-0500 INFO log/harvester.go:216 Harvester started for file: c:\temp\report.log  
2018-07-23T15:18:01.666-0500 ERROR logstash/async.go:235 Failed to publish events caused by: read tcp 10.82.12.27:63729-\>169.171.164.17:5044: i/o timeout  
2018-07-23T15:18:01.670-0500 ERROR logstash/async.go:235 Failed to publish events caused by: client is not connected  
2018-07-23T15:18:02.669-0500 ERROR pipeline/output.go:92 Failed to publish events: client is not connected

---

<div class="post-metadata">

### Author: ![pierhugues](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pierhugues/32/48383_2.png) [@pierhugues](https://discuss.elastic.co/u/pierhugues)
#### Post date: [July 26, 2018, 7:19pm UTC](https://discuss.elastic.co/t/elk-server-timing-out-filebeat-from-windows-server/141635/2 "2018-07-26T19:19:28Z")

</div>

Hello @mrojo, I have a few questions that will help debug your problem:

- What version of Filebeat are you running?
- Any errors on the Logstash log?
- Is there a load balancer between windows and the Logstash instances?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 23, 2018, 7:19pm UTC](https://discuss.elastic.co/t/elk-server-timing-out-filebeat-from-windows-server/141635/3 "2018-08-23T19:19:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
