# ELK stack - Kibana fails time to time giving the same error ( Elasticsearch failed Search rejected due to missing shards \[)\[.kibana\_task\_manager\_7.17.7\_001\]\[0\]\])

**URL:** https://discuss.elastic.co/t/elk-stack-kibana-fails-time-to-time-giving-the-same-error-elasticsearch-failed-search-rejected-due-to-missing-shards-kibana-task-manager-7-17-7-001-0/343414
**Category:** Kibana
**Tags:** docker
**Created:** [September 20, 2023, 3:37am UTC](https://discuss.elastic.co/t/elk-stack-kibana-fails-time-to-time-giving-the-same-error-elasticsearch-failed-search-rejected-due-to-missing-shards-kibana-task-manager-7-17-7-001-0/343414 "2023-09-20T03:37:46Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Senith\_Dilitha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/senith_dilitha/32/125821_2.png) [@Senith\_Dilitha](https://discuss.elastic.co/u/Senith_Dilitha)
#### Post date: [September 20, 2023, 3:37am UTC](https://discuss.elastic.co/t/elk-stack-kibana-fails-time-to-time-giving-the-same-error-elasticsearch-failed-search-rejected-due-to-missing-shards-kibana-task-manager-7-17-7-001-0/343414/1 "2023-09-20T03:37:46Z")

</div>

I am using the ELK stack deployed in a docker swarm for logging. From time to time I get the below error and Kibana service fails.

`[Elasticsearch failed Search rejected due to missing shards [[.kibana_task_manager_7.17.7_001][0]]]`

when I delete the index `.kibana_task_manager_7.17.7_001` and restart Elasticsearch, it works again but after 3, or 4 days it fails with the same error.

Additionally, I am using persistent volume mounting for Elasticsearch.

Has anyone come across this issue or have a permanent solution?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 18, 2023, 3:38am UTC](https://discuss.elastic.co/t/elk-stack-kibana-fails-time-to-time-giving-the-same-error-elasticsearch-failed-search-rejected-due-to-missing-shards-kibana-task-manager-7-17-7-001-0/343414/2 "2023-10-18T03:38:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
