# Enabling X-Pack in Logstash 7 gives me this error

**URL:** <https://discuss.elastic.co/t/enabling-x-pack-in-logstash-7-gives-me-this-error/176671>\
**Category:** Logstash\
**Created:** [April 12, 2019, 4:30pm UTC](https://discuss.elastic.co/t/enabling-x-pack-in-logstash-7-gives-me-this-error/176671 "2019-04-12T16:30:22Z")\
**Posts on this page:** 1\
**Showing post:** 8

<div class="post-metadata">

**Author:** ![teamg](https://avatars.discourse-cdn.com/v4/letter/t/e19b73/32.png) [@teamg](https://discuss.elastic.co/u/teamg)\
**Post date:** [April 12, 2019, 6:07pm UTC](https://discuss.elastic.co/t/enabling-x-pack-in-logstash-7-gives-me-this-error/176671/8 "2019-04-12T18:07:48Z")

</div>

I fixed it by commenting out the following in /etc/logstash/logstash.yml and restarting logstash:

> path.data: /var/lib/logstash  
> path.logs: /var/log/logstash  
> xpack.monitoring.enabled: true  
> xpack.monitoring.elasticsearch.username: logstash\_system  
> xpack.monitoring.elasticsearch.password: password  
> #xpack.monitoring.elasticsearch.hosts: ["[https://10.XX.XX.222:9200](https://10.XX.XX.222:9200)"]

Logstash now appears in Stack Monitoring on Kibana.

Thank you for the support Badger. Your last entry clued me into what could be the problem.

---

_[View the full topic](https://discuss.elastic.co/t/enabling-x-pack-in-logstash-7-gives-me-this-error/176671)._
