# Encounter an error while startup winlogbeat

**URL:** <https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740>\
**Category:** Beats\
**Tags:** winlogbeat\
**Created:** [August 5, 2019, 7:26am UTC](https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740 "2019-08-05T07:26:25Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![ravipemmasani](https://avatars.discourse-cdn.com/v4/letter/r/ccd318/32.png) [@ravipemmasani](https://discuss.elastic.co/u/ravipemmasani)\
**Post date:** [August 5, 2019, 7:26am UTC](https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740/1 "2019-08-05T07:26:25Z")

</div>

Hello Team,

While we are doing POC,i am getting following error when starting up WinlogBeat on remote Host.Following is my ELK stack version info.Would really appreciate your help.

Syslog-ng-3.21  
ElasticSearch-7.2  
Logstasch-7.2.1  
Kibana-7.2.0

2019-08-05T14:37:53.190+0800 ERROR instance/beat.go:877 Exiting: error c  
onnecting to Kibana: fail to get the Kibana version: HTTP GET request to http://  
localhost:5601/api/status fails: fail to execute the HTTP GET request: Get http:  
[//localhost:5601/api/status:](https://localhost:5601/api/status:) dial tcp [::1]:5601: connectex: No connection could  
be made because the target machine actively refused it.. Response: .  
Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET re  
quest to [http://localhost:5601/api/status](http://localhost:5601/api/status) fails: fail to execute the HTTP GET re  
quest: Get [http://localhost:5601/api/status:](http://localhost:5601/api/status:) dial tcp [::1]:5601: connectex: No  
connection could be made because the target machine actively refused it.. Respon  
se: .

Regards  
Ravi.

---

<div class="post-metadata">

**Author:** ![ravipemmasani](https://avatars.discourse-cdn.com/v4/letter/r/ccd318/32.png) [@ravipemmasani](https://discuss.elastic.co/u/ravipemmasani)\
**Post date:** [August 5, 2019, 7:30am UTC](https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740/2 "2019-08-05T07:30:44Z")

</div>

Hello Team,

Just to add on ,ELK stack & Syslog-ng being setup on RHEL-7.5,the remote host where we installed winlogbeat running on Windows 2012.  
In order to access KIbana,the URL http://localhost:5601doesn't work,it works only with IP.

Regards  
Ravi.

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [August 5, 2019, 10:25am UTC](https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740/3 "2019-08-05T10:25:37Z")

</div>

The error you are getting is due to Kibana not being reachable on `localhost:5601`. Are you sure you configured `setup.kibana.host` correctly? If Winlogbeat is on a remote host (not on the same host as Kibana is), you need to change the value in this option.

---

<div class="post-metadata">

**Author:** ![ravipemmasani](https://avatars.discourse-cdn.com/v4/letter/r/ccd318/32.png) [@ravipemmasani](https://discuss.elastic.co/u/ravipemmasani)\
**Post date:** [August 5, 2019, 1:36pm UTC](https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740/4 "2019-08-05T13:36:21Z")

</div>

Hi Noémi Ványi,

Thanks for responding to my email.

Please note that iam able to access Kibana via IP only,localhost doesn't work.

Kindly refer attached for your further assessment.

Would really appreciate your help.

Regards

Ravi.

(Attachment ELK\_Stack\_Config.docx is missing)

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [August 5, 2019, 3:09pm UTC](https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740/5 "2019-08-05T15:09:14Z")

</div>

Are Winlogbeat and Kibana running on the same host?

Also, the attachment you have shared is not available. In the future please share everything in plaintext and format it using `</>` if needed.

---

<div class="post-metadata">

**Author:** ![ravipemmasani](https://avatars.discourse-cdn.com/v4/letter/r/ccd318/32.png) [@ravipemmasani](https://discuss.elastic.co/u/ravipemmasani)\
**Post date:** [August 6, 2019, 12:21am UTC](https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740/6 "2019-08-06T00:21:39Z")

</div>

Hi Noémi Ványi,

ELK Stack(Elastic Search/Log Stash/Kibana) has been running on different host from Winlogbeat.

Kindly refer attached ELK stack config & error log for your further review and advice.

Regards

Ravi.

(Attachment ELK\_Stack\_config1.rtf is missing)

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [August 6, 2019, 12:08pm UTC](https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740/7 "2019-08-06T12:08:09Z")

</div>

`localhost` is a hostname which refers to the host Winlogbeat runs on. You are seeing the error because Kibana is not running on the same machine as Winlogbeat does.  
Just use the IP address of the machine which runs Kibana. Or is there another issue?

---

<div class="post-metadata">

**Author:** ![ravipemmasani](https://avatars.discourse-cdn.com/v4/letter/r/ccd318/32.png) [@ravipemmasani](https://discuss.elastic.co/u/ravipemmasani)\
**Post date:** [August 6, 2019, 1:17pm UTC](https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740/8 "2019-08-06T13:17:39Z")

</div>

Hi Noémi Ványi,

Thanks for the update.

Kindly correct me if my understanding wrong.

ELK Stack components ElasticSearch+Kibana and syslog-ng installed on host server(centralized log server) runs on Red Hat Linux.

Remote Host(client application) runs on Windows for Log collection,installed Winlogbeat only.

kibana & elasticsearch host IP-10.81.162.251

Kindly take a look winlogbeat.yml for your review.

###################### Winlogbeat Configuration Example ########################

# This file is an example configuration file highlighting only the most common

# options. The winlogbeat.reference.yml file from the same directory contains

# all the supported options with more comments. You can use it as a reference.

---

<div class="post-metadata">

**Author:** ![ravipemmasani](https://avatars.discourse-cdn.com/v4/letter/r/ccd318/32.png) [@ravipemmasani](https://discuss.elastic.co/u/ravipemmasani)\
**Post date:** [August 7, 2019, 12:17am UTC](https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740/9 "2019-08-07T00:17:03Z")

</div>

Iam awaiting for your reply,kindly advice me at the earliest.

Regards

Ravi

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 4, 2019, 12:17am UTC](https://discuss.elastic.co/t/encounter-an-error-while-startup-winlogbeat/193740/10 "2019-09-04T00:17:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
