# Enrich processor error: mapper\_parsing\_exception

**URL:** <https://discuss.elastic.co/t/enrich-processor-error-mapper-parsing-exception/311440>\
**Category:** Elasticsearch\
**Tags:** ingest-pipeline\
**Created:** [August 4, 2022, 2:38pm UTC](https://discuss.elastic.co/t/enrich-processor-error-mapper-parsing-exception/311440 "2022-08-04T14:38:45Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![FKarraz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fkarraz/32/80628_2.png) [@FKarraz](https://discuss.elastic.co/u/FKarraz)\
**Post date:** [August 4, 2022, 2:38pm UTC](https://discuss.elastic.co/t/enrich-processor-error-mapper-parsing-exception/311440/1 "2022-08-04T14:38:46Z")

</div>

I'm trying to enrich data to my index called "time\_availability\_alarmed\_cells". The mapping for that index is:

```auto
{
  "mappings": {
    "_doc": {
      "properties": {
        "location": {
          "properties": {
            "cell": {
              "type": "text",
              "fields": {
                "keyword": {
                  "type": "keyword",
                  "ignore_above": 256
                }
              }
            },
            "city": {
              "type": "keyword"
            },
            "cityPath": {
              "type": "keyword"
            },
            "country": {
              "type": "keyword"
            },
            "isoCode": {
              "type": "keyword"
            },
            "location": {
              "type": "geo_point"
            },
            "name": {
              "type": "keyword"
            },
            "region": {
              "type": "keyword"
            },
            "spareRegion": {
              "type": "keyword"
            },
            "type": {
              "type": "keyword"
            },
            "vendor": {
              "type": "keyword"
            }
          }
        }
      }
    }
  }
}

```

I create the following pipeline processor with an enrich policy:

```auto
[
    {
      "enrich": {
        "field": "cell",
        "policy_name": "extradata_location",
        "target_field": "location",
        "ignore_missing": true,
        "ignore_failure": true
      }
    }
]

```

And the enrich policy configuration:

```auto
{
  "match": {
    "indices": "time_availability_cells",
    "match_field": "cell",
    "enrich_fields": ["location.name"]
  }
}

```

The mapping for "location" field in "time\_availability\_cells" index is:

```auto
{
    "mappings": {
      "_doc": {
        "properties": {
          "location": {
            "properties": {
                "city": {
                "type": "keyword"
                },
                "cityPath": {
                "type": "keyword"
                },
                "country": {
                "type": "keyword"
                },
                "isoCode": {
                "type": "keyword"
                },
                "location": {
                "type": "geo_point"
                },
                "name": {
                "type": "keyword"
                },
                "region": {
                "type": "keyword"
                },
                "spareRegion": {
                "type": "keyword"
                },
                "type": {
                "type": "keyword"
                },
                "vendor": {
                "type": "keyword"
                }
            }
          }
        }
      }
    }
  }

```

When i index a new document to "time\_availability\_alarmed\_cells" with the enrich processor, throws the following error:

```auto
ERROR: mapper_parsing_exception: failed to parse field [location.location] of type [geo_point]

```

Any suggestion to resolve this issue?  
Thanks in advance

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 1, 2022, 2:39pm UTC](https://discuss.elastic.co/t/enrich-processor-error-mapper-parsing-exception/311440/2 "2022-09-01T14:39:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
