# Ensure a healthy Elasticsearch cluster is running at https://172.19.0.2:9200 for user elastic

**URL:** <https://discuss.elastic.co/t/ensure-a-healthy-elasticsearch-cluster-is-running-at-https-172-19-0-2-9200-for-user-elastic/299121>\
**Category:** Elastic Search\
**Tags:** docker\
**Created:** [March 8, 2022, 5:12pm UTC](https://discuss.elastic.co/t/ensure-a-healthy-elasticsearch-cluster-is-running-at-https-172-19-0-2-9200-for-user-elastic/299121 "2022-03-08T17:12:32Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![suminlim](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/suminlim/32/97487_2.png) [@suminlim](https://discuss.elastic.co/u/suminlim)\
**Post date:** [March 8, 2022, 5:12pm UTC](https://discuss.elastic.co/t/ensure-a-healthy-elasticsearch-cluster-is-running-at-https-172-19-0-2-9200-for-user-elastic/299121/1 "2022-03-08T17:12:32Z")

</div>

Ensure a healthy Elasticsearch cluster is running at [https://172.19.0.2:9200](https://172.19.0.2:9200) for user elastic.

**When I run docker of enterprise-search,**  
**it fails to run with this message when I entered on Kibana**  
**[http://kibana-url:5601/app/enterprise\_search/overview](http://kibana-url:5601/app/enterprise_search/overview)**

**it is working with elasticsearch and enterprise-search together? or not?**

## [2022-03-08T16:47:50.434+00:00][8][2000][app-server][ERROR]: Could not connect to Elasticsearch backend after 600 seconds. Terminating... [2022-03-08T16:47:50.437+00:00][8][2000][app-server][ERROR]:

Enterprise Search is unable to connect to Elasticsearch. Ensure a healthy Elasticsearch cluster is running at [https://172.19.0.2:9200](https://172.19.0.2:9200) for user elastic.

* * *

---

<div class="post-metadata">

**Author:** ![ross.bell](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ross.bell/32/77559_2.png) [@ross.bell](https://discuss.elastic.co/u/ross.bell)\
**Post date:** [March 8, 2022, 5:46pm UTC](https://discuss.elastic.co/t/ensure-a-healthy-elasticsearch-cluster-is-running-at-https-172-19-0-2-9200-for-user-elastic/299121/2 "2022-03-08T17:46:29Z")

</div>

Hey @suminlim,

It seems that Enterprise Search isn't able to access Elasticsearch using the host/username/password specified. You could try to SSH into the Enterprise Search docker container and attempt to issue a basic request to Elasticsearch in order to test/verify the connection. Something like:

`curl -u [USERNAME]:[PASSWORD] https://[HOST AND PORT]/_cat/health`

Let me know if that helps!

Ross

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 4, 2022, 8:34am UTC](https://discuss.elastic.co/t/ensure-a-healthy-elasticsearch-cluster-is-running-at-https-172-19-0-2-9200-for-user-elastic/299121/5 "2022-11-04T08:34:32Z")

</div>


