# Enterprise search unable to start

**URL:** https://discuss.elastic.co/t/enterprise-search-unable-to-start/306151
**Category:** Elastic Search
**Created:** [June 1, 2022, 5:04pm UTC](https://discuss.elastic.co/t/enterprise-search-unable-to-start/306151 "2022-06-01T17:04:54Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![francis826](https://avatars.discourse-cdn.com/v4/letter/f/91b2a8/32.png) [@francis826](https://discuss.elastic.co/u/francis826)
#### Post date: [June 1, 2022, 5:04pm UTC](https://discuss.elastic.co/t/enterprise-search-unable-to-start/306151/1 "2022-06-01T17:04:54Z")

</div>

Hello, I'm trying to follow the documentation to start up an enterprise search app found here: [Download Elastic Enterprise Search | Elastic](https://www.elastic.co/downloads/enterprise-search)

Note: I am using debian 10 and installed deb packages through the elastic repo (all latest)

I've got Kibana and Elasticsearch running fine but when I try to start the Enterprise Search I am getting the error:

```auto
[2022-06-01T17:02:35.878+00:00][587][4004][app-server][INFO]: Elastic Enterprise Search version=8.2.2, JRuby version=9.3.3.0, Ruby version=2.6.8, Rails version=5.2.7
[2022-06-01T17:02:37.555+00:00][587][4004][app-server][ERROR]:
--------------------------------------------------------------------------------

Invalid config file (/usr/share/enterprise-search/config/enterprise-search.yml):
The setting '#/elasticsearch/ssl/certificate_authority' is not valid: error reading file '/etc/elasticsearch/certs/http_ca.crt'

--------------------------------------------------------------------------------

```

When I go to Kibana and click on Enterprise Search I am presented with this error:

 ![Screen Shot 2022-06-01 at 10.03.37 AM](https://us1.discourse-cdn.com/elastic/original/3X/2/e/2e7104ae26b2ba3e80c6effca01c90cd826e8160.png)

I've followed the setup guide precisely and still running into issues. What am I missing?

---

<div class="post-metadata">

### Author: ![francis826](https://avatars.discourse-cdn.com/v4/letter/f/91b2a8/32.png) [@francis826](https://discuss.elastic.co/u/francis826)
#### Post date: [June 1, 2022, 5:37pm UTC](https://discuss.elastic.co/t/enterprise-search-unable-to-start/306151/2 "2022-06-01T17:37:32Z")

</div>

I think I got it working. A couple of things I had to do in case anyone else runs into this same thing:

```auto
cp /etc/elasticsearch/certs/http_ca.crt /usr/share/enterprise-search/

```

```auto
chown enterprise-search:enterprise-search /usr/share/enterprise-search/http_ca.crt

```

Update `/usr/share/enterprise-search/config/enterprise-search.yml` to have

```auto
elasticsearch.ssl.certificate_authority: /usr/share/enterprise-search/http_ca.crt

```

Then

```auto
chown -R enterprise-search:enterprise-search /var/log/enterprise-search/

```

And finally `systemctl restart enterprise-search.service`

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 4, 2022, 8:35am UTC](https://discuss.elastic.co/t/enterprise-search-unable-to-start/306151/3 "2022-11-04T08:35:43Z")

</div>


