# EntitlementBootstrap failure preventing startup: AttachNotSupportedException: Unable to open socket file

**URL:** <https://discuss.elastic.co/t/entitlementbootstrap-failure-preventing-startup-attachnotsupportedexception-unable-to-open-socket-file/382452>\
**Category:** Elasticsearch\
**Created:** [October 6, 2025, 4:40pm UTC](https://discuss.elastic.co/t/entitlementbootstrap-failure-preventing-startup-attachnotsupportedexception-unable-to-open-socket-file/382452 "2025-10-06T16:40:33Z")\
**Posts on this page:** 1\
**Showing post:** 19

<div class="post-metadata">

**Author:** ![RainTown](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/raintown/32/140206_2.png) [@RainTown](https://discuss.elastic.co/u/RainTown)\
**Post date:** [October 10, 2025, 5:40pm UTC](https://discuss.elastic.co/t/entitlementbootstrap-failure-preventing-startup-attachnotsupportedexception-unable-to-open-socket-file/382452/19 "2025-10-10T17:40:43Z")

</div>

> [@buitcj](#):
>
> So it seems weird that our checks are failing even though things have always been working

Mmm. This is broadly the same story as the other thread, which I checked again:

> [@Self-hosted ES startup fails after upgrading 8.18.0 -\> 8.18.2 due to changes in entitlements](https://discuss.elastic.co/t/self-hosted-es-startup-fails-after-upgrading-8-18-0-8-18-2-due-to-changes-in-entitlements/379440):
>
> In our self-hosted hardened RHEL 8 installed via RPM Elasticsearch 8.18.2 a node failed to start due to changes made here. What would be a sustainable way to fix this error? Just remove this addition from entitlement-policy.yaml or some other solution? we removed this to get elastic to start again from entitlement-policy.yaml what was the addition in the pull request. org.elasticsearch.repository.url: - outbound\_network - files: - relative\_path: . relative\_to: shared\_repo …

Note that also led to a fatal error on startup.

In broadest sense, there's little point in "checking" if you are not going to do something based on the result of the checks. In this case it appears the ownership/permissions are considered an issue that also means a fatal startup error. Probably @DavidTurner or someone else will have to answer to clear up the doubt. Would it be a bug that this completely prevents startup? IMO yes, but without too much conviction. I do agree the way it fails, like the path.repo case, is not helpful or user-friendly from an admin perspective. And I also agree the set of "checks", and any consequences, should remain as consistent as possible through 8.x to 8.y upgrades, but it feels like that train has already left the station.

---

_[View the full topic](https://discuss.elastic.co/t/entitlementbootstrap-failure-preventing-startup-attachnotsupportedexception-unable-to-open-socket-file/382452)._
