# EQL - Alert when Follow up event doesn't occur

**URL:** <https://discuss.elastic.co/t/eql-alert-when-follow-up-event-doesnt-occur/329917>\
**Category:** Elastic Security\
**Created:** [April 13, 2023, 10:01am UTC](https://discuss.elastic.co/t/eql-alert-when-follow-up-event-doesnt-occur/329917 "2023-04-13T10:01:03Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![lilow](https://avatars.discourse-cdn.com/v4/letter/l/e95f7d/32.png) [@lilow](https://discuss.elastic.co/u/lilow)\
**Post date:** [April 13, 2023, 10:01am UTC](https://discuss.elastic.co/t/eql-alert-when-follow-up-event-doesnt-occur/329917/1 "2023-04-13T10:01:03Z")

</div>

Hey,  
I'm trying to implement a rule with eql where I only want to get an alert when a follow up event doesn't occur within a certain time frame. Unfortunately it's not really doing what I'm hoping.  
Is there any way how to fix this?

sequence by host.name with maxspan=5m  
[process where event.code == xxxx]  
[process where event.code != yyyy]

Thanks a lot in advance!

---

<div class="post-metadata">

**Author:** ![spong](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spong/32/54343_2.png) [@spong](https://discuss.elastic.co/u/spong)\
**Post date:** [April 13, 2023, 11:50pm UTC](https://discuss.elastic.co/t/eql-alert-when-follow-up-event-doesnt-occur/329917/2 "2023-04-13T23:50:28Z")

</div>

Hey there @lilow! 👋 Welcome to the community! 🎉 🙂

So unfortunately it looks like there is no easy way to do this at the moment. There was a similar [thread over here](https://discuss.elastic.co/t/alert-when-an-event-is-not-followed-by-another/314527/6) that mentions there is work underway to support this though.

Though as mentioned by [this other user](https://discuss.elastic.co/t/alert-when-an-event-is-not-followed-by-another/314527/7), you may be able to implement this another way depending on your configuration.

Hope this helps!

Cheers!  
Garrett

edit: For reference, this looks like the [public issue/PR](https://github.com/elastic/elasticsearch/pull/92348) you'll want to follow for when this feature will be available.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 11, 2023, 11:50pm UTC](https://discuss.elastic.co/t/eql-alert-when-follow-up-event-doesnt-occur/329917/3 "2023-05-11T23:50:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

---

<div class="post-metadata">

**Author:** ![spong](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spong/32/54343_2.png) [@spong](https://discuss.elastic.co/u/spong)\
**Post date:** [June 20, 2023, 2:38pm UTC](https://discuss.elastic.co/t/eql-alert-when-follow-up-event-doesnt-occur/329917/4 "2023-06-20T14:38:07Z")

</div>

Just an update: support for missing events in sequences has just been merged and will be available in the `8.9` release! 🎉 🙂

Additional details here: [https://github.com/elastic/eql/issues/21#issuecomment-1598724072](https://github.com/elastic/eql/issues/21#issuecomment-1598724072)
