# EQL correlation rule is timing out...sometimes

**URL:** <https://discuss.elastic.co/t/eql-correlation-rule-is-timing-out-sometimes/316641>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-alerting\
**Created:** [October 14, 2022, 1:21pm UTC](https://discuss.elastic.co/t/eql-correlation-rule-is-timing-out-sometimes/316641 "2022-10-14T13:21:54Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![gweiss76](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gweiss76/32/112071_2.png) [@gweiss76](https://discuss.elastic.co/u/gweiss76)\
**Post date:** [October 14, 2022, 1:21pm UTC](https://discuss.elastic.co/t/eql-correlation-rule-is-timing-out-sometimes/316641/1 "2022-10-14T13:21:54Z")

</div>

Hi fellow log analysts

We have a simple EQL correlation rule which we use to identify password changes on critical accounts (eventlog based). It looks like this:

```auto
[any where event.code == "4624"] by winlog.event_data.TargetLogonId
[any where (event.code == "4724" or event.code == "4723") and (ad_account_source != null) and (winlog.event_data.TargetDomainName == "REDACTED")] by winlog.event_data.SubjectLogonId
until [any where event.code == "4720"] by winlog.event_data.SubjectLogonId

```

This generally works fine, but sometimes the EQL rule fails with a "Request timed out".  
The index is pretty huge approx 100m docs. We already had to increase memory of our nodes to have elastic process the correlation. (3 nodes a 128GB RAM)

Any hints on this?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 11, 2022, 1:22pm UTC](https://discuss.elastic.co/t/eql-correlation-rule-is-timing-out-sometimes/316641/2 "2022-11-11T13:22:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
