# EQL Language trouble when creating custom rule

**URL:** <https://discuss.elastic.co/t/eql-language-trouble-when-creating-custom-rule/343144>\
**Category:** Kibana\
**Tags:** detection-rules, eql-elastic-query-language\
**Created:** [September 15, 2023, 2:02pm UTC](https://discuss.elastic.co/t/eql-language-trouble-when-creating-custom-rule/343144 "2023-09-15T14:02:43Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Brandon\_Duffy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_duffy/32/125709_2.png) [@Brandon\_Duffy](https://discuss.elastic.co/u/Brandon_Duffy)\
**Post date:** [September 15, 2023, 2:02pm UTC](https://discuss.elastic.co/t/eql-language-trouble-when-creating-custom-rule/343144/1 "2023-09-15T14:02:43Z")

</div>

Hello, I've been working on this rule for some time now, and it is only partially working.

I am able to see the net.exe related alerts populate, and used to see 'systeminfo', 'hostname', 'nslookup', now i do not.

I can not get the 'ipconfig /all', 'wmic process list full', 'netstat -an', 'route print', or 'route point' arguments.

Here is my EQL rule:  
'''  
process where event.type in ("start", "process\_started") and  
(  
(process.command\_line : "route print" or  
process.args : "hostname" or  
process.args : "ver" or  
process.args : "systeminfo\*" or  
process.args : "ipconfig /all" or  
process.args : "_netstat -an_" or  
process.command\_line : "_route point_" or  
process.args : "nslookup" or  
process.command\_line : "wmic process list full" or  
process.name : "net.exe" or process.name : "net1.exe") and  
(  
process.args : "users" or  
process.command\_line : "_localgroup_" or  
process.command\_line : "_group /domain_"  
)  
)  
'''  
Any help is appreciated!

![image](https://us1.discourse-cdn.com/elastic/original/3X/4/6/46bc58c60f2593968dd94d12271c850f97c9136a.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 13, 2023, 2:02pm UTC](https://discuss.elastic.co/t/eql-language-trouble-when-creating-custom-rule/343144/2 "2023-10-13T14:02:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
