# EQL with time filter

**URL:** <https://discuss.elastic.co/t/eql-with-time-filter/316781>\
**Category:** Elasticsearch\
**Tags:** eql-elastic-query-language\
**Created:** [October 17, 2022, 12:24pm UTC](https://discuss.elastic.co/t/eql-with-time-filter/316781 "2022-10-17T12:24:31Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![kmz161](https://avatars.discourse-cdn.com/v4/letter/k/838e76/32.png) [@kmz161](https://discuss.elastic.co/u/kmz161)\
**Post date:** [October 17, 2022, 12:24pm UTC](https://discuss.elastic.co/t/eql-with-time-filter/316781/1 "2022-10-17T12:24:31Z")

</div>

Hello!

I use rule for checking Sysmon logs

'''any where event.code == 1 and process.executable: "_C:\Windows\System32\sc.exe_" '''

The rule is working, but it checks all existing indexes.  
And my ELK is very loaded. How can I create a time filter for this rule?

 ![Снимок экрана 2022-10-17 в 15.22.20](https://us1.discourse-cdn.com/elastic/original/3X/a/2/a2e06b68a03015dbed4d2a9af4df0ffb54846a83.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 14, 2022, 12:25pm UTC](https://discuss.elastic.co/t/eql-with-time-filter/316781/2 "2022-11-14T12:25:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
