# ERROR: \[1\] bootstrap checks failed in Elastic Search

**URL:** <https://discuss.elastic.co/t/error-1-bootstrap-checks-failed-in-elastic-search/227509>\
**Category:** Elasticsearch\
**Created:** [April 10, 2020, 1:25pm UTC](https://discuss.elastic.co/t/error-1-bootstrap-checks-failed-in-elastic-search/227509 "2020-04-10T13:25:33Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![subhamchatterjee](https://avatars.discourse-cdn.com/v4/letter/s/c5a1d2/32.png) [@subhamchatterjee](https://discuss.elastic.co/u/subhamchatterjee)\
**Post date:** [April 10, 2020, 1:25pm UTC](https://discuss.elastic.co/t/error-1-bootstrap-checks-failed-in-elastic-search/227509/1 "2020-04-10T13:25:33Z")

</div>

While running elastic search via `sudo systemctl start elasticsearch.service` getting error

```auto
Job for elasticsearch.service failed because the control process exited with error code.
See "systemctl status elasticsearch.service" and "journalctl -xe" for details.

```

While running `sudo systemctl status elasticsearch.service` ,it's displaying

```auto
elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2020-04-10 18:38:40 IST; 12min ago
     Docs: http://www.elastic.co
  Process: 8148 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=78)
 Main PID: 8148 (code=exited, status=78)

Apr 10 18:38:25 subham systemd[1]: Starting Elasticsearch...
Apr 10 18:38:26 subham elasticsearch[8148]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will li
Apr 10 18:38:40 subham elasticsearch[8148]: ERROR: [1] bootstrap checks failed
Apr 10 18:38:40 subham elasticsearch[8148]: [1]: the default discovery settings are unsuitable for production use; at least one of [discovery.see
Apr 10 18:38:40 subham elasticsearch[8148]: ERROR: Elasticsearch did not exit normally - check the logs at /var/log/elasticsearch/elasticsearch.l
Apr 10 18:38:40 subham systemd[1]: elasticsearch.service: Main process exited, code=exited, status=78/n/a
Apr 10 18:38:40 subham systemd[1]: elasticsearch.service: Failed with result 'exit-code'.
Apr 10 18:38:40 subham systemd[1]: Failed to start Elasticsearch.

```

Below is my elasticsearch.yml:

```auto
# ---------------------------------- Cluster -----------------------------------
#
# Use a descriptive name for your cluster:
#
#cluster.name: my-application
#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node:
#
node.name: node-1
#
# Add custom attributes to the node:
#
#node.attr.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
path.data: /var/lib/elasticsearch
#
# Path to log files:
#
path.logs: /var/log/elasticsearch
#
# ----------------------------------- Memory -----------------------------------
#
# Lock the memory on startup:
#
#bootstrap.memory_lock: true
#
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#

```

OS Version : Ubuntu 18.04  
Java Version:

```auto
java version "1.8.0_212"
Java(TM) SE Runtime Environment (build 1.8.0_212-b10)
Java HotSpot(TM) 64-Bit Server VM (build 25.212-b10, mixed mode)

```

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [April 10, 2020, 1:28pm UTC](https://discuss.elastic.co/t/error-1-bootstrap-checks-failed-in-elastic-search/227509/2 "2020-04-10T13:28:47Z")

</div>

There should be information about which bootstrap check failed and how to fix this in the Elasticsearch logs. I recommend having a look there.

---

<div class="post-metadata">

**Author:** ![subhamchatterjee](https://avatars.discourse-cdn.com/v4/letter/s/c5a1d2/32.png) [@subhamchatterjee](https://discuss.elastic.co/u/subhamchatterjee)\
**Post date:** [April 10, 2020, 1:34pm UTC](https://discuss.elastic.co/t/error-1-bootstrap-checks-failed-in-elastic-search/227509/3 "2020-04-10T13:34:57Z")

</div>

Could you please send the link here?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 10, 2020, 1:38pm UTC](https://discuss.elastic.co/t/error-1-bootstrap-checks-failed-in-elastic-search/227509/4 "2020-04-10T13:38:46Z")

</div>

Please read [https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html)

---

<div class="post-metadata">

**Author:** ![subhamchatterjee](https://avatars.discourse-cdn.com/v4/letter/s/c5a1d2/32.png) [@subhamchatterjee](https://discuss.elastic.co/u/subhamchatterjee)\
**Post date:** [April 10, 2020, 1:47pm UTC](https://discuss.elastic.co/t/error-1-bootstrap-checks-failed-in-elastic-search/227509/5 "2020-04-10T13:47:50Z")

</div>

Thanks.The problem is solved.Just Changed  
`network.host: 0.0.0.0` to `network.host: 127.0.0.1`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 8, 2020, 1:47pm UTC](https://discuss.elastic.co/t/error-1-bootstrap-checks-failed-in-elastic-search/227509/6 "2020-05-08T13:47:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
