# Error 1053 when starting winlogbeat or auditbeat

**URL:** <https://discuss.elastic.co/t/error-1053-when-starting-winlogbeat-or-auditbeat/312917>\
**Category:** Beats\
**Tags:** winlogbeat, auditbeat\
**Created:** [August 25, 2022, 12:03pm UTC](https://discuss.elastic.co/t/error-1053-when-starting-winlogbeat-or-auditbeat/312917 "2022-08-25T12:03:53Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mammodde](https://avatars.discourse-cdn.com/v4/letter/m/f08c70/32.png) [@mammodde](https://discuss.elastic.co/u/mammodde)\
**Post date:** [August 25, 2022, 12:03pm UTC](https://discuss.elastic.co/t/error-1053-when-starting-winlogbeat-or-auditbeat/312917/1 "2022-08-25T12:03:53Z")

</div>

Goodmorning, when i try to Start-Service winlogbeat i receive the error 1053m same thing for auditbeat.  
for the yml files i followed the getting started guide, so there should not be any error.  
i have a keystore and it is in C:/ProgramData/Winlogbeat, as I read on a similar topic.  
As i read online I also set the Timeout to 180000 for the service, but that didn't work.

the test config says Config OK, the setup doesn't return any error and if I run  
.\winlogbeat.exe -c .\winlogbeat.yml -e -v -d "\*"  
everything works and I am able to see the logs on kibana.

this is winlogbeat.yml

```auto
winlogbeat.event_logs:
  - name: Application
    ignore_older: 72h

  - name: System

  - name: Security
    level: critical, error, warning

  - name: Microsoft-Windows-Sysmon/Operational

  - name: Windows PowerShell
    event_id: 400, 403, 600, 800

  - name: Microsoft-Windows-PowerShell/Operational
    event_id: 4103, 4104, 4105, 4106

  - name: ForwardedEvents
    tags: [forwarded]

winlogbeat.registry_file: C:/ProgramData/winlogbeat/winlogbeat.yml

setup.template.settings:
  index.number_of_shards: 1

setup.kibana:
host: "http://xxxxxxx:5601"
output.elasticsearch:
# # Array of hosts to connect to.
  hosts: ["https://xxxx:9200"]
#
# # Protocol - either `http` (default) or `https`.
# #protocol: "https"
#
# # Authentication credentials - either API key or username/password.
# #api_key: "id:api_key"
  username: "xxxxxx"
  password: "${ES_PWD}"
  ssl:
    certificate_authorities: 
      - ./xxxxxx.pem
    certificate: "./xxxxx.pem"
    key: "./xxxxx.key"

processors:
  - add_host_metadata:
      when.not.contains.tags: forwarded
  - add_cloud_metadata: ~

```

in the properties of the service I also have this, don't know if that could help

```auto
"C:\Program Files\Winlogbeat\winlogbeat.exe" --environment=windows_service -c "C:\Program Files\Winlogbeat\winlogbeat.yml" --path.home "C:\Program Files\Winlogbeat" --path.data "C:\ProgramData\winlogbeat" --path.logs "C:\ProgramData\winlogbeat\logs" -E logging.files.redirect_stderr=true

```

---

<div class="post-metadata">

**Author:** ![mammodde](https://avatars.discourse-cdn.com/v4/letter/m/f08c70/32.png) [@mammodde](https://discuss.elastic.co/u/mammodde)\
**Post date:** [August 25, 2022, 1:12pm UTC](https://discuss.elastic.co/t/error-1053-when-starting-winlogbeat-or-auditbeat/312917/2 "2022-08-25T13:12:17Z")

</div>

I resolved the problem by inserting the absolute paths for the certificates instead of the relative ones.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 22, 2022, 3:12pm UTC](https://discuss.elastic.co/t/error-1053-when-starting-winlogbeat-or-auditbeat/312917/3 "2022-09-22T15:12:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
