# Error 404 on report

**URL:** <https://discuss.elastic.co/t/error-404-on-report/60052>\
**Category:** Kibana\
**Tags:** elastic-stack-reporting\
**Created:** [September 8, 2016, 8:36am UTC](https://discuss.elastic.co/t/error-404-on-report/60052 "2016-09-08T08:36:33Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![tatdat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tatdat/32/113160_2.png) [@tatdat](https://discuss.elastic.co/u/tatdat)\
**Post date:** [September 8, 2016, 8:36am UTC](https://discuss.elastic.co/t/error-404-on-report/60052/1 "2016-09-08T08:36:33Z")

</div>

Hi, I'm updated Elastic 2,4 , LS 2,4 , Kibana 4.6 and Installed Report into Kibana.

But when i using report function in kibana, It's not working.

Here is my error.

 ![](https://us1.discourse-cdn.com/elastic/original/2X/d/dc6d9e0c14af164ce74561076ef44ad5763e5f25.PNG)

---

<div class="post-metadata">

**Author:** ![tbragin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tbragin/32/45166_2.png) [@tbragin](https://discuss.elastic.co/u/tbragin)\
**Post date:** [September 8, 2016, 4:31pm UTC](https://discuss.elastic.co/t/error-404-on-report/60052/2 "2016-09-08T16:31:28Z")

</div>

Are you deploying these versions on your own hardware or in Elastic Cloud? If the former, do you have a proxy between any components? What exactly are you doing right before the error comes up (e.g. hit the "Printable PDF" button, hit the "copy URL" button, copy the "Generate URL" and paste it in the browser, etc..)

---

<div class="post-metadata">

**Author:** ![imHarshj](https://avatars.discourse-cdn.com/v4/letter/i/e495f1/32.png) [@imHarshj](https://discuss.elastic.co/u/imHarshj)\
**Post date:** [October 17, 2016, 2:27pm UTC](https://discuss.elastic.co/t/error-404-on-report/60052/3 "2016-10-17T14:27:20Z")

</div>

Tanya - I'm getting the same error.  
Same configs as the original poster.

When I hit "Printable PDF" i get the error with no indication of what is wrong. Followed the instructions in docs.  
I'm using shield and have given reporting\_user permission to user and to kibana. Not sure what else I need to do.

EDIT: SOLVED - When using Shield and secure https, need to add settingIn kibana.yml. Add - reporting.kibanaServer.protocol: "https"

---

<div class="post-metadata">

**Author:** ![shaharmor](https://avatars.discourse-cdn.com/v4/letter/s/58f4c7/32.png) [@shaharmor](https://discuss.elastic.co/u/shaharmor)\
**Post date:** [December 4, 2016, 8:12am UTC](https://discuss.elastic.co/t/error-404-on-report/60052/4 "2016-12-04T08:12:53Z")

</div>

I also have this error, and I'm not using shield...

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 4, 2016, 8:29am UTC](https://discuss.elastic.co/t/error-404-on-report/60052/5 "2016-12-04T08:29:47Z")

</div>

Open a new discussion and describe all what you have: versions, plugins...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:42pm UTC](https://discuss.elastic.co/t/error-404-on-report/60052/6 "2017-07-06T13:42:50Z")

</div>


