# Error 500 Internal Server Error

**URL:** https://discuss.elastic.co/t/error-500-internal-server-error/46513
**Category:** Kibana
**Tags:** elastic-stack-graph
**Created:** [April 6, 2016, 11:18am UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513 "2016-04-06T11:18:40Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![theo.bot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theo.bot/32/5739_2.png) [@theo.bot](https://discuss.elastic.co/u/theo.bot)
#### Post date: [April 6, 2016, 11:18am UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513/1 "2016-04-06T11:18:40Z")

</div>

I just install graph to an es server (2.3.1) with shield. But when I tried to pass a query I got an error 500.  
In the logs i found the following:  
Kibana.stdout:  
{"type":"error","@timestamp":"2016-04-06T10:55:06+00:00","tags":[],"pid":16028,"level":"error","message":"[illegal\_state\_exception]  
Field data loading is forbidden on  
[message]","error":{"message":"[illegal\_state\_exception]  
Field data loading is forbidden on  
[message]","name":"Error","stack":"[illegal\_state\_exception] Field data  
loading is forbidden on [message] ::  
{"path":"/logstash-2016.04.06/\_graph/explore","query":{},"body":"{\"query\":{\"query\_string\":{\"default\_field\":\"\_all\",\"query\":\"VLAN100\"}},\"controls\":{\"use\_significance\":true,\"sample\_size\":2000,\"timeout\":5000},\"connections\":{\"vertices\":[{\"field\":\"message\",\"size\":5,\"min\_doc\_count\":3}]},\"vertices\":[{\"field\":\"message\",\"size\":5,\"min\_doc\_count\":3}]}","statusCode":500,"response":"{\"error\":{\"root\_cause\":[{\"type\":\"illegal\_state\_exception\",\"reason\":\"Field

data loading is forbidden on  
[message]\"}],\"type\":\"search\_phase\_execution\_exception\",\"reason\":\"all  
shards  
failed\",\"phase\":\"query\",\"grouped\":true,\"failed\_shards\":[{\"shard\":0,\"index\":\"logstash-2016.04.06\",\"node\":\"uzq\_HT8uRBeK3PpkKMd-Hw\",\"reason\":{\"type\":\"illegal\_state\_exception\",\"reason\":\"Field

data loading is forbidden on  
[message]\"}}]},\"status\":500}"}\n at respond  
(/apps/Oss/ELK/kibana-4.5.0-linux-x64/node\_modules/elasticsearch/src/lib/transport.js:238:15)\n  
at checkRespForFailure  
(/apps/Oss/ELK/kibana-4.5.0-linux-x64/node\_modules/elasticsearch/src/lib/transport.js:201:7)\n

at HttpConnector.  
(/apps/Oss/ELK/kibana-4.5.0-linux-x64/node\_modules/elasticsearch/src/lib/connectors/http.js:155:7)\n  
at IncomingMessage.wrapper  
(/apps/Oss/ELK/kibana-4.5.0-linux-x64/node\_modules/lodash/index.js:3095:19)\n  
at emitNone (events.js:72:20)\n  
at IncomingMessage.emit (events.js:166:7)\n at endReadableNT  
(\_stream\_readable.js:905:12)\n at nextTickCallbackWith2Args  
(node.js:437:9)\n at process.\_tickDomainCallback  
(node.js:392:17)"},"url":{"protocol":null,"slashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":null,"query":{},"pathname":"/api/graph/graphExplore","path":"/api/graph/graphExplore","href":"/api/graph/graphExplore"}}  
{"type":"response","@timestamp":"2016-04-06T10:55:06+00:00","tags":[],"pid":16028,"method":"post","statusCode":500,"req":{"url":"/api/graph/graphExplore","method":"post","headers":{"host":"[lqzc4007.mod.nl:5601](http://lqzc4007.mod.nl:5601)","user-agent":"Mozilla/5.0

(Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101  
Firefox/39.0","accept":"application/json, text/plain,  
_/_","accept-language":"nl,en-US;q=0.7,en;q=0.3","accept-encoding":"gzip,

deflate","content-type":"application/json;charset=utf-8","kbn-version":"4.5.0","referer":"[https://lqzc4007.mod.nl:5601/app/graph","content-length":"316","cookie":"sid=Fe26.2](https://lqzc4007.mod.nl:5601/app/graph%22,%22content-length%22:%22316%22,%22cookie%22:%22sid=Fe26.2) **264f6170d6f10154c5e44c3982f4dad3894496d8e122ec0e2b7e27e583f76d4c_vNIRzIQvDaGUsJE5RmNpPg_BxTIuaiEltoTphjp9n56l0ghUQjxs23\_nI9rHj-xEUCb4\_4iUHMMf-rvhKDWmiUsxE\_5M8R0RNfc17AyqAs0\_zDuP1OLiRXc1rtvUzxB31w** c6f285b22913325034fd41140911373e7954a38922a7faf97998d4f8bff6f13d\*6U8auPE4EzdrdytQ3YlIGtFYRAIYS\_dnc13\_iCk\_Bgg","connection":"keep-alive","pragma":"no-cache","cache-control":"no-cache"},"remoteAddress":"10.50.101.106","userAgent":"10.50.101.106","referer":"[https://lqzc4007.mod.nl:5601/app/graph"},"res":{"statusCode":500,"responseTime":59,"contentLength":9},"message":"POST](https://lqzc4007.mod.nl:5601/app/graph%22%7D,%22res%22:%7B%22statusCode%22:500,%22responseTime%22:59,%22contentLength%22:9%7D,%22message%22:%22POST)

/api/graph/graphExplore 500 59ms - 9.0B"}

Please help

Kind regards

Theo

---

<div class="post-metadata">

### Author: ![theo.bot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theo.bot/32/5739_2.png) [@theo.bot](https://discuss.elastic.co/u/theo.bot)
#### Post date: [April 6, 2016, 11:21am UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513/2 "2016-04-06T11:21:36Z")

</div>

And elasticsearch.log  
[2016-04-06 12:55:06,849][WARN  
][rest.suppressed] /logstash-2016.04.06/\_graph/explore Params:  
{index=logstash-2016.04.06}  
Failed to execute phase [query],  
all shards failed; shardFailures  
{[uzq\_HT8uRBeK3PpkKMd-Hw][logstash-2016.04.06][0]:  
RemoteTransportException[[EServer][10.50.101.158:9300][indices:data/read/search[phase/query]]];  
nested:  
SearchParseException[failed to parse search source  
[{"size":0,"timeout":5000,"query":{"bool":{"must":{"query\_string":{"default\_field":"\_all","query":"VLAN100"}}}},"aggregations":{"sample":{"sampler":{"shard\_size":2000},"aggregations":{"field0":{"significant\_terms":{"field":"message","size":5,"min\_doc\_count":3,"shard\_min\_doc\_count":2,"execution\_hint":"map"}}}}}}]];

nested: IllegalStateException[Field data loading is forbidden on  
[message]]; }{[uzq\_HT8uRBeK3PpkKMd-Hw][logstash-2016.04.06][1]:  
RemoteTransportException[[EServer][10.50.101.158:9300][indices:data/read/search[phase/query]]];  
nested: SearchParseException[failed  
to parse search source  
[{"size":0,"timeout":5000,"query":{"bool":{"must":{"query\_string":{"default\_field":"\_all","query":"VLAN100"}}}},"aggregations":{"sample":{"sampler":{"shard\_size":2000},"aggregations":{"field0":{"significant\_terms":{"field":"message","size":5,"min\_doc\_count":3,"shard\_min\_doc\_count":2,"execution\_hint":"map"}}}}}}]];

nested: IllegalStateException[Field data loading is forbidden on  
[message]]; }{[uzq\_HT8uRBeK3PpkKMd-Hw][logstash-2016.04.06][2]:  
RemoteTransportException[[EServer][10.50.101.158:9300][indices:data/read/search[phase/query]]];  
nested: SearchParseException[failed  
to parse search source  
[{"size":0,"timeout":5000,"query":{"bool":{"must":{"query\_string":{"default\_field":"\_all","query":"VLAN100"}}}},"aggregations":{"sample":{"sampler":{"shard\_size":2000},"aggregations":{"field0":{"significant\_terms":{"field":"message","size":5,"min\_doc\_count":3,"shard\_min\_doc\_count":2,"execution\_hint":"map"}}}}}}]];

nested: IllegalStateException[Field data loading is forbidden on  
[message]]; }{[uzq\_HT8uRBeK3PpkKMd-Hw][logstash-2016.04.06][3]:  
RemoteTransportException[[EServer][10.50.101.158:9300][indices:data/read/search[phase/query]]];  
nested: SearchParseException[failed  
to parse search source  
[{"size":0,"timeout":5000,"query":{"bool":{"must":{"query\_string":{"default\_field":"\_all","query":"VLAN100"}}}},"aggregations":{"sample":{"sampler":{"shard\_size":2000},"aggregations":{"field0":{"significant\_terms":{"field":"message","size":5,"min\_doc\_count":3,"shard\_min\_doc\_count":2,"execution\_hint":"map"}}}}}}]];

nested: IllegalStateException[Field data loading is forbidden on  
[message]]; }{[uzq\_HT8uRBeK3PpkKMd-Hw][logstash-2016.04.06][4]:  
RemoteTransportException[[EServer][10.50.101.158:9300][indices:data/read/search[phase/query]]];  
nested: SearchParseException[failed  
to parse search source  
[{"size":0,"timeout":5000,"query":{"bool":{"must":{"query\_string":{"default\_field":"\_all","query":"VLAN100"}}}},"aggregations":{"sample":{"sampler":{"shard\_size":2000},"aggregations":{"field0":{"significant\_terms":{"field":"message","size":5,"min\_doc\_count":3,"shard\_min\_doc\_count":2,"execution\_hint":"map"}}}}}}]];

nested: IllegalStateException[Field data loading is forbidden on  
[message]]; }

---

<div class="post-metadata">

### Author: ![Mark\_Harwood](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mark_harwood/32/10538_2.png) [@Mark\_Harwood](https://discuss.elastic.co/u/Mark_Harwood)
#### Post date: [April 6, 2016, 2:34pm UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513/3 "2016-04-06T14:34:13Z")

</div>

If I recall correctly it is possible for an administrator to specifically exclude some fields from ever having field data loaded.

This looks like what would happen if that was done for the "message" field.

---

<div class="post-metadata">

### Author: ![tri](https://avatars.discourse-cdn.com/v4/letter/t/6bbea6/32.png) [@tri](https://discuss.elastic.co/u/tri)
#### Post date: [April 7, 2016, 4:47pm UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513/4 "2016-04-07T16:47:31Z")

</div>

I just installed the Graph plugin on a Windows installation and also got the same "500 Internal Server Error" when trying to do a simple search.  
The error specifies that Document mapping type can't start with a '\_' , probably in a path, but seems like the underscore in the path is created by the Graph plugin installation. Here's the Kibana error output:

error [09:38:24.187] [invalid\_type\_name\_exception] Document mapping type name  
can't start with '\_' :: {"path":"/logstash-2016.03.04/_graph/explore","query":{  
},"body":"{"query":{"query\_string":{"default\_field":"all","query":"s  
earch"}},"controls":{"use\_significance":true,"sample\_size":2000,"timeout  
":5000,"sample\_diversity":{"field":"clientname.raw","max\_docs\_per\_value  
":1}},"connections":{"vertices":[{"field":"operation","size":5,"min\_d  
oc\_count":3}]},"vertices":[{"field":"operation","size":5,"min\_doc\_coun  
t":3}]}","statusCode":400,"response":"{"error":{"root\_cause":[{"type":"i  
nvalid\_type\_name\_exception","reason":"Document mapping type name can't start  
with ''"}],"type":"invalid\_type\_name\_exception","reason":"Document map  
ping type name can't start with '_'"},"status":400}"}  
at respond (c:\ELK\Kibana\kibana-4.5.0-windows\node\_modules\elasticsearch\sr  
c\lib\transport.js:238:15)  
at checkRespForFailure (c:\ELK\Kibana\kibana-4.5.0-windows\node\_modules\elas  
ticsearch\src\lib\transport.js:201:7)  
at HttpConnector. (c:\ELK\Kibana\kibana-4.5.0-windows\node\_module  
s\elasticsearch\src\lib\connectors\http.js:155:7)  
at IncomingMessage.wrapper (c:\ELK\Kibana\kibana-4.5.0-windows\node\_modules  
lodash\index.js:3095:19)  
at emitNone (events.js:72:20)  
at IncomingMessage.emit (events.js:166:7)  
at endReadableNT (\_stream\_readable.js:905:12)  
at nextTickCallbackWith2Args (node.js:437:9)  
at process.\_tickDomainCallback (node.js:392:17)

Anybody run into a similar situation?

---

<div class="post-metadata">

### Author: ![skearns](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/skearns/32/125945_2.png) [@skearns](https://discuss.elastic.co/u/skearns)
#### Post date: [April 7, 2016, 5:09pm UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513/5 "2016-04-07T17:09:55Z")

</div>

Hi Pham, it looks like your issue is different than the others in this thread. This indicates that the Graph plugin isn't installed into Elasticsearch.

Can you ensure that you have installed the Graph and Licensing plugins into each Elasticsearch node, and that you have restarted the cluster?

---

<div class="post-metadata">

### Author: ![tri](https://avatars.discourse-cdn.com/v4/letter/t/6bbea6/32.png) [@tri](https://discuss.elastic.co/u/tri)
#### Post date: [April 7, 2016, 5:24pm UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513/6 "2016-04-07T17:24:59Z")

</div>

Thanks for the quick response. I found out that I didn't restart elastic search after the plugin installation. Restarted it and looks like it's working now.  
Thanks.

---

<div class="post-metadata">

### Author: ![theo.bot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theo.bot/32/5739_2.png) [@theo.bot](https://discuss.elastic.co/u/theo.bot)
#### Post date: [April 7, 2016, 6:35pm UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513/7 "2016-04-07T18:35:57Z")

</div>

Hi,

I can't remember that I restarted the Elasticsearch Server. And I cannot remember this was mentioned in any training or manual.

But I will do so next thing in the morning.

Thanks

Kind regards

Theo

---

<div class="post-metadata">

### Author: ![theo.bot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theo.bot/32/5739_2.png) [@theo.bot](https://discuss.elastic.co/u/theo.bot)
#### Post date: [April 11, 2016, 10:55am UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513/8 "2016-04-11T10:55:12Z")

</div>

Mark,

I cannot remeber i did such thing. The installation is pretty default. How can I determine this?

Kind regards,

Theo

---

<div class="post-metadata">

### Author: ![Mark\_Harwood](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mark_harwood/32/10538_2.png) [@Mark\_Harwood](https://discuss.elastic.co/u/Mark_Harwood)
#### Post date: [April 11, 2016, 11:07am UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513/9 "2016-04-11T11:07:38Z")

</div>

> [@theo.bot](#):
>
> How can I determine this?

I'm confused as to which of your issues you are referring (the failure to load "message" field data or the missing graph plugin?).  
I assume you mean the original field-data loading issue.  
To test field-data loading issues see if you can run this simple aggregation on the field - that will eliminate the graph plugin from the problem:

```
curl -XPOST "http://localhost:9200/logstash-2016.04.06/_search" -d'
{
   "size": 0,
   "aggs": {
	  "top_terms": {
		 "terms": {
			"field": "message"
		 }
	  }
   }
}'

```

---

<div class="post-metadata">

### Author: ![Andrea](https://avatars.discourse-cdn.com/v4/letter/a/c37758/32.png) [@Andrea](https://discuss.elastic.co/u/Andrea)
#### Post date: [July 20, 2016, 10:11am UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513/10 "2016-07-20T10:11:54Z")

</div>

Hi, I wanna install timelion plugin for kibana. I copied tilelion tar file to instaledPlugins folder and extracted it there. After running kibana I've gotten the error so I deleted it from there but Kibana is still not working. I have this error:

```
    '../src/ui/public/styles/theme.less\nModule build failed: Error: Cannot

```

find module 'color-name'\n at Function.Module.\_resolveFilename (module.js:3  
25:15)\n at Function.Module.\_load (module.js:276:25)\n at Module.require (  
module.js:353:17)\n at require (internal/module.js:12:17)\n at Object. (C:\Users\AJ31490\Downloads\kibana-5.0.0-alpha3-windows\kibana-5.0.  
0-alpha3-windows\node\_modules\css-loader\node\_modules\cssnano\node\_modules  
\postcss-colormin\node\_modules\colormin\node\_modules\color\node\_modules\co  
lor-string\color-string.js:2:18)\n at Module.\_compile (module.js:409:26)\n  
at Module.\_extensions..js (module.js:416:10)\n at Object.require.extensions  
.(anonymous function) [as .js] (C:\Users\AJ31490\Downloads\kibana-5.0.0-alph  
a3-windows\kibana-5.0.0-alpha3-windows\node\_modules\babel-core\lib\api\reg  
ister\node.js:214:7)\n at Module.load (module.js:343:32)\n at [Function.Mo](http://Function.Mo)  
dule.\_load (module.js:300:12)\n at Module.require (module.js:353:17)\n at  
require (internal/module.js:12:17)\n at Object. (C:\Users\AJ3149  
0\Downloads\kibana-5.0.0-alpha3-windows\kibana-5.0.0-alpha3-windows\node\_mod  
ules\css-loader\node\_modules\cssnano\node\_modules\postcss-colormin\node\_mo  
dules\colormin\node\_modules\color\index.js:3:14)\n at Module.\_compile (mo  
dule.js:409:26)\n at Module.\_extensions..js (module.js:416:10)\n at Object  
.require.extensions.(anonymous function) [as .js] (C:\Users\AJ31490\Downloads  
\kibana-5.0.0-alpha3-windows\kibana-5.0.0-alpha3-windows\node\_modules\babel-  
core\lib\api\register\node.js:214:7)\n @ ../src/ui/public/styles nonrecursiv  
e \/\\[^\/\\]+\.less',  
'../src/ui/public/styles/truncate.less\nModule build failed: Error: Cann  
ot find module 'color-name'\n at Function.Module.\_resolveFilename (module.j  
s:325:15)\n at Function.Module.\_load (module.js:276:25)\n at Module.requir  
e (module.js:353:17)\n at require (internal/module.js:12:17)\n at Object.\<  
anonymous\> (C:\Users\AJ31490\Downloads\kibana-5.0.0-alpha3-windows\kibana-5  
.0.0-alpha3-windows\node\_modules\css-loader\node\_modules\cssnano\node\_modul  
es\postcss-colormin\node\_modules\colormin\node\_modules\color\node\_modules  
\color-string\color-string.js:2:18)\n at Module.\_compile (module.js:409:26)  
n at Module.\_extensions..js (module.js:416:10)\n at Object.require.extensi  
ons.(anonymous function) [as .js] (C:\Users\AJ31490\Downloads\kibana-5.0.0-a  
lpha3-windows\kibana-5.0.0-alpha3-windows\node\_modules\babel-core\lib\api\  
register\node.js:214:7)\n at Module.load (module.js:343:32)\n at Function  
.Module._load (module.js:300:12)\n at Module.require (module.js:353:17)\n  
at require (internal/module.js:12:17)\n at Object. (C:\Users\AJ3  
1490\Downloads\kibana-5.0.0-alpha3-windows\kibana-5.0.0-alpha3-windows\node_  
modules\css-loader\node\_modules\cssnano\node\_modules\postcss-colormin\node  
\_modules\colormin\node\_modules\color\index.js:3:14)\n at Module.\_compile  
(module.js:409:26)\n at Module.\_extensions..js (module.js:416:10)\n at Obj  
ect.require.extensions.(anonymous function) [as .js] (C:\Users\AJ31490\Downlo  
ads\kibana-5.0.0-alpha3-windows\kibana-5.0.0-alpha3-windows\node\_modules\bab  
el-core\lib\api\register\node.js:214:7)\n @ ../src/ui/public/styles nonrecur  
sive \/\\[^\/\\]+\.less' ],  
publicPath: '/bundles/' },  
isBoom: true,  
isServer: true,  
output:  
{ statusCode: 500,  
payload:  
{ statusCode: 500,  
error: 'Internal Server Error',  
message: 'An internal server error occurred' },  
headers: {} },  
reformat: [Function] }

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:42pm UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513/11 "2017-07-06T13:42:58Z")

</div>


