# Error 8.5.0 running as systemctl service

**URL:** <https://discuss.elastic.co/t/error-8-5-0-running-as-systemctl-service/318278>\
**Category:** Logstash\
**Created:** [November 6, 2022, 11:14pm UTC](https://discuss.elastic.co/t/error-8-5-0-running-as-systemctl-service/318278 "2022-11-06T23:14:49Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![georgios.mpouras](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/georgios.mpouras/32/113006_2.png) [@georgios.mpouras](https://discuss.elastic.co/u/georgios.mpouras)\
**Post date:** [November 6, 2022, 11:14pm UTC](https://discuss.elastic.co/t/error-8-5-0-running-as-systemctl-service/318278/1 "2022-11-06T23:14:49Z")

</div>

I have a new installation of logstash 8.5.0 at Alma 9 from the repo  
When I run logstash as user logstash from the command line everything works as expocted

sudo -u logstash /usr/share/logstash/bin/logstash "--path.settings" "/etc/logstash"

```auto
[2022-11-07T01:06:03,370][INFO][logstash.javapipeline][.monitoring-logstash] Pipeline Java execution initialization time {"seconds"=>0.45}
[2022-11-07T01:06:03,447][INFO][logstash.javapipeline][.monitoring-logstash] Pipeline started {"pipeline.id"=>".monitoring-logstash"}
[2022-11-07T01:06:03,499][INFO][logstash.javapipeline][main] Pipeline started {"pipeline.id"=>"main"}
[2022-11-07T01:06:03,558][INFO][logstash.agent] Pipelines running {:count=>2, :running_pipelines=>[:".monitoring-logstash", :main], :non_running_pipelines=>[]}

```

When I start logstash as service ( systemctl start logstash ) it starts an endless loop of remove pipelines , shutting down and restartng.

```auto
[2022-11-07T00:58:44,378][INFO][logstash.pipelinesregistry] Removed pipeline from registry successfully {:pipeline_id=>:".monitoring-logstash"}
[2022-11-07T00:58:44,424][INFO][logstash.runner] Logstash shut down.
...

```

the pipelines.yml , logstash.yml are default , I have only a minimum stdin.stdout conf file for testing. I test and search almost anything without success .  
Thanks, George Bouras

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [November 6, 2022, 11:39pm UTC](https://discuss.elastic.co/t/error-8-5-0-running-as-systemctl-service/318278/2 "2022-11-06T23:39:56Z")

</div>

> [@georgios.mpouras](#):
>
> I have only a minimum stdin.stdout conf file for testing

Are you using `stdin` as the input while running it a a service?

Try to change to `tcp` input with a random port, since there is no input for `stdin` when you run Logstash as a service, so the pipeline may not work as expected.

Test with something like this:

```auto
input {
    tcp {
        port => "10000"
    }
}

```

---

<div class="post-metadata">

**Author:** ![georgios.mpouras](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/georgios.mpouras/32/113006_2.png) [@georgios.mpouras](https://discuss.elastic.co/u/georgios.mpouras)\
**Post date:** [November 7, 2022, 8:37am UTC](https://discuss.elastic.co/t/error-8-5-0-running-as-systemctl-service/318278/3 "2022-11-07T08:37:28Z")

</div>

Using the tcp input as you advised the service restart loop stopped.

Actually we have many pipelines at 8.5.0 that working fine at our kubernetes.  
The problem arised when I install it as rpm for development and trying to verify the basic functionality.

thanks for you help.  
G. Bouras

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 5, 2022, 8:38am UTC](https://discuss.elastic.co/t/error-8-5-0-running-as-systemctl-service/318278/4 "2022-12-05T08:38:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
