# Error accessing elastic monitoring tab on kibana

**URL:** https://discuss.elastic.co/t/error-accessing-elastic-monitoring-tab-on-kibana/300620
**Category:** Kibana
**Tags:** elastic-stack-monitoring
**Created:** [March 24, 2022, 6:39pm UTC](https://discuss.elastic.co/t/error-accessing-elastic-monitoring-tab-on-kibana/300620 "2022-03-24T18:39:14Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)
#### Post date: [March 24, 2022, 6:39pm UTC](https://discuss.elastic.co/t/error-accessing-elastic-monitoring-tab-on-kibana/300620/1 "2022-03-24T18:39:14Z")

</div>

Hi all  
After upgraded my cluster to version 8.1 now i cannot access the tab stack monitoring anymore

it keep give me this error

```auto
Access Denied
You are not authorized to access Monitoring. To use Monitoring, you need the privileges granted by both the `kibana_admin` and `monitoring_user ` roles.

If you are attempting to access a dedicated monitoring cluster, this might be because you are logged in as a user that is not configured on the monitoring cluster.

```

and on kibana log i get this

```auto
security_exception: [security_exception] Reason: action [indices:data/read/search] is unauthorized for user [elastic] with roles [superuser], this action is granted by the index privileges [read,all]

```

Is there a way to fix this issue  
Thanks for your time.

---

<div class="post-metadata">

### Author: ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)
#### Post date: [March 25, 2022, 1:54am UTC](https://discuss.elastic.co/t/error-accessing-elastic-monitoring-tab-on-kibana/300620/2 "2022-03-25T01:54:52Z")

</div>

Has anyone encounter this error before? Is there a solution for this error?

---

<div class="post-metadata">

### Author: ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)
#### Post date: [March 25, 2022, 7:47am UTC](https://discuss.elastic.co/t/error-accessing-elastic-monitoring-tab-on-kibana/300620/3 "2022-03-25T07:47:45Z")

</div>

I believe those users have roles that have been deprecated. You need a user with higher privileges now.

---

<div class="post-metadata">

### Author: ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)
#### Post date: [March 25, 2022, 8:03am UTC](https://discuss.elastic.co/t/error-accessing-elastic-monitoring-tab-on-kibana/300620/4 "2022-03-25T08:03:52Z")

</div>

The user i tried have the superuser roles, it still give me access denied.  
I event tried to use user build-in elastic to accesss the page and it still give me access denied.  
I'm not sure what is blocking me from accessing monitoring.

---

<div class="post-metadata">

### Author: ![Gabriel\_Chagas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gabriel_chagas/32/103559_2.png) [@Gabriel\_Chagas](https://discuss.elastic.co/u/Gabriel_Chagas)
#### Post date: [March 26, 2022, 8:50pm UTC](https://discuss.elastic.co/t/error-accessing-elastic-monitoring-tab-on-kibana/300620/5 "2022-03-26T20:50:22Z")

</div>

Hey. The issue is solved by adding `monitoring.ui.ccs.enabled: false` in kibana.yml as mentioned in [Stack Monitoring "access denied" after 8.0.0 upgrade · Issue #125756 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/125756)

---

<div class="post-metadata">

### Author: ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)
#### Post date: [March 27, 2022, 12:16pm UTC](https://discuss.elastic.co/t/error-accessing-elastic-monitoring-tab-on-kibana/300620/6 "2022-03-27T12:16:43Z")

</div>

Thanks that solve my issue.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 24, 2022, 12:17pm UTC](https://discuss.elastic.co/t/error-accessing-elastic-monitoring-tab-on-kibana/300620/7 "2022-04-24T12:17:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
