# Error accessing Kibana after Upgrade

**URL:** <https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677>\
**Category:** Kibana\
**Created:** [March 25, 2022, 9:00am UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677 "2022-03-25T09:00:49Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![kubernetes87](https://avatars.discourse-cdn.com/v4/letter/k/c67d28/32.png) [@kubernetes87](https://discuss.elastic.co/u/kubernetes87)\
**Post date:** [March 25, 2022, 9:00am UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/1 "2022-03-25T09:00:49Z")

</div>

Hi community,

for testing purposes I copied a VM with Ubuntu 18.04.6.  
On that machine everything worked fine.

I upgraded the Ubuntu to 21.10 (the underlying Kibana and Elasticsearch had been updated too).

Now I have an issue accessing Kibana.  
When accessing my kibana instance I am getting  
'Kibana server is not ready yet'

So I checked the kibana logs.

```auto

{"type":"log","@timestamp":"2022-03-25T09:56:25+01:00","tags":["warning","config","deprecation"],"pid":11911,"message":"Starting in 8.0, the Kibana logging format will be changing. This may affect you if you are doing any special handling of your Kibana logs, such as ingesting logs into Elasticsearch for further analysis. If you are using the new logging configuration, you are already receiving logs in both old and new formats, and the old format will simply be going away. If you are not yet using the new logging configuration, the log format will change upon upgrade to 8.0. Beginning in 8.0, the format of JSON logs will be ECS-compatible JSON, and the default pattern log format will be configurable with our new logging system. Please refer to the documentation for more information about the new logging format."}
{"type":"log","@timestamp":"2022-03-25T09:56:25+01:00","tags":["warning","config","deprecation"],"pid":11911,"message":"The default mechanism for Reporting privileges will work differently in future versions, which will affect the behavior of this cluster. Set \"xpack.reporting.roles.enabled\" to \"false\" to adopt the future behavior before upgrading."}
{"type":"log","@timestamp":"2022-03-25T09:56:25+01:00","tags":["warning","config","deprecation"],"pid":11911,"message":"User sessions will automatically time out after 8 hours of inactivity starting in 8.0. Override this value to change the timeout."}
{"type":"log","@timestamp":"2022-03-25T09:56:25+01:00","tags":["warning","config","deprecation"],"pid":11911,"message":"Users are automatically required to log in again after 30 days starting in 8.0. Override this value to change the timeout."}
{"type":"log","@timestamp":"2022-03-25T09:56:25+01:00","tags":["info","plugins-system","standard"],"pid":11911,"message":"Setting up [113] plugins: [translations,licensing,globalSearch,globalSearchProviders,features,licenseApiGuard,code,usageCollection,xpackLegacy,taskManager,telemetryCollectionManager,telemetryCollectionXpack,kibanaUsageCollection,share,embeddable,uiActionsEnhanced,screenshotMode,banners,telemetry,newsfeed,mapsEms,mapsLegacy,kibanaLegacy,fieldFormats,expressions,dataViews,charts,esUiShared,bfetch,data,savedObjects,presentationUtil,expressionShape,expressionRevealImage,expressionRepeatImage,expressionMetric,expressionImage,customIntegrations,home,searchprofiler,painlessLab,grokdebugger,management,watcher,licenseManagement,advancedSettings,spaces,security,savedObjectsTagging,reporting,canvas,lists,ingestPipelines,fileUpload,encryptedSavedObjects,dataEnhanced,cloud,snapshotRestore,eventLog,actions,alerting,triggersActionsUi,transform,stackAlerts,ruleRegistry,visualizations,visTypeXy,visTypeVislib,visTypeVega,visTypeTimelion,visTypeTagcloud,visTypeTable,visTypePie,visTypeMetric,visTypeMarkdown,tileMap,regionMap,expressionTagcloud,expressionMetricVis,console,graph,fleet,indexManagement,remoteClusters,crossClusterReplication,indexLifecycleManagement,dashboard,maps,dashboardMode,dashboardEnhanced,visualize,visTypeTimeseries,rollup,indexPatternFieldEditor,lens,cases,timelines,discover,osquery,observability,discoverEnhanced,dataVisualizer,ml,uptime,securitySolution,infra,upgradeAssistant,monitoring,logstash,enterpriseSearch,apm,savedObjectsManagement,indexPatternManagement]"}
{"type":"log","@timestamp":"2022-03-25T09:56:25+01:00","tags":["info","plugins","taskManager"],"pid":11911,"message":"TaskManager is identified by the Kibana UUID: 4ab39e6e-dac1-475e-b903-9514aa503907"}
{"type":"log","@timestamp":"2022-03-25T09:56:26+01:00","tags":["warning","plugins","security","config"],"pid":11911,"message":"Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
{"type":"log","@timestamp":"2022-03-25T09:56:26+01:00","tags":["warning","plugins","security","config"],"pid":11911,"message":"Session cookies will be transmitted over insecure connections. This is not recommended."}
{"type":"log","@timestamp":"2022-03-25T09:56:26+01:00","tags":["warning","plugins","security","config"],"pid":11911,"message":"Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
{"type":"log","@timestamp":"2022-03-25T09:56:26+01:00","tags":["warning","plugins","security","config"],"pid":11911,"message":"Session cookies will be transmitted over insecure connections. This is not recommended."}
{"type":"log","@timestamp":"2022-03-25T09:56:26+01:00","tags":["warning","plugins","reporting","config"],"pid":11911,"message":"Generating a random key for xpack.reporting.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.reporting.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
{"type":"log","@timestamp":"2022-03-25T09:56:26+01:00","tags":["warning","plugins","encryptedSavedObjects"],"pid":11911,"message":"Saved objects encryption key is not set. This will severely limit Kibana functionality. Please set xpack.encryptedSavedObjects.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
{"type":"log","@timestamp":"2022-03-25T09:56:26+01:00","tags":["warning","plugins","actions"],"pid":11911,"message":"APIs are disabled because the Encrypted Saved Objects plugin is missing encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
{"type":"log","@timestamp":"2022-03-25T09:56:26+01:00","tags":["warning","plugins","alerting"],"pid":11911,"message":"APIs are disabled because the Encrypted Saved Objects plugin is missing encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
{"type":"log","@timestamp":"2022-03-25T09:56:26+01:00","tags":["info","plugins","ruleRegistry"],"pid":11911,"message":"Installing common resources shared between all indices"}
{"type":"log","@timestamp":"2022-03-25T09:56:26+01:00","tags":["info","plugins","reporting","config"],"pid":11911,"message":"Chromium sandbox provides an additional layer of protection, and is supported for Linux Ubuntu 21.10 OS. Automatically enabling Chromium sandbox."}
{"type":"log","@timestamp":"2022-03-25T09:56:28+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations..."}
{"type":"log","@timestamp":"2022-03-25T09:56:28+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"Starting saved objects migrations"}
{"type":"log","@timestamp":"2022-03-25T09:56:28+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"[.kibana] INIT -> WAIT_FOR_YELLOW_SOURCE. took: 203ms."}
{"type":"log","@timestamp":"2022-03-25T09:56:28+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"[.kibana_task_manager] INIT -> WAIT_FOR_YELLOW_SOURCE. took: 204ms."}
{"type":"log","@timestamp":"2022-03-25T09:56:28+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"[.kibana] WAIT_FOR_YELLOW_SOURCE -> CHECK_UNKNOWN_DOCUMENTS. took: 103ms."}
{"type":"log","@timestamp":"2022-03-25T09:56:29+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"[.kibana] CHECK_UNKNOWN_DOCUMENTS -> SET_SOURCE_WRITE_BLOCK. took: 64ms."}
{"type":"log","@timestamp":"2022-03-25T09:56:29+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"[.kibana] SET_SOURCE_WRITE_BLOCK -> CALCULATE_EXCLUDE_FILTERS. took: 15ms."}
{"type":"log","@timestamp":"2022-03-25T09:56:29+01:00","tags":["error","savedobjects-service"],"pid":11911,"message":"[.kibana] Action failed with 'search_phase_execution_exception: [no_shard_available_action_exception] Reason: null'. Retrying attempt 1 in 2 seconds."}
{"type":"log","@timestamp":"2022-03-25T09:56:29+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"[.kibana] CALCULATE_EXCLUDE_FILTERS -> CALCULATE_EXCLUDE_FILTERS. took: 33ms."}
{"type":"log","@timestamp":"2022-03-25T09:56:31+01:00","tags":["error","savedobjects-service"],"pid":11911,"message":"[.kibana] Action failed with 'search_phase_execution_exception: [no_shard_available_action_exception] Reason: null'. Retrying attempt 2 in 4 seconds."}
{"type":"log","@timestamp":"2022-03-25T09:56:31+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"[.kibana] CALCULATE_EXCLUDE_FILTERS -> CALCULATE_EXCLUDE_FILTERS. took: 2049ms."}
{"type":"log","@timestamp":"2022-03-25T09:56:35+01:00","tags":["error","savedobjects-service"],"pid":11911,"message":"[.kibana] Action failed with 'search_phase_execution_exception: [no_shard_available_action_exception] Reason: null'. Retrying attempt 3 in 8 seconds."}
{"type":"log","@timestamp":"2022-03-25T09:56:35+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"[.kibana] CALCULATE_EXCLUDE_FILTERS -> CALCULATE_EXCLUDE_FILTERS. took: 4017ms."}
{"type":"log","@timestamp":"2022-03-25T09:56:43+01:00","tags":["error","savedobjects-service"],"pid":11911,"message":"[.kibana] Action failed with 'search_phase_execution_exception: [no_shard_available_action_exception] Reason: null'. Retrying attempt 4 in 16 seconds."}
{"type":"log","@timestamp":"2022-03-25T09:56:43+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"[.kibana] CALCULATE_EXCLUDE_FILTERS -> CALCULATE_EXCLUDE_FILTERS. took: 8019ms."}
{"type":"log","@timestamp":"2022-03-25T09:56:59+01:00","tags":["error","savedobjects-service"],"pid":11911,"message":"[.kibana] Action failed with 'search_phase_execution_exception: [no_shard_available_action_exception] Reason: null'. Retrying attempt 5 in 32 seconds."}
{"type":"log","@timestamp":"2022-03-25T09:56:59+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"[.kibana] CALCULATE_EXCLUDE_FILTERS -> CALCULATE_EXCLUDE_FILTERS. took: 16033ms."}
{"type":"log","@timestamp":"2022-03-25T09:57:31+01:00","tags":["error","savedobjects-service"],"pid":11911,"message":"[.kibana] Action failed with 'search_phase_execution_exception: [no_shard_available_action_exception] Reason: null'. Retrying attempt 6 in 64 seconds."}
{"type":"log","@timestamp":"2022-03-25T09:57:31+01:00","tags":["info","savedobjects-service"],"pid":11911,"message":"[.kibana] CALCULATE_EXCLUDE_FILTERS -> CALCULATE_EXCLUDE_FILTERS. took: 32040ms."}

```

What can I check to get Kibana server ready?

thank you

---

<div class="post-metadata">

**Author:** ![FALEN](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/falen/32/82754_2.png) [@FALEN](https://discuss.elastic.co/u/FALEN)\
**Post date:** [March 25, 2022, 9:03am UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/2 "2022-03-25T09:03:31Z")

</div>

> [@kubernetes87](#):
>
> `no_shard_available_action_exception`

Its more likely a elasticsearch problem, kibana just cant get proper data from elasticsearch to start up and let you login

Please share elasticsearch debug logs, so we can see which error you are getting. And you can also see status of elasticsearch by running healthcheck APIs

`GET /_cluster/health?pretty`

> **[Cluster health API | Elasticsearch Guide \[8.11\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/cluster-health.html)**

---

<div class="post-metadata">

**Author:** ![kubernetes87](https://avatars.discourse-cdn.com/v4/letter/k/c67d28/32.png) [@kubernetes87](https://discuss.elastic.co/u/kubernetes87)\
**Post date:** [March 25, 2022, 9:18am UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/3 "2022-03-25T09:18:20Z")

</div>

Thank you for your fast reply and the explanation.

When running healthcheck APIs I tried with the command but got no output.  
Then I tried curl [http://localhost:9200/\_cluster/health?pretty](http://localhost:9200/_cluster/health?pretty) and got the following:

```auto
{
  "cluster_name" : "elasticsearch",
  "status" : "red",
  "timed_out" : false,
  "number_of_nodes" : 1,
  "number_of_data_nodes" : 1,
  "active_primary_shards" : 18,
  "active_shards" : 18,
  "relocating_shards" : 0,
  "initializing_shards" : 0,
  "unassigned_shards" : 24,
  "delayed_unassigned_shards" : 0,
  "number_of_pending_tasks" : 0,
  "number_of_in_flight_fetch" : 0,
  "task_max_waiting_in_queue_millis" : 0,
  "active_shards_percent_as_number" : 42.857142857142854
}

```

Elasticsearch log

```auto

[2022-03-25T00:00:45,862][WARN][r.suppressed] [kibana] path: /.kibana_task_manager/_search, params: {size=1, index=.kibana_task_manager}
org.elasticsearch.action.search.SearchPhaseExecutionException: all shards failed
        at org.elasticsearch.action.search.AbstractSearchAsyncAction.onPhaseFailure(AbstractSearchAsyncAction.java:713) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.AbstractSearchAsyncAction.executeNextPhase(AbstractSearchAsyncAction.java:400) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.AbstractSearchAsyncAction.onPhaseDone(AbstractSearchAsyncAction.java:745) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.AbstractSearchAsyncAction.onShardFailure(AbstractSearchAsyncAction.java:497) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.AbstractSearchAsyncAction.performPhaseOnShard(AbstractSearchAsyncAction.java:308) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.AbstractSearchAsyncAction.run(AbstractSearchAsyncAction.java:244) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.AbstractSearchAsyncAction.executePhase(AbstractSearchAsyncAction.java:454) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.AbstractSearchAsyncAction.start(AbstractSearchAsyncAction.java:199) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.TransportSearchAction.executeSearch(TransportSearchAction.java:1048) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.TransportSearchAction.executeLocalSearch(TransportSearchAction.java:763) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.TransportSearchAction.lambda$executeRequest$6(TransportSearchAction.java:399) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.ActionListener$1.onResponse(ActionListener.java:136) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.index.query.Rewriteable.rewriteAndFetch(Rewriteable.java:112) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.index.query.Rewriteable.rewriteAndFetch(Rewriteable.java:77) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.TransportSearchAction.executeRequest(TransportSearchAction.java:487) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.TransportSearchAction.doExecute(TransportSearchAction.java:285) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.search.TransportSearchAction.doExecute(TransportSearchAction.java:101) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.support.TransportAction$RequestFilterChain.proceed(TransportAction.java:179) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.support.ActionFilter$Simple.apply(ActionFilter.java:53) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.support.TransportAction$RequestFilterChain.proceed(TransportAction.java:177) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.xpack.security.action.filter.SecurityActionFilter.apply(SecurityActionFilter.java:145) [x-pack-security-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.support.TransportAction$RequestFilterChain.proceed(TransportAction.java:177) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.support.TransportAction.execute(TransportAction.java:154) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.action.support.TransportAction.execute(TransportAction.java:82) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.client.node.NodeClient.executeLocally(NodeClient.java:95) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.rest.action.RestCancellableNodeClient.doExecute(RestCancellableNodeClient.java:81) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.client.support.AbstractClient.execute(AbstractClient.java:407) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.rest.action.search.RestSearchAction.lambda$prepareRequest$2(RestSearchAction.java:122) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.rest.BaseRestHandler.handleRequest(BaseRestHandler.java:109) [elasticsearch-7.17.1.jar:7.17.1]
        at org.elasticsearch.xpack.security.rest.SecurityRestFilter.handleRequest(SecurityRestFilter.java:105) [x-pack-security-7.17.1.jar:7.17.1]

```

---

<div class="post-metadata">

**Author:** ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)\
**Post date:** [March 25, 2022, 9:34am UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/4 "2022-03-25T09:34:21Z")

</div>

To me it looks like while doing the migrations you suffered from a resource issue leading to the reconnects... maybe giving it time to complete the task would bring Kibana up. it is usually timely and resource heavy.

---

<div class="post-metadata">

**Author:** ![kubernetes87](https://avatars.discourse-cdn.com/v4/letter/k/c67d28/32.png) [@kubernetes87](https://discuss.elastic.co/u/kubernetes87)\
**Post date:** [March 25, 2022, 9:45am UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/5 "2022-03-25T09:45:50Z")

</div>

Yes the kibana service is restarting often.

Do you think giving time over the weekend is enough?

Or should I maybe start again with updating with more RAM and CPU?  
Currently 8 GB RAM and 8 CPUs.

Are 8 GB RAM sufficient?

---

<div class="post-metadata">

**Author:** ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)\
**Post date:** [March 25, 2022, 9:52am UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/6 "2022-03-25T09:52:58Z")

</div>

That would be advisable, first check that Elasticsearch has upgrade properly, health and all the shards have been replicated. When there are no issues with Elasticsearch, then the kibana upgrade should be smoother.

Given the kibana restarts and failure you might need to take action on some of the indexes which are highlighted in the second link.

> **[Upgrade Elasticsearch | Elasticsearch Guide \[8.1\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-upgrade.html)**

> **[Upgrade Kibana | Kibana Guide \[8.1\] | Elastic](https://www.elastic.co/guide/en/kibana/current/upgrade.html)**
>
> A reference of the reporting settings administrators configure in kibana.yml.

---

<div class="post-metadata">

**Author:** ![kubernetes87](https://avatars.discourse-cdn.com/v4/letter/k/c67d28/32.png) [@kubernetes87](https://discuss.elastic.co/u/kubernetes87)\
**Post date:** [March 25, 2022, 10:04am UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/7 "2022-03-25T10:04:14Z")

</div>

So it is better not to do apt-get update/upgrade and do-release upgrade but updating independently from the OS right?

Thank you for the links. I will try again and tell about the - hopefully successful - result 🙂

Thank you for your help!

---

<div class="post-metadata">

**Author:** ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)\
**Post date:** [March 25, 2022, 10:14am UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/8 "2022-03-25T10:14:41Z")

</div>

I generally use the apt-get upgrades but some of the steps taken in the independent OS installations are good to follow in troubleshooting issues.

---

<div class="post-metadata">

**Author:** ![kubernetes87](https://avatars.discourse-cdn.com/v4/letter/k/c67d28/32.png) [@kubernetes87](https://discuss.elastic.co/u/kubernetes87)\
**Post date:** [March 25, 2022, 2:19pm UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/9 "2022-03-25T14:19:46Z")

</div>

I tried to do an upgrade with my original machine in the test environment.  
First I wanted to check that all services are running.

I am getting this.

Does that mean I have to check the indexes?

```auto
[2022-03-25T15:16:29,251][INFO][o.e.n.Node] [kibana] version[7.9.1], pid[23441], build[default/deb/083627f112ba94dffc1232e8b42b73492789ef91/2020-09-01T21:22:21.964974Z], OS[Linux/4.15.0-171-generic/amd64], JVM[AdoptOpenJDK/OpenJDK 64-Bit Server VM/14.0.1/14.0.1+7]
[2022-03-25T15:16:29,267][INFO][o.e.n.Node] [kibana] JVM home [/usr/share/elasticsearch/jdk]
[2022-03-25T15:16:29,267][INFO][o.e.n.Node] [kibana] JVM arguments [-Xshare:auto, -Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -XX:+ShowCodeDetailsInExceptionMessages, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dio.netty.allocator.numDirectArenas=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Djava.locale.providers=SPI,COMPAT, -Xms1g, -Xmx1g, -XX:+UseG1GC, -XX:G1ReservePercent=25, -XX:InitiatingHeapOccupancyPercent=30, -Djava.io.tmpdir=/tmp/elasticsearch-13605701858005843870, -XX:+HeapDumpOnOutOfMemoryError, -XX:HeapDumpPath=/var/lib/elasticsearch, -XX:ErrorFile=/var/log/elasticsearch/hs_err_pid%p.log, -Xlog:gc*,gc+age=trace,safepoint:file=/var/log/elasticsearch/gc.log:utctime,pid,tags:filecount=32,filesize=64m, -XX:MaxDirectMemorySize=536870912, -Des.path.home=/usr/share/elasticsearch, -Des.path.conf=/etc/elasticsearch, -Des.distribution.flavor=default, -Des.distribution.type=deb, -Des.bundled_jdk=true]
[2022-03-25T15:16:33,471][INFO][o.e.p.PluginsService] [kibana] loaded module [aggs-matrix-stats]
[2022-03-25T15:16:33,471][INFO][o.e.p.PluginsService] [kibana] loaded module [analysis-common]
[2022-03-25T15:16:33,471][INFO][o.e.p.PluginsService] [kibana] loaded module [constant-keyword]
[2022-03-25T15:16:33,472][INFO][o.e.p.PluginsService] [kibana] loaded module [flattened]
[2022-03-25T15:16:33,472][INFO][o.e.p.PluginsService] [kibana] loaded module [frozen-indices]
[2022-03-25T15:16:33,472][INFO][o.e.p.PluginsService] [kibana] loaded module [ingest-common]
[2022-03-25T15:16:33,472][INFO][o.e.p.PluginsService] [kibana] loaded module [ingest-geoip]
[2022-03-25T15:16:33,472][INFO][o.e.p.PluginsService] [kibana] loaded module [ingest-user-agent]
[2022-03-25T15:16:33,473][INFO][o.e.p.PluginsService] [kibana] loaded module [kibana]
[2022-03-25T15:16:33,473][INFO][o.e.p.PluginsService] [kibana] loaded module [lang-expression]
[2022-03-25T15:16:33,473][INFO][o.e.p.PluginsService] [kibana] loaded module [lang-mustache]
[2022-03-25T15:16:33,473][INFO][o.e.p.PluginsService] [kibana] loaded module [lang-painless]
[2022-03-25T15:16:33,473][INFO][o.e.p.PluginsService] [kibana] loaded module [mapper-extras]
[2022-03-25T15:16:33,473][INFO][o.e.p.PluginsService] [kibana] loaded module [parent-join]
[2022-03-25T15:16:33,473][INFO][o.e.p.PluginsService] [kibana] loaded module [percolator]
[2022-03-25T15:16:33,474][INFO][o.e.p.PluginsService] [kibana] loaded module [rank-eval]
[2022-03-25T15:16:33,474][INFO][o.e.p.PluginsService] [kibana] loaded module [reindex]
[2022-03-25T15:16:33,474][INFO][o.e.p.PluginsService] [kibana] loaded module [repository-url]
[2022-03-25T15:16:33,474][INFO][o.e.p.PluginsService] [kibana] loaded module [search-business-rules]
[2022-03-25T15:16:33,474][INFO][o.e.p.PluginsService] [kibana] loaded module [searchable-snapshots]
[2022-03-25T15:16:33,474][INFO][o.e.p.PluginsService] [kibana] loaded module [spatial]
[2022-03-25T15:16:33,475][INFO][o.e.p.PluginsService] [kibana] loaded module [systemd]
[2022-03-25T15:16:33,475][INFO][o.e.p.PluginsService] [kibana] loaded module [tasks]
[2022-03-25T15:16:33,475][INFO][o.e.p.PluginsService] [kibana] loaded module [transform]
[2022-03-25T15:16:33,475][INFO][o.e.p.PluginsService] [kibana] loaded module [transport-netty4]
[2022-03-25T15:16:33,475][INFO][o.e.p.PluginsService] [kibana] loaded module [vectors]
[2022-03-25T15:16:33,475][INFO][o.e.p.PluginsService] [kibana] loaded module [wildcard]
[2022-03-25T15:16:33,476][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-analytics]
[2022-03-25T15:16:33,476][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-async]
[2022-03-25T15:16:33,476][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-async-search]
[2022-03-25T15:16:33,476][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-autoscaling]
[2022-03-25T15:16:33,476][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-ccr]
[2022-03-25T15:16:33,476][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-core]
[2022-03-25T15:16:33,476][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-data-streams]
[2022-03-25T15:16:33,477][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-deprecation]
[2022-03-25T15:16:33,477][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-enrich]
[2022-03-25T15:16:33,477][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-eql]
[2022-03-25T15:16:33,477][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-graph]
[2022-03-25T15:16:33,477][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-identity-provider]
[2022-03-25T15:16:33,477][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-ilm]
[2022-03-25T15:16:33,477][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-logstash]
[2022-03-25T15:16:33,477][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-ml]
[2022-03-25T15:16:33,477][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-monitoring]
[2022-03-25T15:16:33,478][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-ql]
[2022-03-25T15:16:33,478][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-rollup]
[2022-03-25T15:16:33,478][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-security]
[2022-03-25T15:16:33,478][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-sql]
[2022-03-25T15:16:33,478][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-stack]
[2022-03-25T15:16:33,478][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-voting-only-node]
[2022-03-25T15:16:33,478][INFO][o.e.p.PluginsService] [kibana] loaded module [x-pack-watcher]
[2022-03-25T15:16:33,479][INFO][o.e.p.PluginsService] [kibana] no plugins loaded
[2022-03-25T15:16:33,553][INFO][o.e.e.NodeEnvironment] [kibana] using [1] data paths, mounts [[/mnt/Elasticsearch (//192.168.1.1/Kibana/elasticsearch)]], net usable_space [4.6tb], net total_space [5tb], types [cifs]
[2022-03-25T15:16:33,553][INFO][o.e.e.NodeEnvironment] [kibana] heap size [1gb], compressed ordinary object pointers [true]
[2022-03-25T15:16:35,315][ERROR][o.e.b.Bootstrap] [kibana] Exception
java.lang.IllegalArgumentException: Could not load codec 'Lucene87'. Did you forget to add lucene-backward-codecs.jar?
        at org.apache.lucene.index.SegmentInfos.readCodec(SegmentInfos.java:449) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:356) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:291) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:61) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:58) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:720) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:81) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:63) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.elasticsearch.gateway.PersistedClusterStateService.nodeMetadata(PersistedClusterStateService.java:262) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.env.NodeEnvironment.loadNodeMetadata(NodeEnvironment.java:408) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:329) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.node.Node.<init>(Node.java:344) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.node.Node.<init>(Node.java:277) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:227) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) [elasticsearch-cli-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.9.1.jar:7.9.1]
        Suppressed: org.apache.lucene.index.CorruptIndexException: checksum passed (a082e877). possibly transient resource issue, or a Lucene or JVM bug (resource=BufferedChecksumIndexInput(SimpleFSIndexInput(path="/mnt/Elasticsearch/elasticsearch/nodes/0/_state/segments_c5w")))
                at org.apache.lucene.codecs.CodecUtil.checkFooter(CodecUtil.java:466) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:434) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:291) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:61) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:58) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:720) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:81) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:63) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.elasticsearch.gateway.PersistedClusterStateService.nodeMetadata(PersistedClusterStateService.java:262) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.env.NodeEnvironment.loadNodeMetadata(NodeEnvironment.java:408) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:329) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.node.Node.<init>(Node.java:344) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.node.Node.<init>(Node.java:277) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:227) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) [elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) [elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) [elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) [elasticsearch-cli-7.9.1.jar:7.9.1]
                at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) [elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.9.1.jar:7.9.1]
Caused by: java.lang.IllegalArgumentException: An SPI class of type org.apache.lucene.codecs.Codec with name 'Lucene87' does not exist. You need to add the corresponding JAR file supporting this SPI to your classpath. The current classpath supports the following names: [Lucene70, Lucene80, Lucene84, Lucene86]
        at org.apache.lucene.util.NamedSPILoader.lookup(NamedSPILoader.java:116) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.codecs.Codec.forName(Codec.java:116) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.SegmentInfos.readCodec(SegmentInfos.java:445) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        ... 22 more
[2022-03-25T15:16:35,325][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [kibana] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: Could not load codec 'Lucene87'. Did you forget to add lucene-backward-codecs.jar?
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:174) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) ~[elasticsearch-cli-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.9.1.jar:7.9.1]
Caused by: java.lang.IllegalArgumentException: Could not load codec 'Lucene87'. Did you forget to add lucene-backward-codecs.jar?
        at org.apache.lucene.index.SegmentInfos.readCodec(SegmentInfos.java:449) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:356) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:291) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:61) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:58) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:720) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:81) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:63) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.elasticsearch.gateway.PersistedClusterStateService.nodeMetadata(PersistedClusterStateService.java:262) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.env.NodeEnvironment.loadNodeMetadata(NodeEnvironment.java:408) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:329) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.node.Node.<init>(Node.java:344) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.node.Node.<init>(Node.java:277) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:227) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) ~[elasticsearch-7.9.1.jar:7.9.1]
        ... 6 more
        Suppressed: org.apache.lucene.index.CorruptIndexException: checksum passed (a082e877). possibly transient resource issue, or a Lucene or JVM bug (resource=BufferedChecksumIndexInput(SimpleFSIndexInput(path="/mnt/Elasticsearch/elasticsearch/nodes/0/_state/segments_c5w")))
                at org.apache.lucene.codecs.CodecUtil.checkFooter(CodecUtil.java:466) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:434) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:291) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:61) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:58) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:720) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:81) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:63) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
                at org.elasticsearch.gateway.PersistedClusterStateService.nodeMetadata(PersistedClusterStateService.java:262) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.env.NodeEnvironment.loadNodeMetadata(NodeEnvironment.java:408) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:329) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.node.Node.<init>(Node.java:344) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.node.Node.<init>(Node.java:277) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:227) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) ~[elasticsearch-cli-7.9.1.jar:7.9.1]
                at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) ~[elasticsearch-7.9.1.jar:7.9.1]
                at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.9.1.jar:7.9.1]
Caused by: java.lang.IllegalArgumentException: An SPI class of type org.apache.lucene.codecs.Codec with name 'Lucene87' does not exist. You need to add the corresponding JAR file supporting this SPI to your classpath. The current classpath supports the following names: [Lucene70, Lucene80, Lucene84, Lucene86]
        at org.apache.lucene.util.NamedSPILoader.lookup(NamedSPILoader.java:116) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.codecs.Codec.forName(Codec.java:116) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.SegmentInfos.readCodec(SegmentInfos.java:445) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:356) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:291) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:61) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:58) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:720) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:81) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:63) ~[lucene-core-8.6.2.jar:8.6.2 016993b65e393b58246d54e8ddda9f56a453eb0e - ivera - 2020-08-26 10:53:36]
        at org.elasticsearch.gateway.PersistedClusterStateService.nodeMetadata(PersistedClusterStateService.java:262) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.env.NodeEnvironment.loadNodeMetadata(NodeEnvironment.java:408) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:329) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.node.Node.<init>(Node.java:344) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.node.Node.<init>(Node.java:277) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:227) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) ~[elasticsearch-7.9.1.jar:7.9.1]
        ... 6 more

```

---

<div class="post-metadata">

**Author:** ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)\
**Post date:** [March 25, 2022, 2:35pm UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/10 "2022-03-25T14:35:36Z")

</div>

Before checking Kibana... is Elasticsearch upgraded, working correctly and health ?

```auto
curl -X GET http://<localhost or IP address>:9200/_cluster/health?pretty -u username:password 

curl -X GET https://<localhost or IP address>:9200/_cluster/health?pretty -u username:password -k

```

---

<div class="post-metadata">

**Author:** ![kubernetes87](https://avatars.discourse-cdn.com/v4/letter/k/c67d28/32.png) [@kubernetes87](https://discuss.elastic.co/u/kubernetes87)\
**Post date:** [March 25, 2022, 2:37pm UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/11 "2022-03-25T14:37:14Z")

</div>

No I wanted to check before the upgrade if everything is working that I can upgrade Elasticsearch first.

Or should I ignore that ES-Service is not running and upgrade instead ES?

I wanted to use the Upgrade assistant  
[Upgrade to Elastic 8.1.1 | Elastic Installation and Upgrade Guide [8.1] | Elastic](https://www.elastic.co/guide/en/elastic-stack/8.1/upgrading-elastic-stack.html#prepare-to-upgrade)

---

<div class="post-metadata">

**Author:** ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)\
**Post date:** [March 25, 2022, 2:43pm UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/12 "2022-03-25T14:43:39Z")

</div>

If you are upgrading you need to upgrade Elasticsearch first and make sure it is working as that is where Kibana stores some of the data that defines your setup. Kibana will never work if Elasticsearch is unhealthy

---

<div class="post-metadata">

**Author:** ![kubernetes87](https://avatars.discourse-cdn.com/v4/letter/k/c67d28/32.png) [@kubernetes87](https://discuss.elastic.co/u/kubernetes87)\
**Post date:** [March 28, 2022, 11:46am UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/13 "2022-03-28T11:46:45Z")

</div>

Hello together,

I had a lot of trouble with the indices.

My further plan is a fresh installation of ElasticStack, Logstash and Kibana.

Thank you for your help 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 25, 2022, 11:47am UTC](https://discuss.elastic.co/t/error-accessing-kibana-after-upgrade/300677/14 "2022-04-25T11:47:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
