# Error Activating Self-Monitoring in ElasticSearch 7.10

**URL:** <https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-10/262616>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-monitoring\
**Created:** [January 29, 2021, 8:32am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-10/262616 "2021-01-29T08:32:48Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![IGNACIO\_RODERA\_TOBAL](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ignacio_rodera_tobal/32/55188_2.png) [@IGNACIO\_RODERA\_TOBAL](https://discuss.elastic.co/u/IGNACIO_RODERA_TOBAL)\
**Post date:** [January 29, 2021, 8:32am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-10/262616/1 "2021-01-29T08:32:48Z")

</div>

Hello all,  
I am setting up a new production environment with ElasticSearch version 7.10.  
At this moment we only have 2 servers running  
When I try to activate Self Monitoring I always get the same error:  
"We couldn't activate monitoring  
No monitoring data found. Try setting the time filter to "Last 1 hour" or check if data is available for a different time period.  
If data is in your cluster, your monitoring dashboards will show up here. "

A few seconds later I get the following error:  
"[illegal\_argument\_exception] unknown type for collapse field` cluster_uuid`, only keywords and numbers are accepted (and) [illegal\_argument\_exception] unknown type for collapse field `cluster_uuid`, only keywords and numbers are accepted: Check the Elasticsearch Monitoring cluster network connection or the load level of the nodes. "

The indices we have are:  
//  
GET \_cat / indices / .monitoring-en- \*  
green open .monitoring-en-7-2021.01.29 5EBtCwKCRtS3epUdWkxKJQ 1 1 80253 123984 135.4mb 66.4mb  
green open .monitoring-en-7-2021.01.28 h4l08hVMSK2zx9Z-LDuywQ 1 1 79520 117952 137.6mb 68.4mb

GET /.monitoring-es-7-2021.01.28/\_mapping/field/cluster\_uuid  
{  
".monitoring-en-7-2021.01.28": {  
"mappings": {  
"cluster\_uuid": {  
"full\_name": "cluster\_uuid",  
"mapping": {  
"cluster\_uuid": {  
"type": "text",  
"fields": {  
"keyword": {  
"type": "keyword",  
"ignore\_above": 256  
}  
}  
}  
}  
}  
}  
}  
}  
//

How can I fix this error? I have tried to clear the indices to see if they are generated correctly afterwards, and this has not solved the problem

What I don't understand is, why are these indices being generated in the wrong way?

For now we can lose the monitoring indices ...

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 1, 2021, 1:35am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-10/262616/2 "2021-02-01T01:35:11Z")

</div>

Welcome to our community! 😃

> [@IGNACIO\_RODERA\_TOBAL](#):
>
> When I try to activate Self Monitoring I always get the same error:

Can you elaborate a little more on what you are doing to activate this please?

---

<div class="post-metadata">

**Author:** ![IGNACIO\_RODERA\_TOBAL](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ignacio_rodera_tobal/32/55188_2.png) [@IGNACIO\_RODERA\_TOBAL](https://discuss.elastic.co/u/IGNACIO_RODERA_TOBAL)\
**Post date:** [February 3, 2021, 7:59am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-10/262616/3 "2021-02-03T07:59:00Z")

</div>

When I go to the Stack Monitoring in Kibana Menu:

 ![No_monit](https://us1.discourse-cdn.com/elastic/original/3X/8/b/8b12fdc23f565b37898d633b321b2c05c402c2cb.jpeg)

I go to Self Monittoring as I am doing in other environs:

 ![Self_Monitoring](https://us1.discourse-cdn.com/elastic/original/3X/b/f/bf075d23685d3e570072fa336f30f11c52ef487b.jpeg)

Then the error appears as I said in the previous mail.

```
`[illegal_argument_exception] unknown type for collapse field `cluster_uuid`, only keywords and numbers are accepted (and) [illegal_argument_exception] unknown type for collapse field `cluster_uuid`, only keywords and numbers are accepted (and) [illegal_argument_exception] unknown type for collapse field `cluster_uuid`, only keywords and numbers are accepted: Check the Elasticsearch Monitoring cluster network connection or the load level of the nodes.`

GET _cat / indices / .monitoring-en- *

```

green open .monitoring-en-7-2021.01.29 5EBtCwKCRtS3epUdWkxKJQ 1 1 80253 123984 135.4mb 66.4mb  
green open .monitoring-en-7-2021.01.28 h4l08hVMSK2zx9Z-LDuywQ 1 1 79520 117952 137.6mb 68.4mb

GET /.monitoring-es-7-2021.01.28/\_mapping/field/cluster\_uuid  
{  
".monitoring-en-7-2021.01.28": {  
"mappings": {  
"cluster\_uuid": {  
"full\_name": "cluster\_uuid",  
"mapping": {  
"cluster\_uuid": {  
"type": "text",  
"fields": {  
"keyword": {  
"type": "keyword",  
"ignore\_above": 256  
}  
}  
}  
}  
}  
}  
}  
}

What you need more?

---

<div class="post-metadata">

**Author:** ![IGNACIO\_RODERA\_TOBAL](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ignacio_rodera_tobal/32/55188_2.png) [@IGNACIO\_RODERA\_TOBAL](https://discuss.elastic.co/u/IGNACIO_RODERA_TOBAL)\
**Post date:** [February 4, 2021, 9:31am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-10/262616/4 "2021-02-04T09:31:04Z")

</div>

Sorry the problem was an index template, i deleted this template and all works fine...

Thanks all

Best Regards

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 4, 2021, 9:31am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-10/262616/5 "2021-03-04T09:31:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
