# Error Activating Self-Monitoring in ElasticSearch 7.17.3

**URL:** <https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-monitoring\
**Created:** [May 11, 2022, 10:33am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451 "2022-05-11T10:33:16Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![IMagalashvili](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/imagalashvili/32/105557_2.png) [@IMagalashvili](https://discuss.elastic.co/u/IMagalashvili)\
**Post date:** [May 11, 2022, 10:33am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451/1 "2022-05-11T10:33:16Z")

</div>

Hi, I have problem with Self-Monitoring in Elasticsearch 7.17.3.  
It worked correctly, but I changed Stting parameters with  
PUT 'http: // server:9200 /\_settings  
{  
"index": {  
"final\_pipeline": "geoip-info"  
}  
}  
My foult ☹

After I trying to fix it with:  
PUT http :// server:9200 /\_settings  
{  
"index": {  
"final\_pipeline": null  
}  
}

Filebeat/Heartbeat was restored, but self-monitoring is still not available.

I found one topic with issue like my and solution was to remove index template (monitoring-es), but it's a system template and I afraid to delete it )  
How can i fix this issue? How can I find what is problem witn Self Monitoring?

Elasticsearch 7.17.3 cluster with 3 data-nodes and 1 Kibana

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 11, 2022, 11:22pm UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451/2 "2022-05-11T23:22:49Z")

</div>

What do your Elasticsearch logs show?

---

<div class="post-metadata">

**Author:** ![IMagalashvili](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/imagalashvili/32/105557_2.png) [@IMagalashvili](https://discuss.elastic.co/u/IMagalashvili)\
**Post date:** [May 13, 2022, 6:29am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451/3 "2022-05-13T06:29:40Z")

</div>

[2022-05-13T00:00:00,374][WARN][o.e.x.m.MonitoringService] [tb-elk001.bee.mobitel.local] **monitoring execution failed**  
**org.Elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulks**  
at org.Elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.lambda$doFlush$0(ExportBulk.java:110) [x-pack-monitoring-7.17.3.jar:7.17.3]  
at org.Elasticsearch.action.ActionListener$1.onFailure(ActionListener.java:144) [Elasticsearch-7.17.3.jar:7.17.3]  
etc...  
**Caused by: org.Elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulk [default\_local]**  
... 101 more  
**Caused by: java.lang.IllegalStateException: There are no ingest nodes in this cluster, unable to forward request to an ingest node.**  
at org.Elasticsearch.action.ingest.IngestActionForwarder.randomIngestNode(IngestActionForwarder.java:52) ~[Elasticsearch-7.17.3.jar:7.17.3]  
at org.Elasticsearch.action.ingest.IngestActionForwarder.forwardIngestRequest(IngestActionForwarder.java:42) ~[Elasticsearch-7.17.3.jar:7.17.3]  
at org.Elasticsearch.action.bulk.TransportBulkAction.doInternalExecute(TransportBulkAction.java:244) ~[Elasticsearch-7.17.3.jar:7.17.3]  
... 92 more

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 16, 2022, 12:34am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451/4 "2022-05-16T00:34:46Z")

</div>

> [@IMagalashvili](#):
>
> There are no ingest nodes in this cluster, unable to forward request to an ingest node.

This would be worth checking. You can use the `_cat/nodes?v` API to check what roles your nodes have enabled.

---

<div class="post-metadata">

**Author:** ![IMagalashvili](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/imagalashvili/32/105557_2.png) [@IMagalashvili](https://discuss.elastic.co/u/IMagalashvili)\
**Post date:** [May 16, 2022, 9:06am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451/5 "2022-05-16T09:06:35Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/2/4/247e2a57a6026e2df1e653e919de7ada8e7cf0ee.png)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 16, 2022, 9:48am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451/6 "2022-05-16T09:48:01Z")

</div>

Please don't post pictures of text, logs or code. They are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them 🙂

---

<div class="post-metadata">

**Author:** ![IMagalashvili](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/imagalashvili/32/105557_2.png) [@IMagalashvili](https://discuss.elastic.co/u/IMagalashvili)\
**Post date:** [May 16, 2022, 9:50am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451/7 "2022-05-16T09:50:57Z")

</div>

Ok 🙂  
ip heap.percent ram.percent cpu load\_1m load\_5m load\_15m node.role master name  
x.x.x.223 58 98 0 0.16 0.18 0.12 dm - elk001  
x.x.x.115 17 82 0 0.00 0.01 0.05 lr - kibana  
x.x.x.224 36 97 0 0.10 0.04 0.05 dm \* elk002  
x.x.x.225 11 99 0 0.03 0.04 0.05 dm - elk003

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 16, 2022, 9:55am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451/8 "2022-05-16T09:55:15Z")

</div>

Thanks.

Have you explicitly set the node roles in the configs?

---

<div class="post-metadata">

**Author:** ![IMagalashvili](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/imagalashvili/32/105557_2.png) [@IMagalashvili](https://discuss.elastic.co/u/IMagalashvili)\
**Post date:** [May 16, 2022, 11:44am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451/9 "2022-05-16T11:44:26Z")

</div>

node.roles: [master, data] - elk001  
node.roles: [data, master] - elk002  
node.roles: [data, master] - elk003

kibana

node.name: kibana  
node.master: false  
node.data: false  
node.ingest: false

---

<div class="post-metadata">

**Author:** ![IMagalashvili](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/imagalashvili/32/105557_2.png) [@IMagalashvili](https://discuss.elastic.co/u/IMagalashvili)\
**Post date:** [May 19, 2022, 10:28am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451/10 "2022-05-19T10:28:23Z")

</div>

Problem was solved after setting up metricbeat monitoring.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 16, 2022, 10:28am UTC](https://discuss.elastic.co/t/error-activating-self-monitoring-in-elasticsearch-7-17-3/304451/11 "2022-06-16T10:28:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
