# Error after setting up xpack security , elasticsearch is not starting after anbaling xpack

**URL:** <https://discuss.elastic.co/t/error-after-setting-up-xpack-security-elasticsearch-is-not-starting-after-anbaling-xpack/256699>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [November 25, 2020, 5:53pm UTC](https://discuss.elastic.co/t/error-after-setting-up-xpack-security-elasticsearch-is-not-starting-after-anbaling-xpack/256699 "2020-11-25T17:53:58Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![siddesh\_patke](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/siddesh_patke/32/79716_2.png) [@siddesh\_patke](https://discuss.elastic.co/u/siddesh_patke)\
**Post date:** [November 25, 2020, 5:53pm UTC](https://discuss.elastic.co/t/error-after-setting-up-xpack-security-elasticsearch-is-not-starting-after-anbaling-xpack/256699/1 "2020-11-25T17:53:58Z")

</div>

tail -30 /var/log/elasticsearch/elkstack.log ---- LOg Error

```
    at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:227) ~[elasticsearch-7.10.0.jar:7.10.0]
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227) ~[ela sticsearch-7.10.0.jar:7.10.0]
    at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) [elast icsearch-7.10.0.jar:7.10.0]
    at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170 ) [elasticsearch-7.10.0.jar:7.10.0]
    at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java: 161) [elasticsearch-7.10.0.jar:7.10.0]
    at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwar eCommand.java:86) [elasticsearch-7.10.0.jar:7.10.0]
    at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:1 27) [elasticsearch-cli-7.10.0.jar:7.10.0]
    at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cl i-7.10.0.jar:7.10.0]
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126 ) [elasticsearch-7.10.0.jar:7.10.0]
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.10.0.jar:7.10.0]

```

[2020-11-25T17:22:28,021][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [e lk-wms01] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException : setting [cluster.initial\_master\_nodes] is not allowed when [discovery.type] is set to [single-node]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:174 ) ~[elasticsearch-7.10.0.jar:7.10.0]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java: 161) ~[elasticsearch-7.10.0.jar:7.10.0]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwar eCommand.java:86) ~[elasticsearch-7.10.0.jar:7.10.0]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:1 27) ~[elasticsearch-cli-7.10.0.jar:7.10.0]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-c li-7.10.0.jar:7.10.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126 ) ~[elasticsearch-7.10.0.jar:7.10.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.10.0.jar:7.10.0]  
Caused by: java.lang.IllegalArgumentException: setting [cluster.initial\_master\_n odes] is not allowed when [discovery.type] is set to [single-node]  
at org.elasticsearch.cluster.coordination.ClusterBootstrapService. (ClusterBootstrapService.java:86) ~[elasticsearch-7.10.0.jar:7.10.0]  
at org.elasticsearch.cluster.coordination.Coordinator.(Coordinator .java:203) ~[elasticsearch-7.10.0.jar:7.10.0]  
at org.elasticsearch.discovery.DiscoveryModule.(DiscoveryModule.ja va:157) ~[elasticsearch-7.10.0.jar:7.10.0]  
at org.elasticsearch.node.Node.(Node.java:615) ~[elasticsearch-7.1 0.0.jar:7.10.0]  
at org.elasticsearch.node.Node.(Node.java:289) ~[elasticsearch-7.1 0.0.jar:7.10.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:227) ~[elasticsearch-7.10.0.jar:7.10.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227) ~[ela sticsearch-7.10.0.jar:7.10.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) ~[elas ticsearch-7.10.0.jar:7.10.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170 ) ~[elasticsearch-7.10.0.jar:7.10.0]

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 30, 2020, 4:50am UTC](https://discuss.elastic.co/t/error-after-setting-up-xpack-security-elasticsearch-is-not-starting-after-anbaling-xpack/256699/2 "2020-11-30T04:50:57Z")

</div>

Welcome to our community! 😃  
Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you.  
If you've changed settings, then including what you have is also very helpful.

> [@siddesh\_patke](#):
>
> setting [cluster.initial\_master\_nodes] is not allowed when [discovery.type] is set to [single-node]

That seems pretty relevant to me.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 28, 2020, 4:51am UTC](https://discuss.elastic.co/t/error-after-setting-up-xpack-security-elasticsearch-is-not-starting-after-anbaling-xpack/256699/3 "2020-12-28T04:51:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
