# Error after update from 1.7.5 to 2.3.2

**URL:** <https://discuss.elastic.co/t/error-after-update-from-1-7-5-to-2-3-2/52878>\
**Category:** Elasticsearch\
**Created:** [June 15, 2016, 2:51pm UTC](https://discuss.elastic.co/t/error-after-update-from-1-7-5-to-2-3-2/52878 "2016-06-15T14:51:10Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![cterron](https://avatars.discourse-cdn.com/v4/letter/c/ccd318/32.png) [@cterron](https://discuss.elastic.co/u/cterron)\
**Post date:** [June 15, 2016, 2:51pm UTC](https://discuss.elastic.co/t/error-after-update-from-1-7-5-to-2-3-2/52878/1 "2016-06-15T14:51:10Z")

</div>

I have a elasticsearch cluster running the 1.7.5 version. I've updated the cluster to Elasticsearch 2.3.2. The system works: Events are inserted, can query Elasticsearch, but I see this error in the logs:

> ```
> [2016-06-15 14:43:04,330][WARN][index.warmer] [ip-10-0-0-222-avos] [logs-2016-06-15-23][0] failed to warm-up global ordinals for [message.has_alarm]
> java.lang.ClassCastException: org.elasticsearch.index.fielddata.plain.PackedArrayIndexFieldData cannot be cast to org.elasticsearch.index.fielddata.IndexFieldData$Global
> at org.elasticsearch.search.SearchService$FieldDataWarmer$3.run(SearchService.java:1104)
> at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
> at java.lang.Thread.run(Thread.java:745)
> 
> ```

This is a warning message that I can ignore or is better to investigate the issue. The problem is that this is an old index with eager\_global\_ordinals enabled in a boolean field. This can be done in the 1.7.5 but no in 2.3.2.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [June 16, 2016, 1:19am UTC](https://discuss.elastic.co/t/error-after-update-from-1-7-5-to-2-3-2/52878/2 "2016-06-16T01:19:39Z")

</div>

Ideally you should fix it by reindexing, but given it is a warning only you can probably live with it.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:43pm UTC](https://discuss.elastic.co/t/error-after-update-from-1-7-5-to-2-3-2/52878/3 "2017-07-05T22:43:32Z")

</div>


