# Error after upgrading to 7.15

**URL:** <https://discuss.elastic.co/t/error-after-upgrading-to-7-15/285890>\
**Category:** Elasticsearch\
**Created:** [October 5, 2021, 7:33am UTC](https://discuss.elastic.co/t/error-after-upgrading-to-7-15/285890 "2021-10-05T07:33:09Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mads\_Lundegaard](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mads_lundegaard/32/82423_2.png) [@Mads\_Lundegaard](https://discuss.elastic.co/u/Mads_Lundegaard)\
**Post date:** [October 5, 2021, 7:33am UTC](https://discuss.elastic.co/t/error-after-upgrading-to-7-15/285890/1 "2021-10-05T07:33:10Z")

</div>

I am getting errors after I upgraded my client from 7.13.4 to 7.15. I suspect this is due to incompatible versions between server and client, but I am not sure. I tried upgrading the server, running in AWS but could not find a update. All help is appreciated!

Here is part of my stacktrace:  
`org.elasticsearch.ElasticsearchException: Invalid or missing build flavor [oss]\n\tat org.elasticsearch.client.RestHighLevelClient.performClientRequest(RestHighLevelClient.java:2084)\n\tat org.elasticsearch.client.RestHighLevelClient.internalPerformRequest(RestHighLevelClient.java:1732)\n\tat org.elasticsearch.client.RestHighLevelClient.performRequest(RestHighLevelClient.java:1702)\n\tat org.elasticsearch.client.RestHighLevelClient.performRequestAndParseEntity(RestHighLevelClient.java:1672)\n\tat org.elasticsearch.client.RestHighLevelClient.search(RestHighLevelClient.java:1128)\n\tat`

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [October 5, 2021, 7:43am UTC](https://discuss.elastic.co/t/error-after-upgrading-to-7-15/285890/2 "2021-10-05T07:43:55Z")

</div>

> [@Mads\_Lundegaard](#):
>
> running in AWS

Do you mean you're using [AWS OpenSearch](https://aws.amazon.com/blogs/aws/amazon-elasticsearch-service-is-now-amazon-opensearch-service-and-supports-opensearch-10/)? If so, that service is a fork of Elasticsearch that isn't 100% compatible, you'll need to use an OpenSearch-specific client. Alternatively if you want a managed Elasticsearch service you can use [https://cloud.elastic.co/](https://cloud.elastic.co/).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 5, 2021, 7:45am UTC](https://discuss.elastic.co/t/error-after-upgrading-to-7-15/285890/3 "2021-10-05T07:45:08Z")

</div>

Welcome!

You should use the same client version as the server.

I believe that your server is running an older version, may be 7.10.2 ?

Otherwise upgrade the server to 7.15.0, which is a much better approach. If you are running on EC2, you will need to use the default distribution from 7.11.

---

<div class="post-metadata">

**Author:** ![Mads\_Lundegaard](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mads_lundegaard/32/82423_2.png) [@Mads\_Lundegaard](https://discuss.elastic.co/u/Mads_Lundegaard)\
**Post date:** [October 5, 2021, 7:51am UTC](https://discuss.elastic.co/t/error-after-upgrading-to-7-15/285890/4 "2021-10-05T07:51:03Z")

</div>

Thanks @dadoonet!  
I am using 7.10, but the problem is that is seems that I am not able to upgrade to 7.15.0 in AWS OpenSearch portal, even though I am using Elasticsearch... But as far as I understand, the issue I am having is caused by incompatible server and client?

---

<div class="post-metadata">

**Author:** ![Mads\_Lundegaard](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mads_lundegaard/32/82423_2.png) [@Mads\_Lundegaard](https://discuss.elastic.co/u/Mads_Lundegaard)\
**Post date:** [October 5, 2021, 7:54am UTC](https://discuss.elastic.co/t/error-after-upgrading-to-7-15/285890/5 "2021-10-05T07:54:00Z")

</div>

The server is hosted in AWS OpenSearch, but I am using Elasticsearch... If that made sense? In AWS OpenSearch you can choose between OpenSearch and Elasticsearch. The problem is that the newest version available in the AWS OpenSearch portal is 7.10.... Which as far as I understand, is an old and uncompatible version with the 7.15 client?

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [October 5, 2021, 7:56am UTC](https://discuss.elastic.co/t/error-after-upgrading-to-7-15/285890/6 "2021-10-05T07:56:16Z")

</div>

> [@Mads\_Lundegaard](#):
>
> The server is hosted in AWS OpenSearch, but I am using Elasticsearch... If that made sense?

It doesn't, unfortunately. Even back in 7.10 the AWS service was running a fork, although it was confusingly still called Elasticsearch. Thankfully it is being renamed so eventually the confusion will go away.

You could carry on using the 7.10 Elasticsearch client I think, it'll mostly work with both versions, but it won't work if the client has a newer version than the server.

---

<div class="post-metadata">

**Author:** ![Mads\_Lundegaard](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mads_lundegaard/32/82423_2.png) [@Mads\_Lundegaard](https://discuss.elastic.co/u/Mads_Lundegaard)\
**Post date:** [October 5, 2021, 8:22am UTC](https://discuss.elastic.co/t/error-after-upgrading-to-7-15/285890/7 "2021-10-05T08:22:12Z")

</div>

Okay, so in conclusion: We can either switch to a managed Elasticsearch or keep using the version we do right now.

Thanks a lot for the help, I really appreciate it!

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 5, 2021, 9:13am UTC](https://discuss.elastic.co/t/error-after-upgrading-to-7-15/285890/8 "2021-10-05T09:13:49Z")

</div>

> [@Mads\_Lundegaard](#):
>
> Okay, so in conclusion: We can either switch to a managed Elasticsearch or keep using the version we do right now.

Have a look at [Cloud by Elastic](https://www.elastic.co/cloud), also available if needed from [AWS Marketplace](https://aws.amazon.com/marketplace/pp/Elasticsearch-Inc-Elasticsearch-Service-on-Elastic/B01N6YCISK), [Azure Marketplace](https://azuremarketplace.microsoft.com/en-us/marketplace/apps/elastic.ec-azure?tab=Overview) and [Google Cloud Marketplace](https://console.cloud.google.com/marketplace/details/endpoints/elasticsearch-service.gcpmarketplace.elastic.co).

Cloud by elastic is one way to have access to **all features** , all managed by us. Think about what is there yet like Security, Monitoring, Reporting, SQL, Canvas, Maps UI, Alerting and built-in solutions named [Observability](https://www.elastic.co/observability), [Security](https://www.elastic.co/security), [Enterprise Search](https://www.elastic.co/enterprise-search) and what is coming next 🙂 ...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 2, 2021, 9:14am UTC](https://discuss.elastic.co/t/error-after-upgrading-to-7-15/285890/9 "2021-11-02T09:14:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
